STEPS TO SET UP A K-12 SCHOOL IN MAPLEWOOD

IMPORTANT NOTES - PLEASE READ FIRST:

1- SYSTEM DATE WHILE DOING SETUPS: Itis strongly recommended to set the system date using File - Change Date to
the first day in the calendar (first day of school for students) especially when working with student timetables. This
way any class that gets added to a student's timetable will have an Add date of the first day of school. If the class Add
date is later than the first day of school, then no attendance can be recorded between the first day of school and the Add
date. The Add date can be cleared afterwards but this means more work.

2 - CALENDAR START DATE: the first available date in the Calendar should be the first day of school for students. To
_ The first date in the calendar that is not greyed out is the first

day of school for the current year. Ensure that date is correct. See Section 3 of this document for more details.

Log in first

First get yourself logged in, then start working on tasks listed in this document. If you have forgotten your password,
please contact one of the SIS Coordinators or your IT Program Coordinator for assistance. They can have your password
reset within a few hours.

How to login ona PC | How to login on a Mac
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1. UPDATE STAFF LIST AND PRINT LIST OF USER ACCOUNTS
Update staff records

Newly arriving staff need to be added to the system and leaving staff need to be removed if you have not already done
this in the previous spring.

Quick steps for adding staff: Go to Staff -> Add New Staff. Fill in name, employee number (school code + four digit
sequential number, e.g. 0580001), Teacher Certification Number and Gender. Use Role =T for teachers, S for Secretaries
and P for Principals. Click OK.

Quick steps for removing staff: Go to Staff -> Staff Records and search for the staff member (type one letter of last
name). Double-click on the staff member to open his/her Staff Record. Please note that you cannot remove a teacher
who is assigned to a class or homeroom; you may have to un-assign them from a class or homeroom at File -> School
Setup -> Rooms/Homerooms or File -> School Setup -> Classes. Finally you can go to the Employment tab and click the
Edit button. After that, click the Deleted (Ret./Trans.) radio button to remove the teacher, then click OK.

Additional notes on removing staff:

e If you already removed staff in the previous spring, you probably marked the staff members as “This year only”,
which caused those staff members (the same way it does with students) become Past Staff at the end of the
previous school year. As a result, they will no longer show up in the system in the fall.

e If you are removing current staff, ensure you do not permanently remove staff (there is a checkbox for it) from
Maplewood as they need to become part of the historical data we retain year to year

Detailed steps: How to Add or Delete Staff

Print a list of connectEd user accounts for your teachers

Once finished adding and removing staff members, it is recommended to print out a list of connectEd user accounts for
the teachers. That list will show usernames for everybody and, additionally, passwords for completely new teachers who
have never logged in before.

Detailed steps: How to print a list of connectEd accounts
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http://nunavutsis.wikispaces.com/file/view/How%20to%20Print%20a%20List%20of%20connectEd%20Teacher%20Accounts.pdf/445475956/How%20to%20Print%20a%20List%20of%20connectEd%20Teacher%20Accounts.pdf

2. SET UP SCHOOL CALENDAR
Verify Calendar start and end dates

Go to File -> School Setup -> Calendar -> Edit. The first available date in the Calendar should be the first day of school
for students. The first date in the calendar that is not greyed out is the first day of school for the current year. Ensure
that date is correct. Also check the last day in the Calendar in a similar manner.

Add holidays, professional development and in-service days

We have already put national statutory holidays into the calendar. Please add local holidays, Professional Development
(PD) and in-service days to your school calendar. Those days will be removed from students’ possible days and no
attendance collection is expected on those days.

The blue date is the currently selected date (September 3 below). To set PD days, select the date by clicking it and then
click "Board" at the bottom. That will make that day a Board (PD) day (:JX8]d). Put in all PD/in-service days and holidays
(INI9). Any colorful day in the calendar means "no school for students" and reduces their possible days.

Once you close the Calendar, it will ask you to save the changes.

iJSchunl Calendar 2012-2013 - Inuksuk High School E3
Fle Edt Help Check that the first and last
July 2012 August 2012 September 2012 October 2012 available dates in the
Sum | Mon| Tue | Wwed| Thu | Fri | Sat | Sum | Mon| Tue | Wed| Tho | Fri | Sat | Sum | Maon| Tue | w'ed| Tho | Fri | Sat | Sum | Mon| Tue | Wed| Tha | Fri | Sat Calendar are the flrSt and
1le|s|efs[e]r HEER 1 12 3 last day of school for
AR EREREEEBRERERE:: BEHBEEE - BEE students
sl | m]e|wlalales|w]es]ea]e]alo]nz]a]uw] salxela ’
BIEIEEEEEE D o 23 5 g 18 | 20 | 2l | 2= | =i | 22|25 | 24 | 25 | 26 | 2
EIESE (AEIE) 30| 3 2% | 24 | 2% | 26 | 27 |28 | 23 |22 | 23 | 30| & In this example, August 27 is
o the first day and June 20 last.
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1 (2] = 1 5
a(s|efli|as|alw|a|ls|a|s]e|i]la]e|lr]a|alw|[n]|r]s
KN - I RN R L I To make a date a Holiday, first
% |13 |20 | 2 HENEEEE AR . .
prn P e e e o click the day in the Calendar so

25 | 26 | 27 | 28
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March 2013 April 2013 May 2013 June 2013 click the pink [Ty button.
Sum | Mon| Tue |ed| Thu | Fri | Sat | Sum | Men| Tus |Wed| Thu | Fri | Sat | Sum | Mon| Tue |Wed| Thu | Fri | Sat | Sum | Mon| Tus | %ed| Tha | Frig Sat Then C“Ck on some Other date
L Z - L T /AR and you will see that how the
a|la|ls|e|r|s|a]r|s|a|w|n|le|[w]|s|e|7|s|a|lw|n|ez]|a|]a|s]|sifi| = )
o[ 1 [ 12 (13 [ 14 [ 15[ 16 |14 | 15 |6 | 17 |18 |13 | 20|12 [ 13[4 |15 |16 | W[ 5| 2| 10]| 1|12 4 [ 15 date has changed to pink.
7|18 |19 |20 |21 |22 | 23 |21 |22 |23 |24 | 25|25 | 27| 3 E oz |es o | e[| |22 =
a4 | a0 A 25 |24 | 25 | Nl | 2o
31 . | day button should be
2 = : used for PD days.
M il # Special Grant Day Bnard Bemove | Optiohs... | Dahe |
[ \ | 07/28/2014 [11:35 AM e is reserved for
\ unexpected closures. You
Half day closures should not need to use it at

this point.

Half day closures cannot be handled in the calendar so do not worry about those yet.

Half day closures are handled using the Excursions feature of Maplewood. Link: How to use Excursions to Set Attendance

Exam Days (YELLOW)

Exam Days will also remove that day from the possible days for students. Avoid using Exam day altogether. If you feel
that you must use them, please contact the SIS Coordinators first.
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3. SET SEMESTER DATES AND REPORTING TERM DATES

If your school uses semesters, then you have to set the date for when your semester one ends and semester two starts.
Additionally, you need to set your reporting term dates (typically three or four reporting periods) for report cards. The
reporting term dates may or may not coincide with your semester dates.

Setting the reporting term dates will ensure that attendance totals printed on the report cards are collected for the
correct range of dates.

Quick steps for setting semester dates: Go to File -> School Setup -> Calendar -> Edit. Once the Calendar is open, go to
the Edit menu and click on Semesters. This option will be grayed out if you are not using semesters. Colorful areas
represent semesters. Click-and-drag the semester end point to the appropriate date. Click OK and save the Calendar.

Quick steps for setting reporting term dates: go to Marks -> Topic-Based Marks -> Define Terms. Edit the listed
reporting terms by selecting the term and clicking Edit. Use the date picker in the Edit window to stet both the start and
the end date for the reporting term.

Note: it is a common mistake to forget to check the YEAR in the date. Please also check the YEAR when setting the
reporting term start and end dates. If you are lucky, the SIS Coordinators have already advanced the year portion of
the dates for you.

Notes on term identifiers:

e First (SEC), Second (SEC), Third (SEC) and Fourth (SEC) are reporting terms for grades 10-12
e Term 1 (ELEM), Term 2 (ELEM) and Term 3 (ELEM) reporting term for full-year classes in grades K-9.

Detailed steps: How to Set Semester and Reporting Term Dates
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4. ASSIGN STUDENTS TO HOMEROOMS

Next, assign students to Homerooms if that has not already been completed in the previous spring. Normally only junior
high grades are assigned to homerooms in order to provide a grouping for them for homeroom AM/PM attendance
collection. In senior high grades (10-12), schools must do period-by-period attendance, therefore homerooms are not
required, but you can still assign senior high students to homerooms if you want to use homerooms for example for
communications in the mornings.

Detailed steps: How to Assign Homerooms

After completing Homeroom assignments, verify the homeroom lists by printing them:

Detailed steps: How to Print Homeroom Lists
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5. REVIEW AND EDIT CLASSES FILE

Go to File -> School Setup -> Classes to open the Classes File. The Classes File defines who is teaching what and when at
your school. It is the most important area to set up.

Review the Classes File completely and edit entries to change the teachers or other information on the class.
Add entries as necessary. Delete unnecessary entries to keep things clean.

Interpret each class in the Classes File as “this subject or course will be taught and marked by this teacher.” Each class
is specific to a teacher, a group of students and a subject or course being offered.

Typical entries in the Classes File look like this:

Course Code Semester/Term Pattern Day/Period Pattern Teacher Occupancy
7000MATa Full Year Floater Esther Green 24/30
NRC1001a Semester 1 Block 1 Agnes White 21/30
NRC1001b Semester 2 Block 2 Shaniat Wain 20/30
MAT1793a Semester 1 Block 2 Arnold Schwein 17/30
WLD1010a Semester 2 Floater Lisabeth Qayaq 5/30

Above, NRC1001a and NRC100b are two sections of Aulajaaqtut 10 differentiated by section letters a and b. Separate
sections are required when a class is taught either at a different time, by a different teacher, or to a different group of
kids.

Below is an explanation of the most important columns in the Classes File:

Column Explanation

Course Code Defines the course code taught. Use the Approved Course List to look up senior high course codes (ask
for a PDF list if needed). 7000MATa is an example of a course code for grade seven mathematics. You
can see an explanation of K-9 course codes here: K-9 Course Codes

Semester/Term Pattern Defines the duration of the class, e.g. Full Year or Semester 1 or Semester 2. (The actual semester
dates are set earlier in this document.)

Day/Period Pattern Defines which cycle days and periods the class takes place in, for example “Block 1” could refer to
“Periods 1 and 2 of every cycle day”. The Day/Period patterns are created and named individually
depending on school. SIS Coordinators can set them up for youl Floater pattern means ‘no timetable
has been assigned to this class’ and is used with CTS modules and often but not always with junior

high classes.
Teacher The teacher of the class
Occupancy Shows how many students have been assigned to the class (5 out of max 30 students in WLD1010a)

On the use of Special Schedule

If your school does not have patterned timetables and class schedules appear more random, then you should use Special
Schedule to timetable your classes:

Detailed steps on the use of Special Schedule: How to Construct a Class Using Special Schedule
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What classes should | timetable?

Timetabling means defining the specific weekly timetable for the class by using Patterns (Semester/Term Pattern and
Day/Period Pattern columns in the Classes File) or Special Schedule.

e C(Classes are timetabled in order to enable attendance collection for them. That is the primary reason for
timetabling.

o All grade 10-12 classes have to be timetabled because attendance is collected per-class

e K-9classes are typically not timetabled; instead, they are set as “floaters” (= no timetable). This is because
normally attendance is not taken for every class in junior high; AM/PM homeroom attendance is more common
(see Section 6: Set Up Homeroom Attendance for K-9)

e |f you want to do class-by-class attendance in junior high, then just timetable all junior high classes
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6. SET UP HOMEROOM ATTENDANCE FOR K-9

In order to do AM/PM attendance in K-9 grades, fake attendance classes need to be created in the Classes File for each
homeroom. They use course codes such as ATTAM1, ATTPM2, ATTAM2, ATTPM2, the number indicating the grade. The
attendance classes will act as a vehicle for homeroom-style attendance collection in a K-12 school. The attendance
classes have to be assigned a schedule in the Classes File. All other classes for that grade must be set as “floaters” (= no
timetable) to avoid timetable conflicts. The word "fake" refers to the fact that no mark is given for these classes by the
teacher; these courses are not “taught”.

If you want to do class-by-class attendance for a K-9 grade, then you do not need to do this step — simply timetable all
the classes in that grade instead. Remember: a class is only timetabled if attendance will be collected during that class.

Example fake attendance classes in the Classes File for K-9:

B
_lol x|
e Edit SeNrch Help
Sem. 1 Term 1 \Pay1.2.3.456 Per. 1,234 5E Include Classes with Unassigned Patterns: Yes
Clazz Code \ | Sem./Ter... | Sem./Ter... | [ap/Per. ... | Day/FerP.. | Teachg;l
ATTAMT a Full year Full year Attendance A Panigay.
ATTAMZ a Full year Full year Attendance A Ittunga, In d K'12 SChOOI, AM/PM attendance for K'9
ATTAMI a Full year Full year Attendance A Meevear 3
ATTAMS 3 Full year Full year Attendance  AM Dleekat: must be set up using attendance classes for
ATTAME a Full year Full year Attendance A Etunga,
ATTAME a Full year Full year Attendance A K.avanag H
ATTAMY a Full year Full year Attendance A Thomszot eaCh homeroom (your SChOOl may reqUIre a
ATTAMY b Full year Full year Attendance A Lee, Jor d ff f d I
ATTAMS a Fulyear  Fulyesr  Afendance  AM Pike, ifferent set of attendance classes
ATTAMY a Full year Full year Attendance  AM Hill, Geo .
ATTPMI & Full year Fulyear  Attendance PM Panigay. ~ depending on your homerooms). SIS
ATTPMZ a Full year Full year Attendance P Itunga,
ATTPM3 a Full year Full year Attendance P Meevear i
ATTPMA a Full year Full year Attendance P Oleekat: Coord|nator$ can help you Set them Up.
ATTPME a Full year Full year Attendance  PM Etunga,
ATTPME a Full year Full year Attendance P K.avanag .
ATTPMT & Full year Full year Attendance  PM Thormso Students are assigned to these classes based
ATTPMY b Full year Full year Attendance P Lee, Jor
ATTPME a Full year Full year Attendance P Fike, v H
ATTPMI a Full year Full year Attendance  PM Hill, Geo on thelr homeroom'
ATTPME. a Full year Full year Attendance P Eetooloc +
I 3
Aeld Edt |  Delete Biint Dore |
\ /
N/ -

Timetabling fake attendance classes

An “Attendance AM” class will span the first morning period and an “Attendance PM” class will span the first afternoon
period of every cycle day. SIS support can help you set up this schedule using "AM" and "PM" patterns.

Who teaches the fake attendance class?

The homeroom teacher should be set as the teacher for the fake attendance classes since they are expected to do
attendance on the students in the homeroom.

Assigning students to fake attendance classes

If you have completed assigning students to Homerooms already, then simply go to Students -> Edit Timetables ->
Assign Timetables by Group, then pick Homeroom as the assigning method, and multi-select (press CTRL key and click
with mouse) the two attendance classes for that Homeroom. Then click OK. In the next step, check the "Individual
Homeroom" box and then pick the correct homeroom for the dropdown menu. Then click Start.
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7. SET UP CTS CLASSES USING MASTER CLASSES

CTS courses or modules are typically taught in a manner where several modules are taught at the same time to a group
of students. As a result, individual students may complete a different number of CTS courses during the semester.

The first intuition would be to timetable all those individual CTS modules and then assign them to the students. But
this will cause timetable conflicts. CTS Master Classes are a design to avoid these conflicts.

Instead of timetabling all those individual modules so that you can do attendance for them, you have to set CTS modules
as “floaters” (= no timetable) and instead create a single, timetabled CTS Master Class for attendance collection. When
the CTS Master Class is assigned to the group of students, it reserves a spot in their timetable. Next, when the CTS
"floaters" are added, they go in without a problem as they have no timetable and cannot conflict with anything.

The CTS Master Class is used purely for doing attendance but no mark is expected for it. The students must be assigned
both to the CTS Master Class, and the CTS classes that they are taking.

An example on CTS setups:

e 10 students are taking "Wildlife CTS" on cycle day 1, period 1 in Semester 1
o All of them take WLD1010. Six take WLD2040. Another four take WLD3020.
e (TS setup would then be:
e Create Wildlife CTS Master class (WLD00O01a) for collecting attendance for the group. Assign all 10 students to
it.
o  Wildlife CTS Master (WLD0001a) is given the timetable of cycle day 1, period 1, semester 1 in the Classes File
using Patterns or Special Schedule
e WLD1010 s set as a “floater” and all ten students are assigned to it
e  WLD2040 is set as a “floater” and the six students are assigned to it
e  WLD3020is set as a “floater” and the four students are assigned to it
e After this, the setup is complete

Detailed steps: How to Set Up CTS Classes Using a Master Class
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8. PRINT TEACHER TIMETABLES
In order to see how your timetabling work is taking effect, print teacher timetables.

Quick steps: Go to Staff -> Print Teacher Timetables. Pick a semester. Click on Setup to check the box for Print Grid Lines
and to tweak other print options and click OK to accept the options. Finally, click View to produce the teacher timetables
for a selected group of teachers.

Detailed steps: How to Print Teacher Timetables
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9. ASSIGN STUDENTS TO CLASSES

Once you have assigned homerooms and the teacher timetables look correct, you can assign students to their classes.
Without doing this step, teachers cannot do attendance or give marks to students as the students do not have any
timetables assigned to them.

Quick steps for assigning classes by grade of homeroom: If you are giving classes to all the students in a Homeroom or
in a certain grade, go to Students -> Edit Timetables -> Assign Timetables by Group. If doing it by grade, select Grade on
the left. If by Homeroom, select Homeroom on the left. Then multi-select the classes you wish to assign by control-
clicking them (push CTRL key on keyboard and click with the mouse). Once ready, click OK. In the next step, check the
box for "Individual homeroom" and then select the Homeroom from the dropdown if using the Homeroom method. If
using the Grade method, pick the grade from the dropdown. Then click Start.

Quick steps for hand-picking students to a class: if the group of students taking the class needs to be hand-picked, then
go to Students -> Edit Timetables -> Assign Timetables by Group. Use the method of "Alphabetically" on the left. Select
the class on the right by clicking it. Then click OK. In the next step, select By Group at the top, then click OK again. To
add (hand-pick) students for the class, click the Add button to add them in one-by-one. Finally, click OK to assign the
class to the students.

Working with one student at a time: go to Students -> Edit Timetables -> Individual Student. Search for the student by
typing one or two letters from their last name. Double-click the student once showing in the search results. Once the
Change Student Timetable screen opens up, use the Add button to add classes to the timetable. This is a very slow
method and should only be used in a few individual cases, for example when a student transfer to the school in the
middle of the school year.

NOTE: Once you are done, assigning classes, run Correlate Database to ensure that the change becomes immediately
visible to the teachers. Do this by going to File -> Maintenance -> Topic-Based Marks -> Correlate Database.

Detailed steps: How to Assign Classes to Students
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10. PRINT HOMEROOM AND CLASS LISTS

Once you have finished assigning students to homerooms and classes, you should print out homeroom, class lists and
timetables for students (or create these lists as PDFs) so that you can verify students are in the correct homerooms and
classes. You can find all basic report options under Students -> Print Lists.

Detailed steps: How to Print Homeroom Lists

Detailed steps: How to Print Class Lists

Detailed steps: How to Print Student Timetables
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11. TWEAK

When everything looks 95 % good but a few students have incorrect classes, grades or homerooms, just open their
Student Record, find the tab that the information you want to change is displayed on, and click Edit button at the
bottom. Make the changes as necessary. Student Records can be found under Students -> Student Records.

In the Student Records:

e Biographics tab allows you to change Homeroom and Grade, among other things.

e Timetable tab allows you to make class changes for an individual student, to change what subject classes they are
taking. Use Edit button to enter the edit screen where you can add and delete classes from the student's timetable
(see below).

How to use Timetable tab to tweak student timetable

[ student Records —l l _(o] x|
FileStudent  View HET
Asssssmens | (B
Evams | Choices | Motepads | Custam Fislds | Transpanation | Livraiy| Discipline| Locker|
Masked info Biograptics| Famip/Contacts | Emergency| Enolent| Atendance| Histoys  Timetable | Achievement |
 Timetable: Day 1
Per.| Class | Description | Fioom | Lunc| Teachsr | Alt Teacher | jl
Sem. 1
No Picture 1 ELATI04a  Engish 218 Elizabeth Fitt
(Click here to 2 ELA11045 English 218 Elizabeth Pitt
add a picture) 3 MS51002a Social Studies 211 Ay Smith
4 MS51002a Social Studies 211 Ay Smith
5
Bithdate: 4/871999  Age: 15 5
Gee. Mo st 10 7 Make tweaks to
ef, Chars
Homeroom: Not Assigned Gz 2 individual student
1
) 2 . .
Etvict It : timetables in the
4
5 MATI793a  Mathemalies 208 ¥t - S S Student Records
Other Schols B MATI733a  Mathematics 208 Math - Science Seniar . .
z -l Timetable tab. Click
— Step To Another Student Frev Day
z | ' ™e¢—— Edit to start making
phabetical -
Brevioss | Newt Selegt & ThisYear ¢ Mest'ear Font Eniry Prnt ‘ &I | N&T
\/j changes.
[ [7/2872014 [0477 PH
[ thange Student Timetable
File Edit Wew Help Window
] o= Here you can see what
Homeroom: | Unassigned =l __| classes the student is
P Semester 1 .
Doy Tz 3 = —T 0 s s s already assigned to. If you
[Tt o T A2 sl | e want to remove one, click
R — m: on it first. Then click Delete

button lower down.

Fix issues in the student's
timetable by using Add
and Delete buttons.

CI |
owt = Qe | Choces Click Done once finished!

Delete

I~ Display choices not in timetable

Details | Apply Daone | ’
N

Once you click Done, the Add/Drop Register will pop up. You can just click Done on that one. The Add/Drop Register
tracks when Classes have been dropped or added to a student’s timetable and is presented to you mostly for
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information.

ﬂRegister !EI
The Add/Drop Register will be
Classes
Date Class £dd/Drop Semester/Tem Day/Period = presented to you. The register shows
P |09/19/2014 | 9000HELa Added S000HELa S000HELa J you dates when Classes were added

05/19/2014 | 3000MATh Aidded S000MATE 3000MATh or dropped. It is for information only
05/18/2014 | 300055 Th fidded 300055 Th 300055 Th

although you can make edits. Click

Done to close it.

03419/2014  [3000DRAR Added 0000 RAD 3000DRAD
03419/2014 | 3000ILAS Added S000ILA 3000IL&s

11413/2014 [ 3000MUSE Added S000MUSE 3000MUShE -

Add I Delete | Frint Dane

\#
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