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1 Introduction

The Student Information System (SIS) is a territorial, central database system provided by Maplewood
Computing Ltd based out of London, Ontario. All 43 schools in Nunavut use the system to maintain student
records, collect attendance on a daily basis, collect marks, and produce report cards and other student reports.
The use of Nunavut SIS is mandated by the Department of Education.

The Student Information System (SIS) User Manual was developed in 2014 by the Government of Nunavut
Department of Education. Previously developed help documentation were coalesced and enhanced to create a
single document with the most comprehensive information.

The purpose of the manual was to provide a comprehensive reference and how-to package for SIS users across
the territory. The manual was developed collectively by the Student Information System Coordinators and the
regional IT Program Coordinators.

The Student Information System (SIS) User Manual is a living document that will grow and expand over time. It
will be continuously updated as new software updates are released and new and better practices are
introduced. The SIS User Manual should be updated at least once every year. The latest version will be made
available on the Nunavut SIS wikispace (http://nunavutsis.wikispaces.com) or via the SIS Coordinators.

1.1 How to Use the Manual

The SIS User Manual is intended for users who have already undergone SIS training. It is designed to answer
specific questions that the users have rather than to read like a book. Look through the Table of Contents in the
beginning of this document to find the specific area that you need help with. Where sections are referred to
(e.g. “more detailed steps in section 5.3”), click on the section number or title to jump to it.
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2 User Accounts and Login

2.1 User Accounts and Passwords

In SIS, there are two types of users: administrators who use the Remote Desktop Connection; and teachers who
use the connectEd Web portal in a Web browser. This section explains the account creation for administrators
for whom this manual has been written. Teacher accounts are discussed section 5.3.

211 Account Creation

School administrators access Nunavut SIS by using Microsoft Remote Desktop Connection, accessible both from
PC and Mac machines. The accounts created are called remote desktop user accounts.

The administrator accounts are created by sending a request to either the SIS Coordinators or the region’s IT
Program Coordinator. They can forward the request to Maplewood who are ultimately in charge of account
creation. The user is provided with a username and a temporary password to log in with.

2.1.2 Password Resets

If the password is forgotten, it can be re-set by contacting one of the SIS Coordinators or the school region’s IT
Program Coordinator and requesting a password reset. Please specify in your request whether you are using a
Mac or a PC computer to access the Student Information System remote desktop. It affects how the account is
created.

2.2 Loginona PC

In order to log into SIS, the user needs to establish a Remote Desktop Connection to the SIS server to the
address of hosting.maplewood.com. This is most easily done on a Windows PC machine as no software
installations are required. Microsoft Remote Desktop Connection software comes pre-installed on all Windows
machines. Your SIS Coordinator or IT Program Coordinator will send you a pre-configured “.RDP” file which can
be saved to your desktop and used like an icon. If you need to build your own, follow the directions below.

1. Open Remote Desktop Connection application. You can find it under Start -> All Programs -> Accessories.

2. Type hosting.maplewood.com in the Computer field

3. Click the Options button at the bottom and the tool will expand. In the User Name field, type MWOOD\[type
your username here].

4. Click Connect
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#3 Remote Desktop Connection #% Remote Desktop Connection

Remote Desktop

Remote Desktop Connect

Connection

General | Display | Local Resources | Programs || Bxperience | Advanced |

| osting maplewood com Logon settings

E&’h. Enter the name of the remote computer.
y

Username:  MWOQD\nunavut msivala

Computer: |hosti b |
You will be asked for credentials when you connect. N\
User name: MWOOD\usemame| ) |

> ‘You wil be asked for credentials Wwhen you connect.

] Allow me to save credentials

Connect H Cancel H Help ([ Options >>]
o ——

Connection settings

Save the cument connection settings to an RDP file or open a
l b saved connection.

[ Save ] [ Save As.. ] [ Open... ]

SN
Cﬁogned Encel [ Help ] [ Qptions << ]

5. After a moment you should get the following screen. (For Windows 7 users the password will be prompted
before this step). Click OK.

6. In the next screen you should see your user account displayed. Click on your account.

7. Finally, type in your password and click the arrow button to log in. If you are not sure what your username or
password is, please contact your SIS support person for a password reset. Please note that you may have to try
this step twice. The lag caused by satellite connections causes the first authentication to fail on Microsoft’s
Servers, returning you back to the password entry screen. This is undesirable but normal.
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2.3 Log in on a Mac

Mac users need to install a third-party application to access SIS. There are several to choose from, however the
SIS team recommends a choice of two applications that seem to work consistently connecting to Maplewood:
CoRD and Microsoft Remote Desktop Client for Mac. Both applications are free downloads, however, Remote
Desktop Client for Mac requires you to log into the Apple Store to download.

1. The installer for the most up-to-date version of CoRD is available on the NunavutSIS Wikispaces site:
http://nunavutsis.wikispaces.com/Software. Download CoRD to your desktop and double-click the installer. To
install just move the CoRD program to your Applications folder. Double-click the icon to start program.

This is the CoRD
application icon on
your Mac “Dock”.
<Ctrl> click to see
the menu to “Add
to Dock”
preference.

2. Create your connection profile in CoRD. When you open Cord for the first time, it will look like the image
below. You need to configure a login profile in order to connect to Maplewood with your username.


http://nunavutsis.wikispaces.com/Software
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O~ Search Servers f I Cuick Connecy

ik Coanect

ALUNC SRssns

To create a new
connection profile,
click the “+” and
the profile form
window will
display.

Crmere b3 remee s
ek Nefrv e
LG sNeae Swnee

Cokorr: Tesmance 1 Sarenc by
— Tarrec cewan
Soy X bamm L
ST A B Al

3. Your Remote Desktop login profile should contain the same information as the image below.

Inspector: mac.hosting

Label: |mac.husting | '1;.:'
Address: |mac.hnsting.maplewn{:d.cum E3
Username: | MWOOD\NU_IHS.RLearn |
Password: |ssasssssas | ™ save password

Domain:  MWOOD |

|| Connect to console session

Session Preferences

Screen size: | 1024x640 s | Devices

[ | Forward disks
[ | Forward printers

Colors: | Thousands . |

Hotkey: 3+ | None = |

b Performance & Audio

10
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Label: is simply the title of the profile. You can call it Maplewood, SIS or your name.

Address: This is the internet address of the Maplewood hosting server. Because the application is launched
from a Mac, you need to use the address mac.hosting.maplewood.com to ensure your connection goes to a
Mac-compatible server. (For connecting with a Windows-based PC the address is hosting.maplewood.com)

Username: this is the username Maplewood uses to identify your login. You need to use this convention for
your username: MWOOD\NU_xxx.NNnnnn. Replace the xxx with your school letters (check with the SIS team to
find out yours). Also, there should be a period between your school letters and your first initial last name. The
‘NNnnn’ should be your name, typically first initial and last name.

Password: whether you enter and save your password or not, Maplewood will still ask you to enter your
password once you reach the server.

Domain: the domain in all cases is MWOOD.

Screen size (optional): you can adjust the screen size to your preference by clicking the pull-down menu and
choosing a different resolution. You will have to choose the size and try logging in to see if you like that
resolution. If not, just choose another setting and login until you get the setting you like best.

All other settings should be left as they are.

4. Once you have configured your server login profile, click the red ball to close the inspector. Then double-click
the new profile to log into Maplewood.

B Viincoms Server xe
(N

5. The login will continue with a black screen and will give you the login window above to connect to your

Maplewood Admin session. Click the icon with your username.

11
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MW ni

(= —

e

" Windows Serverace

6. Type in your password and click the arrow to login.

7. CoRD will display your remote desktop session.

mac.hostie

» Y e - aa

P (G Corm 2a ==
Correr slnicer Windower

n3
"
v £ et TS s oA - o

B, MWIODabnailiarigd # Occasionally, the SIS Team may need
N Socvee F . . ' ‘ . “ to troubleshoot your connection to
f Hare . | o sovrd e 1 15 o agr 24 G LIS o

the Maplewood servers. When we
ask which server you are on, we are
asking for the Host Name:

......

THEMS M S HiEs
e

Host Name: TS-PR2

User Name: nunavut ricarn

2.3.2 Microsoft Remote Desktop Connection Client for Mac

1. Open the Microsoft Remote Desktop application. For Mac users, a Microsoft Remote Desktop Connection
Client for Mac may need to be installed first. Contact your IT Program Coordinator if you need it installed on a
Mac.

12
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Microsoft Remote Desktop

2. You need to create or edit a login profile. Click New to create a login prOfile or Edit to edit an existing login

profile.

Microsoft Remote Desktop

Preferences Remote Resources  Microsoft RemoteApp

User name: MWOOD\nurigvut.riearn

mac maplewood
User name: mwood\nunavut. rieg

Sandbox

You can create 3 new remote You can edit an existing remote
login profile by dicking the profile by highlighting the profile
New button and clicking the Edit button

13
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3. Your Remote Desktop login profile should contain the same information as the image below:

00/ X ® i)

“
Start tan Preferences Remaote Resources Microsoft RemoteApp

v My Desktops

o ]

U | General Session Redirection

NOTE: Use mac.hosting.maplewood.com
unlike shown here. Both address will work
but mac.hosting.maplewood.com will have
Connection name |Maplewood the ability to print to local printers.

S
U

PC name |hosting.maplewood.com

Gateway | No gateway configured :

Credentials
User name 'MWOOD\NU_XXX.ATeacher

Password esssssscsses

Resolution | 1600x900

>

Colors | True Color (24 bit) -
Full screen mode | OS X native -

Start session in full screen
Scale content
Use all monitors

4. Username should be your username, where the _XXX. Is your school letter code and .ATeacher is your first
initial and last name.

5. Close the Preferences window to save your settings. No other settings need to be changed.

6. Click to highlight your profile and click Start on the Remote Desktop Connection window

7. A large black screen should appear and after a moment will display this message:

Vou st conmecting 1o ROP haet ‘hosting maplesnnd com The
COTtIRCAIE W as Ve e 1hroegh The carahicate chalt 1o velf
SIgred most totiicane thit wis presert |3 the messege. 2ot that
O] CerimGane 15 M 3 Kvkem. Tnviied roed ConfGane. Your
connmcion mighe ot Be uacues, 40 you want o8 conthee?

Continu

Negotiating Credentials ...

Click Continue to proceed.

8. The login will continue with the black screen and will give you the login window to connect to your

Maplewood Admin session. Click the icon with your username.

14
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9. Type in your password and click the arrow to login.

15
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3 Student Records

3.1 The Student Record

Student Records is a part of the Student Information System that allows the user to look up student information
specific to individual students. Each student has a unique student record that can be searched, opened, viewed
and edited. These functions are limited depending on the user’s permissions. Typically the Principal has the most
permissions but different levels of permissions can be granted to users based on their work needs.

The Student Record includes information such as:

o lLegal Name

Preferred an alternative names
GN ID number

This year’s and next year’s grade

Homeroom (if applicable)

Address for student and parents
e Emergency contact information

Attendance

Marks

Enrolment information

Student timetable

Student course history (if applicable)
e Etc.

By default, a school can view records for:

e Students who are currently enrolled at the school (Student Records)
e Students who have attended the school in the past (Past Students). Information available may be
limited.

3.2 Search Student Records

To search and open a student record for a student that is currently registered at the school, go to Students ->
Student Records. Type in a few letters of the last name of the student in the Search box. Then click the Search
button (binoculars).

When you see the search results, double-click over the student name to open their student record.

16
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ﬂSElect Students [ |

~ Eilter Include students registered Incl Al Names ——
Search By IPart\aI Marme j ¥ Both this and next pear IV Name Changes
Search On: IS‘-‘""GF"E j M W This pear only [not returming) IV Alases

I Seaich
<% j = [V Neut year only M atches found on slteinate names are highlighted
. ith the alternates shown in a tooltip window.

Search: 4 v Use Soundex w Deleted [withdravr !

& | ~ o (ithdiawn)
S | Eenline || i) || sl || Letpisn. || A | Sdis | e Seiee) | Ee | e | E 1 B
gak Janne-Maria Janme-M aria a1 493
Ahegona Shyanne Shyanne 7 /8 381634
Akammak Paul Paul Aggark 8 107258
Akilak Hattie Hattie 9 G4 (00E0G1,
Akiting Gilbert Gilbert 114 02753 Search results.
Akittirg Pearl Pearl B B/7 Errakll f
Akoomalik. Carltan Hanmy Carltan Thiz Year Onlp 12 195892 Double-click on
Akoomalik Famela Enmily Pamela 3 34 (080424 any of these rows
Akulukjuk Francis Francis 10 58588 —
Alagalak. Adin Myles Adin 5 GA 54474 to open the
Alaralak Wincent Wincent 1 14 (049642
Alariag Alexander Alexander Allurat This “rear Dnly 12 30590z student record.
Algona Enosh Erosh 4 L) 149871
Alik atuktuk. Carter Carter 1 " 821647
Aliktiluk, Julianne Julianne This “rear Dnly 12 734655
Alipak, Dionavan Dionavan g 78 159398
Alookie Tam Tam Alookie Deleted fwithd... 2 24 -

Total Students: 63 Pint Method oK. | Cancel |

I

Search Tips:

e The search process looks, by default, for students whose surname starts with the letters you typed. You
can change the Search On parameter to search based on given name (first name) or some other option

e The search process also searches through alias names for the student. You can prevent this by
unchecking the box for Aliases.

e Leave Use Soundex checked. The search will give you results on anything that sounds like what you
typed in the Search field

To view student aliases in this screen, hover your mouse over the student’s name. You can tell a student has
aliases if the AKA column has a number in it (1 indicates one alternative name). See below.

- | !
—1 If the AKA column has a number in

i kst w1 mg T ril A8 e o | i
N T [T p— LT it like for this student, it means
S Cr T E ol W bl — | thatth h | i
TG g that the student has alternative
W fed e ah 'H
" e b e L names.
e Hover the mouse over the row to
el brare el 4 e see the alternative names in a
v iyl [ cam B S
e i Fatie oW WiEL callout bubble.
nalid) e Cizert oo £
et Ce Tas TN
' o - Lt - oy
ey i Tmrma T n L
djs Fire T WAL
i a2n s hr ) s
Seashy dmy CLE W Syl
] S B i, 2 wo
- i [ ) P
gl e L L] 1 1 T
ety e vl —— =
P s Foabe ' i
_l"hﬁ I “\"- .l - aladrt L] 'nt i 4 I-J . _'I
| | =
[I—— Fe | e | ae Zand

3.3 Navigate Student Records

The Student Record has a tab-based interface. Every tab shares the left sidebar which shows the student GN ID,
Status, Home School (yes/no), Birthdate, Age, Gender, Grade, Homeroom and Ethnicity information as well as
a few other things.

17
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Use the Previous and Next buttons to jump to the next student record in alphabetical order or use the Select
button to return back to the Student Search screen. By default, the Next button brings you to the next student in
the alphabetical order. If you want to step through students in the same Homeroom or Grade as the student
whose record is already open, use the Step to Another Student dropdown menu to pick “Homeroom” or
“Grade”.

@/5tudent Records - Aaluk, Tunalaaq Tunalaag [_ O[]
Elle Student Wiew Help
Aaluk. Tunalaag Tunalaag Assessmentsl =
Exams' Chaices | Motepads | Customn Fieldsl Tranzpartation | Librawl Discip\inel Lockerl
Letters: AJX 2008199 Biographics | Familp/Contacts | Emergency| Envolment| Attendance | History | Timetable | Achievement |
Status: This Year and Hext Year ~ Mailing Addr e
Home School: Yes Michael & Ulipika Aaluk Special Custody? No
GN Student [D: 448443472 E10 Po 925 Custodian: None
PO BOX 123 Lives With: None Use the Previ and
- Pangnirtung NU X04 080 Legal Guardian: Mone evious
No Picture BE7] 8951545 Next buttons to step

(Click here to

to other student

add a picture)

The left sidebar is records. Change the

shared by all tabs Bithdate: 12/17/2005 Age: 8 + 8 Tnciléﬁéemmuk q:r'.fe\.r::r'n Y stepping method using
A Gender:  Female Grade: 2 © 3 i the dropdown
and contains key — Def. Chars Niugtug, Mrs. Doris P .
B . Homeroom: 2 24 . Advizor Graup: | |+
Informatlon on Niugtug. Mrs. Donis Wttt e Mot Assigned 1 Alt t‘ | | k
the student. Stisls T Grade: 2 ernatively, clic
: Select to go back to
Emergenc; — Mest Year
Michael Aaluk: (857) 761-4452 Hamergor: 2 2A the Student Search
Ulipika aluk: [86:7) 360-8017 Niugtug, Mrs. Doris screen.
Advizor Group:
r Step To Another Shudent — Not Assigned
Grade: 3

Alphabetical h
Freviows | Mewt | Selkct | Name Custody Print Edit =

- |Refer ta the family tab to view/edit additional information on parents [08/19/2014 [0313 P

3.4 Biographics tab

The Biographics tab pulls together information from several tabs, providing a view to a lot of the key
information: mailing address, parents and their addresses, emergency information, special custody
arrangements, grade and homeroom.

IAIphabetlcaI 3 —

Print and Edit

ﬂstudent Records - Aaluk, Tunalaaq Tunalaag H=]
File Student Wiew Help “_.----------------------------------------------------....
* e
Aaluk. Tunalaag Tunalaag :‘ Assessmemtsl < o
: Examsl Choices I Motepads | Cuztom Fleldsl Transparkation I leraryl D\scwplmel Lockerl t‘
Letters: AdX 2008193 BiDQfaPhiCSI Fami\_l,l./‘Contactsl Emergencyl Enro\mentl Attemdancel Histary | Timetable I Achievement | -
Statuz: This Year and Next Yeil — Mailing Addr — Custody .
Home School. Yes - Michael & Ulipika A aluk Special Custody? No H . :
BN Studert ID: 448443472 = 610 Po 925 Custodiar: None :4—— The Biographics tab
: PO BOX 123 Lives With: None -
- = Panarirung MU %04 0R0 Legal Guardian: None L]
No Picture BB [957) 8351945 B
(Click here to = .
add a picture) = :
.
5 .
5 -
Bithdate: 12/17/2005 Age: 8 +78 - Parenl ~ThisVear ——————————————— .
Gender  Female Grade: 2 . tichasl &aluk Homeroom: 2 24 H
Dief. Chars: : Miugtuq, Mrs. Doris -
Homeroom: 2 2A - - Advizor Group: H
Hiugtuq. Mrs. Dorisa el Mot Assigned H
. 5 Grads: 2 .
Ethnicity:  Irwuit n -
5 -
= ~Emergenc; ~Mestyear———————————————— .
. Michael Azluk: (867) 761-4452 Homeroom: 2 24 =
E Ulipika Aaluk: [967) 950-9017 Niugtug, Mrs. Doris .
: Advisor Group: :
Mot Assi -
—Step To Another Student——————— = T = H Name, Custody’
H
x

N
Previous | Newt_ | Seleg‘( Nme | cusody | Prin _ Ed [P 1: buttons
&
'o.\ o
s *

R e L T P |2 A LT
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Student Records | Family/Contacts tab

3.4.1 Edit Homeroom, Grade or Advisor Group

Click the Edit button to change the Grade, Homeroom and the Advisor Group for the student, both for this and
next school year.

ﬂEdit Bio. - Aaluk, Tunalaaq (... [HElE3
_
) Edit Bio. - Aaluk, Tunalaag
T

r— Date of Birth
124172005 Female

— Thiz Year

Grade: Im 'l

Hormeraom:

|2 24 Miugtug, Daris Mrs. j

Advisor Group: The Edit button on Biographics tab lets you set the
| Mot Assianed =l = student Grade, Homeroom and Advisor Group both for
NextYear this and next school year.

Grade: |3 'l

Hormeraom:

|2 28 Miugtug, Doiis Mrs. j

Advizor Group:

INUl Assigned j
—Defined Characters———————————————————

[ =1 = = =

ok | LCancel |
|

3.4.2 Set Preferred Name or Add Aliases

Click the Name button to set the Preferred Name for the student. You cannot change the Legal Name of the
student. That can only be done by the Student Records Registrar after the school fills out a Request to Change of
Student Information Form.

Also, you can use this area to add student aliases or alternative names so that the student can be searched by
them.

3.4.3 Set Special Custody Arrangement

Click the Custody button to set up a special custody arrangement for the student, such as “Lives with aunt. Must
not be released to father.”

3.44 Print a Student Information Sheet

Use the Print button to print a sheet of basic student information for this student. The printout includes, most of
the information you see on the Biographics tab and in the left sidebar.

3.5 Family/Contacts tab

The Family/Contacts tab is intended for inputting address, phone and other contact information for the student
and the parents. You can view this information directly on the tab. The Edit button lets you edit the information.
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Student Records | Emergency Tab

ﬂstudent Records - Aaluk, Tunalaaq Tunalaaq H[=]
File Student Yiew Help
Aaluk, Tunalaag Tunalaag Assessments | ke
Examsl Chuicasl Nulepadsl Custom FiEIdsl Transpullaliuﬂl Libraryl D\sc\plinal LDCkE[I
Letters: AdX 2008193 Biographics ~ Family/Cantacts I Emergency| Ervaiment| Attendance]| Histary | Timetatle | Achisvement |
Statuz: This Year and Next Year — Addr
Home Schodl: Yes lm
GN Student ID: 448443472 (s [BIE5] GRIAIEE D x
First Line Of Mailing:
Michael & Ulipika Aaluk
i House: B10 ApHi:
No Picture Shest Po 925
(Click here to City: Pangnirtung
add a picture) Province: NU
Postal: X0A ORO
RR#:  Box 123
Bitthdate: 12/17/2005 Age: 8 + 8 TownshipMunicipality:
) ) Lat: Sublat; None
Gender: Female Grade: 2 EEmes
Def. Chars: Euun.t;J.
Homeroom: 2 24 Emergency Code:
Miugtuq, Mrs. Dorig Couritry: Canada
Additional Information:
Ethnicity:  Inuit Emait Aaluk_Tunalaaa(@M apl d com
Cell:
Pager: LI
= Siblin "
? The Edit button allows
~Step To Another Student you to set student and
" = |, | | |
[1phaetice = "N parent (and others)
Brovioss | Hew | Seleot | ( __& | _) contact information as
well as to identify
I [08A572014 0320 FM emergency contacts.
3.5.1 Edit Student Contact Information

Click the Edit button on the Family/Contacts tab. Select the Student tab to input contact information for the
student.

Note: the First Line of Mailing is what you would write on the first line of an envelope sent to home.
Typically it is used like this: “Mr. and Mrs. Aaluk”, indicating the names and titles of the parents.

3.5.2 Edit Parent Contact Information

Click the Edit button on the Family/Contacts tab. Go to the Father tab to set father’s contact information and to
Mother tab to set her information.

If you need to input contact information for other than the mother or the father, use the other tabs or
click Add Contact button to see other options for contacts, e.g. Doctor.

3.5.3 Set Emergency Contacts

Click the Edit button on the Family/Contacts tab and go to the tab that has the information for the person who
should be the emergency contact. Check the box for Emergency Contact. When printing student emergency
contacts, this person’s contact information will be produced on the report.

3.6 Emergency Tab

The Emergency tab is linked to the Family/Contacts tab. If you have set Emergency Contacts when inputting
contact information through the Family/Contacts tab, you will see a list of the emergency contacsts here.

e Edit the emergency contacts directly in this tab by clicking the Edit button
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Student Records | Enrolment Tab

e Use the Notes button on the Emeregency tab to provide special notes on possible medical conditions
that the school should know of, such as “Allergic to peanuts. Carries and EPI pen.”
e Use the Print button to print out a sheet of emergency information for this student

3.7 Enrolment Tab

The Enrolment tab is one of the most important tabs in the Student Record. It captures all key information on
the student’s enrolment status at the school:

ﬂstudent Records - Akoomalik, Carlton Harry M= E3
File Student WYiew Help

Akoomalik. Carlton Harry Assessmentsl LZ

Examsl Choices | Motepads | Cuistom Fieldsl Tranzportation | Libraryl Disciplinel Lockerl

Letters: AKF 1019577 Biographics | Family/Contacts | Emergency  Envolment | Attendance | History | Timetable | Achisvement |

Statuz: This Year Only — Ermdert

Home School: Yes Statuz: This Year Only -

Alberta Student Mumber: GM Student I0: 195899904

Alberta Student Murmber:
Language:
Freferred Language: Unknown
First Reporting Language: Inuktitut
Second Reporting Language: English

No Picture

(Click here to

add a picture) Ethnicity: Inuit
Entry Date: Birth  kother Tongue: Inuktitut
Source Document Type: Unknown

Bithdate: D6/28/1994 Age: 20 Document Humber;
Gender.  Male Grade: 12 Doc. lzsue Date:
Def. Chare: Resident Board: Unknown

Attendance: Full time
French Language Entitlement: No
Fiegistration Type: Unknown
- : Entry Ta Elementary:
Ethricity:  Inuit Entiy To Secondary: 0372571999
Entry To This School: 0342571999
Req. Entry Status: Unknown
Fiegistration Statuz: Unknown
Origin School Unknown
Exit Date: 0643072013
Exit Description: Graduated with diploma
—Step To Another Student——————————— Dest. School: Unknown
IAIphabeticaI j LE.P:No  Altemate Programs: Mo LI ||

Previous I Next I Select I Prew. Enral Int. Transfers Edit | -

Homeroom: Mot Assigned

| | 0872572014 |D2:55 P

3.7.1 Edit Enrolment Information

You can make changes to the student’s enrolment information by clicking the Edit button on the Enrolment tab.
This opens the following screen:
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Student Records

| Enrolment Tab

ﬂEnrollment - Angootealuk, Jackie {Jackie)

Errollment | DOther Fields |

Enrolment fields that

—Statu

i This year anly
T Mext pear anly

" This year and Next year

* Deleted Mwithdramn)

— Origin

Entry ta Elem. School: I_-"’_f"_ E :I
IUBJ1?.-’2EIU1 E :I
IUBJ1?.-’2EIU1 E :I

Entry to Sec. Schoal:
Entry ta This Schoal:

Registration Entry Status:

— Ministry Infarmation
GM Student 1D:

Citizenzhip:

Yerification Document:

Student Authorization Espiny D ate;
I_.-"_.-‘l_ E :‘ ~ Betirement

—Language
Prefered Language:

I jv
13t Repaorting Language:

I Ik titat < l

the user can edit.
Accessible through
Enrolment tab -> Edit.

— IUnknown j 2nd Reporting Language:
Registration Status: m
IDD2DDD?ED I j nghs
J Orrigin S chaal: Filter: All Schools ¥ | ™ French Enidement
I Unknown j —Attendance
[ Full Time =l

Exit D ate:

|12.-’13£2D12 E :I

Dracument Mumber:

Exit Description:

=
—

21100 Tral i

— Registration Type

I jv

N . Destination Schoal Filter: All Schaoals LI

: . El=l [ aqsamit linniardk (Mw) || ~Erograms
Father Tongue:
II i 2 J — Fiesident Board I" IEP

il it hd
— S [~ Alternate Program

Borm in iy Uale 10 manadal Unknawn i r— Ethricit

7 Canada IBirth E :I I J e
Ilnuit 'I
QK I Cancel |

Make changes to the information as needed. Use the table below as a reference.

3.7.2 Explanation of Enrolment Fields

Field Name

Possible Values

Use

Status

This Year and Next Year: the student is actively
enrolled this year and is expected back next year.
Most students have this status.

This Year Only: the student is actively enrolled this
year but is not expected to return next year (e.g.
graduating or moving to another school). Students
who are in the final grade offered by the school
would most likely have this status.

Next Year Only: the student will become actively
enrolled in the next school year. This status can be
used to pre-register students for the next school
year. Pre-registering students in the spring with
Next Year Only status reduces the workload for
next fall.

Deleted/Withdrawn: the student is withdrawn
from this school and is no longer attending. The
student may have moved or dropped out, for
example.

The Status field indicates whether the student is
actively enrolled in this school or whether the
student is withdrawn (Deleted). The Status can
be changed for a student at any point of time to
reflect the current status of the student as
accurately as possible.

GNID

A seven digit unique ID number

Cannot be edited by the school

Alberta
Student

A number complying with Alberta’s student
number generation rules

Cannot be edited by the school
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Number
Citizenship Canadian Citizen Set student citizenship by picking the appropriate
Permanent Resident value from the dropdown
Student Authorization
Study Permit
Child of a Canadian Citize
Child of an individual lawfully admitted to Canada
for permanent or temporary residence
Other/Unknown
Verification Canadian Birth Certificate What document was used to verify the student’s
Document Health Care Card legal name and birthdate when the student was
Canadian Citizenship Certificate first registered? Usually this field is set only upon
Permanent Landed Immigrant document the very first registration.
Passport
Canadian Marriage Certificate
Canadian Adoption Certificate
Document The document number associated with the Do not fill this — not required
Number Verification Document
Doc. Issue The document issue date associated with the Do not fill this — not required
Date Verification Document
Mother Unknown Fill in the mother tongue of the student
Tongue English
Inuinnaqgtun
Inuktitut
Other
ORIGIN
Entry to Elem. | Date The date the student entered elementary school
School for the first time
Entry to Sec. Date The date the student entered secondary school
School for the first time
Entry to This Date The date the student entered this school (the

School

latest entry date if the student has come and
gone in the past)

Registration
Entry Status

Continous Registration

New Registration

Transfer-in from a school within the school region
Transfer-in from a school within Nunavut
Transfer-in from a school within Canada
Transfer-in from a school outside Canada
Returning to school

When a student registers at the school, this field
must get a value. Pick the value that most
accurately desribes the registration.

New Registration should only be used if a
student has never attended school in Nunavut
before.

Registration Registered Required as of August 2017. Normally set to
Status Active Active unless the student is changing status to
Cancelled ‘Withdrawn’ or other.
Withdrawn
Completed
Created in Error
Closed
Origin School List of Nunavut schools If a student is a transfer-in from another school in

Nunavut, pick the origin school’s name from the
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‘ list of schools

RETIREMENT (STUDENT HAS DELETED/WITHDRAWN STATUS)

Exit Date

Date

The date the student exited the school. This date
must be filled when a student’s Status is changed
to Deleted/Withdrawn.

Exit
Description

Unknown

Completed prescribed course of studies (no
diploma)

Transferred within school region
Transferred within Nunavut

Transferred to other province or territory
Transferred to other country

Deceased

Disciplined out

Left school for health reasons

Seeking employment

Gone to work

Pregnancy

Child care

Sports

Dropped Out

Other

Created in error

Graduated with diploma (continuing post-
secondary)

Graduated with diploma

A description of why the student left the school.
This field must be filled when a student’s Status is
changed to Deleted/Withdrawn .

Destination
School

List of Nunavut schools

If a student transfers to another school in
Nunavut, pick the destination school’s name
from the list of schools

RESIDENT BOAR

Resident - Not used in Nunavut
Board
LANGUAGE
Preferred English Fill in the language in which the student prefers
Language French to be addressed

Inuktitut

Inuinnagtun

Other
1* Reporting English For multilingual reports provided to the student,
Language French what should be first language be?

Inuktitut

Inuinnagtun

Other
2" Reporting English For multilingual reports provided to the student,
Language French what should the second language be?

Inuktitut

Inuinnagtun

Other
French Yes/No Ayant Droit. Is the student entitled to full-time
Entitlement French language instruction? If so, check the box

for “Yes”.
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ATTENDANCE

Attendance Full time Attendance Type describes how the student
Part time attends the school. The default is Full Time.
Independent Study Change this to Half Time (AM) or Half Time (PM)
Half time (PM) for Kindergarten students based on how their
Half time (AM) classes have been timetabled. Part Time,
Half Time Alternative Days Independent Study and Half Time Alternative

Days are rarely used in Nunavut.
OTHER FIELDS

Registration
Type

Continuing Education Day Student
Regular Day Student

Continuing Education Evening Student
Group Home

Home Schooling < 50 %

Home Schooling 50-100 %

Home Schooling 100 %

Magnet Facility < 50 %

Magnet Facility 50-100 %

Magnet Facility 100 %
Non-Attendee

Summer Day Student

Summer Evening Student

Registration Type describes the registration or
association that the student has with the school.
The default value is Regular Day Student. In most
cases the value should be left at that. If the
student is home-schooled, please select one of
the Home Schooling options.

Programs IEP Select IEP for IEP students, otherwise leave these
Alternate Program unchecked

Ethnicity Unknown Select the value based on the ethnicity of the
First Nations student
Inuit
Non-Aboriginal
Metis

3.8 Attendance Tab

The Attendance tab displays today’s attendance for a student. You will either see the attendance code entered

by the office and/or the teacher or “Not Yet Reported” if attendance has not yet been reported by either.
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Azzessments l
Examsl Ehoicesl Nolepadsl Custom Fieldsl Transportalion] Liblalyl Disciplinel Lockell
Bioglaphics] Famil}lHContacts] Emergency] Enrolment  Attendance ] Histor_l,l] Timetable] Achi

/Toda_l,l's Attendance
Per.  Class Office Teacher In/0ut s
1 NSS1002c Absent Absent -
2 LDCZ2290a Absent Mot Yet F!e_parte’d
3 ELAZ2104p Absent P!uj Yef Reported
4 PED3447a Absent =T “Mot Yet Reported
PO

+ Today's Attendance © Attendance Register

Altendance Naotes
B/22/2014
Signed Out: 3:30 PM [Perniod 3]

11/29/2013

teacher in zervice

11/415/2013

Signed Out: 2:29 PM [Period 7)

101742013

parent teacher interview
31172013

Mates

Edit Reqizter | Frint Beqister | Print Per. Aft. |

Today’s Attendance is shown
on the Attendance tab

]

Edit

Click on the Attendance Register radio button to see a record of past absences for the student:

Assesmenis |
Shane: | Chowces | Woepads | Custom P | Tiarspotation | L] Oiscipkes | Locker
:-{n._'pa.'h'ul FamdpCorlacts I-'r-:ug-u-n_-,-l Enclmant  Ahendance Hnﬂn':,-l Irm:ahal .J.r.h;.-m'rnu:l

Apendence Regsier

Switch to Attendance Register in
order to see past absences in a
table format.

Cate Period 1 Teicd2 | Feicd 3 Frricd 4 / _:—_,"
1dagdd  [SCHI10M e JELAZI0Gs  [HSST00E:  [Fnaid00s ==
1200974 | MSST0LEe JLOCSNL [ELAZTOAS  [FEL=E4/a -7 . ]
1318 |FLAZIE  |HWSST0G: |LDCFA0e  |FRaldiie + 7 -

i Togafs Abendence [+ Hencacs Aegse V3

Shencaree Hoes

I -
Signed Dut 3:30 PH [Pericd 3)

17233 m 3

lached @ SEvice

1141520 3

Signed Qut 2:20 PH [Peried 7)

101772013

parmnl lnachan mlarvieer

SE] ) memoonen 0 e E|

Hiplss Fcll Ragrdn: | Panl Fagedn | Panl Per il it
3.8.1 Edit Student Attendance Register

The Edit Register button on the Attendance tab allows you to edit past, present or future attendance for the

student:
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.ﬁssn—e-mu:rl:l

Tadsy ¢ Sbewisnce
Fz. Ll Uiice

RIS Abperd
WLl Ahserd
FLAZI Aol
FELM47s Absert

| etk

#hren)
Mol 7et Heporled
TR T—
Haa 't Meporied

Eaowd b

5 Totafcdllondance (0 Slerdonc: Recpdo

Al aros Mok
Q222004
Signid Dist: 320 PW [Feresd 2]

1177232003

teacher in sEivice

11A%203

Signid Oul: 279 PM [Frrasd 7

107203
pasent beacher inbeiview
R

dgw | Pl Heater |

Lame I}nicu| "-clsp:-ds| Cysami Fdds | Trarsporsion Ll:-'e','l Jiscipne L:-cq.e'|
Ficepaphizs | Famdaonbartz | Froscerey | Erasbment Stterdance | Hirey | Tinetsbn | Achimmmd

(@D
.

Furk Fes, AL

InUie

Edi

Click Edit Register on the
Attendance tab to make changes to
the student’s attendance. Changes
can be made for today’s date, past
dates, or even future dates.

The Edit Register screen has the following functions, the Calendar button being the most useful one:

[)secondary Attendance -

Current School D ate Information

Monday, Auqust 25, 2014
Day of Cycle: 5
Type of day: Hormal

Feqister l Add/Drop

=10 =] Use the Add button to add an
absence. Best use: use this button
to add and absence for a range
dates. See further down for more

instructions.

Use the Edit button to edit today’s

office attendance entry.
_ ] y
[ Habitually Absent
Diate Period 1 Period 2 Period 3 Period 4 j Use the Calendar button to view a
1840014 |ELAZ104p |MS51002c |LDC2290a | FMAT400a calendar and to use that to edit any
Alse s ,/ day’s attendance. See further
1340914 |LDC2290a |ELAZ104p |WNSS1002c |PED a o (60 e S e hs,
2040914 |NSS1002c | LDCZ290a | ELAZ10. FMA14005
i ALk Alis alikas Use the Notes button to add, edit
A-Augd FLA2_1 Dan r?ISS-_I 002 DC2230a | PED3A7a | | —1 or delete attendance notes for this
22pun14 | LDC2230a ECAZI04p |NSST0025 | FNAT400s student. o If"the’ down for
Absent~ | Absent Absent Abse more Instructions.
Z_Y - "
Add | Edit | LCalendar | Mates | Print | Summary |
L3 4

' \

|

|

[

Set Attendance for a Range of Dates

Use Print to print an attendance
register for the student. Use Summary
to get a quick report on this student’s
attendance this year.

If a student is known to be absent with a known attendance code (e.g. Family Trip or health related absences)
for a period time and the dates are known, attendance can be set at once for that range of dates. This can be
done via Edit Register by using the Add button.
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NOTE: Use the calendar widget instead of typing in the dates. The widget opens when you click the little
down pointing arrow to the right of the date. This will ensure that the correct date format is entered

into the date field. It is also more intuitive to use.

Set start and end date for a range of dates: ... use the calendar widget:

ﬂ Add Register EI'ItI"f E’ l ~Monday, August 27, 2012 [Toda}l];?a}l of Cycle: 2; Type of day: Normal—
EntyDate:  [08/27/72012 B~ T [0B/27/2012 (S]]

tonday, August 27, 2002 [Today]; Day of Cycle: 2; Tvpe of day: Marmal ] gl [ 2012
|7 Entr_'.-' D ater IE."IE?."IED-I 5 AI vI To IDB.-"E?.-"ED-I = AI I Sun Tue|'wed Thu| Fri | Sat | Cancel
13 (14 15 (18

ak I Cancel |

Once the date range is entered, click OK to get the Add Register Entry window, shown below.

Here is where you enter the attendance code for the range of dates. If an entry is made for instance just for
Period 1, the code will be applied for the entire date range entered in the previous window. However, at the
bottom of the window is the option to check the All day checkbox. When this is checked you can set all the
periods of the date range to the attendance code chosen in the drop down menu.

After picking the code for individual periods or for All Day, click OK and the entries are saved for the date range.

Ecj Add Register Entry x|
Maonday, August 25, 2014 [Today); Day of Cycle: 5; Type of day: Momal

Entp Date:  8/25/2014

Period Clazs Feazon
Period 1 551002 P Present
Period 2 LDC22304 P Present
Period 3 ELA&2104p P Present
Period 4 El P Present
All day v | j 0K | Caneel |

& Bbgent <
Seleft attendari g Helpirg

C Compassion
: SAug-14 |E Excursion
EF Fam. lnp

(& Grant day
dd |H Health ar Z Motes | Print Surnmary Daone |

L Late hd

Add Register Entry screen

Use Calendar to Edit Attendance

The Calendar button in Attendance tab -> Edit Register is possibly the most useful way to edit past, present or
future attendance. Click the Calendar button and it will bring up the attendance calendar for the student.
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Next, click on the month’s name to open a more detailed view of the month’s attendance. Clicking over

“August” in the calendar screen brings up just the month of August:

ﬂ Attendance Register: Aglukkaq, Jordan {Jordan) - |
August W September October Mowvemnber I
Mon  Tue ‘Wed Thu Frisd tMon Tue  Wed  Thu Fri |Maon Tue ‘Wed Thu Fri | Mon Tue ‘wed Thu Fri
3 2 3 4 5 1z 3 Legend
ooz 1 M 15 51 Click here to open the month of August oo 1213 14
18 1w oz 2 A 2 22 ) . ) 17 18 1920 2 [Excused
B 2 27 2@ 23 | = a0 alone. It is a more detailed view of the 24 25 28 27 3
monh G
December J arrETy FEDIIETY tarch I
Mon  Tue ‘Wed Thu Fri | Mon Tue ‘Wed Thu Fri |Maon Tue ‘Wed Thu Fri | Mon Tue ‘wed Thu Fri
1 2 3 4 I3 1 2 4 5 E 2 3 4 I3 3
g g n 1 12 1 E T g g 1 12 13 g n 1 12 13
15 16 17 18 19 12 13 14 15 16 18 19 20 16 17 18 19 20
22 23 24 25 28 13 20 21 22 23 23 25 26 27 23 24 25 25 27
249 30 #H 25 27 28 29 30 30 #H
Sl bl ay June July I
Mon  Tue ‘Wed Thu Fri | Mon Tue ‘wWed Thu Fri |Mon Tue ‘Wed Thu Fri | Mon Tue ‘wed Thu Fri
1 2 3 1 3 4 5 H b4 b
E T g | n 4 1 E 7 g 10 N 12 : 3 bl Hi
13 14 18 18 17 1 12 13 14 15 17 18 13 i H ¥ # i
20 21 22 23 24 18 19 20 21 22 22 24 26 26 i e wl i i
27 28 29 30 25 26 27 28 29 29 2 b s =i e
Edit | Motes Summary | Print | Done |

[OvR [8/25/2004 1230 M

Now you can see the attendance codes for each period of the day in the month. Dot (.) means Present, A means
Absent, L means Late (similarly for any other codes).

In either of these two views, year or month, click on a date and hit the Edit button to edit attendance for that

date.
ﬂnttendance Register: Aglukkaq, Jordan ( Jordan ) Homeroom: 6 Phone: - il
| August 2014
aon Tue Wed Thu Fri
1
4 ] E 7 g
15
AB4.
29

Summary |

Ent

Frrint

| Done I

OvR | 8/25/2014 [12:47 PM

29

Attendance for the month of
August. Dot (.) means Present, A
means absent, L means Late. Any
other codes recorded will show up
as well if they have been used.

Click on a date to select it, then
click the Edit button in the toolbar
at the bottom to edit attendance.
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Finally, use the dropdown menus to set the attendance code one period at a time. Click OK to save the

Change the attendance code for the
desired period by clicking open the
dropdown menu and then selecting
the attendance code from the list.

Under here somewhere is the OK
button...

After picking the code(s), click OK to
save the changes.

changes.
[T attendance for 8/29,/2014 B4 ﬁ
Penod Clazz Reaszon
Per i1 ELAZ104p P Present
Per.#i2 |NSS1002c | P Present /
Per.#t3 LDC2290a P Present ot 4
Per. #4 PED3447a P Present -
E Excursion o
F Fam. tnp
Listing of attendance details G Grant day
LR B | N
2% = 2 2 H Health
L Late J /,/’/
N Sleeping «
0 On land
Add Attendance Notes

Attendance notes can also be entered the attendance register screen. The attendance notes will be displayed in

the connectEd interface and can inform teaching staff on the student’s status. The notes can be also displayed

on student attendance reports.

Click the Notes button on the attendance register screen. Click the Add button to enter a note.

Wi rrebare o pa - n, i i
Sk pe=n
[uws “obz T=
-
=
| ER [ | R Toee

e N

You will be presented with a window in which to enter your note. Select a date if necessary and simply type the

information in the text field and click OK when complete:
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dd end. - Airut, Bri . .
Blaidaezncance NOt e Pick a date for the note if other
)~ than today’s date.
&
< Type the attendance note
o Click OK
Spell Check Ok Cancel
[Type the contents of the note here

NOTE: for those of us challenged by spellingg, there is a conveniently located Spell Check button.

3.9 History tab

The History tab is primarily used to track high school students’ completed courses, the course history. The tab
displays all course attempts from the past including both failed and successful attempts. The course history gets
updated at the end of each semester based on the student’s marks. The tab is a great place to monitor how the
student is progressing towards graduation.

ammlli’l:l

Ewzre | Choszes | Motepads | Custom Fiekds | Teaneponistion | Lbcay | Oiscpine| Locker
Eh-;'acl'\i.'-s| Famibg/Conbazts | Ersgency Em:h:ﬂ:l Atedsnce  Hibay |Ti1'-e:di:- | -"'v:lie'.'cﬂ:n:|

L b Lindives

Courzs Tils [ials Tmn  Mak Essm Piged Fnel Cedl Stenpisd Coedi Wan Cat Sip Slstus Msthcd Larg Ty,
COMTORD Frikding Consction SRR El 52 rva n'a n? 1en 100 Cawe E Tachwningg Shades Corplerd Frempdar EH Hn
LGS0 Tiou & the Lae 1 (a5 Conpemm an 2000500 2 5 e 1= 100 00 Ciorpbeiad Fagls CH He
LTHIIg dab Fiepaiaoon AlEAn 1 ER Fia s LE) 1L T Laeer B lechoaogg Sudes Lompkeed Fegular Mo
CTR1210 Prereonal K afu by W aracpammn| AR 1 ER A e F3 1cn 100 Caww B Tuchoiogg Shodes Crrplasl Fenpls Hu
FOCA010 Focd Daszs a4 1 11} L] 51 100 100 Canmer B Tachno ogp Soudes Corpleiad Fagls Ho
KCOS1IN LCresting & Career and Frogiam Fir 0080 1 1] e A L) 1C0 10 Caeer B Techmapgy Shutes Compb=izd Fegbyr EW Heo
CTRZZ10 =t imbplaca Salady [Pracd ses] F R 1 EE ra wha B3 1co 100 Dol Faipda Hu
LES 10 Tha Cieign Finces: A6 2 M s nfa T3 100 100 Corplead Fapds EH Ho
COrA1020 Frotogashe 1 2K 1 113 e aa |5} 1.00 0 Ciorpbeed Fguiar He
COM1120 P Pl e el 080 1 a7 e i ar 1c0 com Do e Pk EH Ho
COR11AD Toain g Ooeestore A 1 AT e s AT 1cn oon Corplsed Fgls EH Ho
Cieid 0N bilmms d o mb w s hdmbnsimle WIW A L] A7 mieaie iT A0n o [ Cimm e L b,
Loy by Cawclls

Ll igeimer il irainy T8 Bygauppeadkkaningnig ]

E ragli by o M5 Mahsratice 0 Md

Fare: Aty oM FomEnce L L)
Aailajacul F CT5 [

fadaj ma it 341 Mhar v

Con PracfSwe 14 Add. Lewvel 30 5 A0

Fris Ed 3.0 Lraper Ciedi 2r A2

Himmavuziulil 13

Social Gt oMo

Murthezin Shad e

Tkl Compislionp Criidils [y (o] = Earad
™ Projecied
Lpkona o | fgterd Hist | Py Crehc flikmn

The following information is shown for each course attempt. The columns are visible in the screenshot above.

Column Explanation

Course Code The Nunavut-approved course code for the course attempted

Course Title The name of the course

Completion Date The year/month when the course was attempted. Normally dated to the end of the semester.
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(vear/month)
Term The term during which the course was attempted:
e 1 =Semester one
e 2 =Semester two
e 3 =Fullyear
e 4 =Summer
e 5 =Special Session
Mark The Final Mark for the attempt, typically a percentage mark. Some letter grades are also
available:
e P=Pass
e INC=Incomplete (Credit Achieved = 0)
e |IPG = In Progress (Credit Achieved = 0)
Exam Mark An Exam Mark will only apply to Alberta exam courses. It will be available once the marks have
(if applicable) been received from Alberta. Counts for 50 % of the Final Mark.

Project Mark
(if applicable)

Social Studies courses with a Nunavut Project will have mark in this column. Counts for 30 % of
the Final Mark. Must be over 50 % to achieve credit.

Credit Attempted

The credit available upon successful completion of the course

Credit Achieved

The credit achieved by the student

Main Category Group

The Category Group towards which graduation requirement the course counted. For example:
Aulajaaqtut, Mathematics, Fine Arts, etc.

Status: Course Completion Status. Possible values are:
e Completed: all course work has been completed by the student, whether successfully
or unsuccessfully
e InProgress: the student has not completed all components of the course but is
expected to complete them within reasonable time
e Re-Try: the student has re-attempted the course, most likely in order to improve the
mark
e Re-Write: the student has re-written an Alberta exam for the course
e Incomplete: the student has not provided enough work to make an assessment and
cannot achieve credits
Method: Course Completion Method. Possible values are:
e Regular: a regular course
e Alberta Exam: a course that includes an Alberta exam
e Nunavut Project: a course that includes a Nunavut Project
e Challenge: the student challenged the final exam for the course
e  Evaluated: the credit was evaluated. Students who have completed courses outside
of the province get evaluated credits.
e  Waived: the course was removed from the student’s graduation requirements
e Retroactive: the student completed the course using the Retroactive Credits rule
from the Secondary School Administration Handbook
Language The instructional language of the course
School School completed in. Blank means “this school”.
Absences The number of absences (truancies) while attending the course

Excused Absences

The number of excused absences while attending the course

Lates

The number of lates while attending the course

Possible

The number of possible periods in the course
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3.9.1 Set Graduation Path

The graduation path can be set through the History tab using the Edit button. Please note that the student and
the parent of the student must be consulted before making changes to the graduation path; the school is not
authorized to make graduation path change decisions without consent from the parents and the student.

Click Edit and pick the graduation path from the dropdown called “Graduation Path”. Then click Done.

Diglom=s Ey— E_‘““"’“"“““"“" . \ Change the student’s graduation path
e Hors A0 = al ||| Gt Enty " = using the Edit button on the History
iy Schodl =] || Gradustion Pa | 20092010 Gradustion Frequeme =] | tab, and then by picking the path from
Second | | |_] e 20201 Gracushon Regaemearnts this dropdown.
- 2004- 3008 Geacushion Pegunements

i Shosd =]

Cowase Tille Dibes Tem | Mark | Ewam | Project| Firal | Ciedd Afempind | Credit | Mar ~

IMF1ILET Faghasidng 1 204,10 1 19 néa ] 15 .00 100

IMF102D0 Word Fiosssag | 201440 B ni'a ni'a L .00 nom

HRCI000 Aulssaciul 10 4 27 | rnia | nia | 27 %00 .0

3.9.2 View Student Graduation Status

The lower part of the History tab shows you in red the areas that the student has not yet completed to
graduate. This does not include achievement on courses that have not yet finished. The student below has not
yet completed English, Fine Arts, Social Studies, Science and Additional Level 30 requirements.

Lol ony ey
Ugausditinig
Englith
Free: Asls
P
Audmmachd
[
Prye Ed
Humarvucoead i
Sncial 51
Hortham Shad

Dcdowiia | ia

Aghaal Hist

L]
LIk}
o3

10
1A
23

n An

Iqgappekk sy
Rl
Science
LTS
Ditheer
Add. Lavel JU
Ureper. Ciedis

Total Compulsery Crefits:

Pyl Ciadht oo |

10 A
5 /10
55

L
aF 2

2100 o Eamed
™ Frojcisd

3.9.3 Print Validation Statement

You can print the student’s Validation Statement by clicking the Print button in the History tab, and then by
selecting the Validation Statement radio button. Then click View.
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[ settings x|

Tranzcript Settings

Date of lzsue: ME/25/2014 |2~

~
&
" Course History
F Grades
2 [~ Limit Courses by Grade
-
= Lowest Grade: :Iv
r Highest Grade: -
- (¢ Print Credit Granted

Printer Settings
I Include Students “ith Empty Transcripts
I Include Banner

Frint affzets (330 = 1/4 inch)]

Top of page: 0 Left edge of page: a

3.9.4 Print Credit Breakdown

To print a report called Credit Breakdown (equally good as the Validation Statement) click on the Credit
Breakdown button directly on the History tab. The report looks like this:

ﬂ Print Preview =10f x|
111 R .| # 0 = =

Zoom Search Print Exit

|»

Qigirtaq llihakvik

Credit Summary -

Category Course Credt Title Dt Mark Compdszory  Other
Walue Credts Credts

Lgausilinni

Erglish 10457

Fre Arts (003

Aulajaactut (3/3) NRCZO01 5 fulajaagt 11 201401 &1 3

Cormn. Prac.fSuve. [141) MR C2400 1 FAulajaaqut Community Practicum 11 2014-03 P 1

Phiys. Ed (32 ED1445 3 Physical Education 10 2011-06 56 3

H it
Sooial 5. (040 )
Northern Stud. 3/ LOC1193 3 Northem Studies 10 2012-06 50 3

I qagqaukkar ngni ¥ J
Mathematics (10407 MAT1793 5 Mathematics 10-3 2013-06 &1 5
MATIT O3 5 Mathematics 20-3 2014-01 50 5
Science [3M0] LOC1290 l Seience 15 201406 &1 l
CTE(545) CON1070 1 Building Construction 2006-06 52 1
CTRIDID 1 Job Preparation 2008-01 68 1
CTRIZ10 1 Perzonal Sakty (Management) 2008-01 68 1
FoD1010 1 Food Basics 2008-01 50 1
NES1411 1 Creating a Career and Program Plan 2008-01 50 1
CTRZZ0 1 Wiorkplace Safety (Practices) 2008-01 62
DES1020 1 The Design Process 2008-06 79
FoD1030 1 Snacks & Appetizers 2009-01 55
FAZZ0A0 1 Specialty Fabrics 1 2009-06 &5
CONZ040 1 Framing Systerms 1 (Floor & Wally 2011-01 [:13]
WWLOZ0G0 1 Intera ctions (Wildlife & Sodety) 2011-06 40
INF1010 1 Computer Operations 2012-06 &5
ChiHzO10 1 Aduole szert Health Issues 2012-06 55 - -
ENT 1020 1 Planning a “eriure 2013-06 62 - -
ENT2020 1 Financing “entures 01306 63 - - j

Credit Breakdown report
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3.9.5 Attend. Hist.

The ‘Attend. Hist.” is the attendance history of the student. This table shows the student attendance summaries
for previous years. | also includes the Promotion/Retention history for elementary students as well as the school
at which the history was collected.

[} Accumulated Attendance History - o ] B3
Attendance History | Attendance Details ] G.P.A. History ]
Accumulated Attendance History
History Attendance
Date Grade | Teacher Promation Abs. Ex. Late Pc
P | OB/28/2012 K Promation ] 0 ] z
0641372013 1 tdrs. Tagoona Janet Promotion E5 1] 1] 11
06/05/2014 2 tdrs. Maynard Jennife Promotion 7 kil 2 11
0B/09/2015 3 Miss Guptill Sara Ly Pramation 4 4 2 1
0E/07/206 ] r Leone Michael Retained i g ] 1
06/07/2M 7 5 r Leone Michael Promation 4 35 ] 1
L1 | 3
Frint
[

Attendance History table

3.10 Timetable Tab

The Timetable tab displays the Classes that the student has been assigned to and shows what the student
studying this school year. For high schools, this classes are actually slotted to the periods. For elementary
schools, the classes show up at the bottom of the table next to letters A-Z as they do not normally get
timetabled (they are “floaters”).
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ﬂstudent Records - Aggark, Jeanne-Maria Yalentina [_[O]x]

File Student View Help

Aggark, Jeanne-Maria Assessmeﬂlsl
Valentina Examsl Ehnl:esl Nntapadsl Custom Flaldsl Transpnrtalmnl Llhraryl Dlsclphnel Locker
Letters: AJO 2003435 Biugraph\csl FamiWComtacls' Emergencyl Enmlmenl' Attandance' H Elable Achievament'
Status: This Year and Next Year — Timetable:
Home School Yes
GN Student ID:_817493021 Pe|Class ___JPesciption | Room | Lunc| Teache: | Al Teacher |ﬂ
. em. 1
No Picture ATTAMSs  AM Attendsrce M. Manuel dolegostok ||
(Click here to TTAMIz AM Attendance X
add a picture) ATTPMIa P Attendance = M1, Manuel Aglegoetal:
ATTPM3a P Attendance X M. Manuel Aglegoetak
S000CSEa Computer 1. Manuel Aglegoetak
Eithdate: 02/18/1939 Age: 15 E 9000EL4a  English 9 ® Mr. Manuel Aglegoetok
Gender: Female  Grade 9 C 9000FM&a A9 ® M. Manuel Aglegoetok
Def. Chars: [ 9000HELa  Healthd X br. Manuel Aglegostok 1
Homeroom: 9 94 E 9000IL&a  lmukibatd ® W
e U F9000MATa  Mathemalics3 X bir. Manuel Aglegostak
anuel .
Ethricity:  Inuit G S000PEDa  Physical s M. Manuel Aglegoetal:
H 90005CMa  Science 3 s . Manuel Aglegoetal
| 900055Ta Social Studies 9 % 1. Manuel Aglegoetal
Sem 2
1. ATTAM3a AM Attendance X 1. Manuel Aglegoetal: j
r Step To Anather Student
Alphabetical -
Previous | Mest | Select | & This Vear © Mewt'rear LCort. Enfry Frirt | Edit |

Periods of the day. This
school has only four
periods today.

Classes that have been
scheduled to the four
periods today

Classes that the student is
taking but for which there
is no schedule for today.
They may occur on
another day or they may
be “floater” classes that
have no schedule at all.

[o8/2172014 [01:20PM

3.10.1 Edit Student Timetable

1. Go to the Timetable

B nkkak, Karen (This Year)

tab and click Edit to get to the following screen:

Hame=icom: |Ll1a$5|;ned

[\

Semeste 2 Teim 1

Day 1 1 2

[ 2] 4] 5] & 1 S EN

3000HEL
|FOCO1 0y
| B000MAT b
0005008

]|

300055 T
[Fas1mo0:
EEn
3 000 FAE

1
2
3
]
3 A00LAa
]
]

[ w2a |

L W
11 AIARTh
12 \ | 3000MUSE
13\ |3000PEDh

IEIa,J] -

I Diisplaw chaicaz not in imetabls

Select a Class on the left to delete,
then click the Delete button to
remove it from this student’s

timetable.

Use Add button to add new classes.

Click Done when you are done with
all the changes.

/1

L/

Done

2. To delete a Class, click on it on the left, then click on the Delete button. To add a Class, click on the Add
button. Once happy with the changes, click Done
3. On the Add/Drop Register that pops up, you can click on Done. The Add/Drop Register tracks when Classes
have been dropped or added to a student’s timetable and is presented to you mostly for information.
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ﬂRegister !EI
Claszes
D ate Clazz Add/Drop Semester/Term Drap/Period j
B [03r19/2014 | 3000HELS tsedded S000HE La SO00HE La [l The Add/Drop Register will be
09/13/2014 | FOD1010y Added FOD010y FOD1010p .
09/19/2014 | S000MATE Added S000MATE JO00MATE presented to you. The register shows
09/13/2014 | S0005CI6 Added 30005C16 50005 Clb
09/19/2014 | 900055Th Added 900055 Th 00055 Th you dates when Classes were added
09/419/2014 S000E LA Added 9S000E LAk S000E LAk or dropped' |t is for information only
09/19/2014 | S000DRAL Added A000DRAL 000D RiAE
09/13/2014 | NC31411a Added NCS1411a NCS1411a although you can make edits. Click
09/19/2014 | 3000ILA Added 9000IL4A S000ILAS .
11/13/2014 | 90004RTh Added 90004RT b SO004RT b Done to close it.
11/13/2014 | 3000MUSh Added S000MUSH S000MUSH -
Add Delate Pririt Diahe
|

3.11 Achievement Tab

You can view a student’s marks for the current school year in the Achievement tab. Both term marks and Final
Marks are available for viewing.

In order to see the marks after entering the tab, you need to first select the Topic-Based Marks radio button on
bottom left:

ﬂﬁtudent Records - Akoomalik, Carlton Harry =] B3
Fle Student ‘iew Help
Akoomalik, Carlton Harry Assessmentsl IE
Examsl Choicesl Notepadsl Custam F\eldsl Tlanspoltat\onl L\blaryl Discwplinal Lockerl
Letters: AKF 1019577 Biographics | Famiyw/Cantacts | Emergency| Ervolment| Attendance] Histors | Timetable ~Achievemert |
Status: This Year Only [ —
Home School: Yes Per. Class Marks
Alberta Student Murnber. Sem. 1 Final
1
No Picture 2
(Click here to i
add a picture) i
Sem. 2 Final
Bithdate: 06/28/1994 Age: 20 1:
Gender.  Male Grade: 12 2
Def. Chars: 3 Click on Topic-Based Marks to
Homeroom: Mot Assigned 4 MAT3793a Mathematics M N MW N N N

, s
|_{ see the student’s marks in this
Ethnicity:  Inuit 11 school year

—Step To Anather Student
[#iphabetical =l
Pievious I Hext I Select I

i " Camments / . ||
Based Marks Edit -

I [08/25/2014 [02:20FM

Then use the dropdown menu to see the course for which you wish to see the marks:
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Student Records - Akoomalik, Calon Harry

B Shudent  Wew Helo First pick the class

Akoomakik_ Caslbon Hasiy .Ms-esm:l | — using this dropdown...
Eramms| oo | Motepads | Costom Fiskds| Tiareportation | ooy | Decpine| Locke
Literz: AKF L Fy Bingraphicz | Famis/Tonisc: | Emeigency | Envcirent| Atendancs | Hato siabl Achisueneni | The term marks for
E WS that class for this
Home Schcat Tes [rzseceHiciing = .
Albzerts Sircherd Hussbes: i § student will appear
[ wheaic) | FeshEEcIN [ [ L 1—] hereif the marks have
Mo Picture 1 L] been entered.

1 44

(Click here 1o

aid a picure) Faral A doted | M The current Final
Mark is on the bottom
Gethclste: DEF20/1998 A= 200
fonder Wals firacke 13 row (cyan colour).
Diel. Chars

Homaen Naot Assigned

Edriciy  Inuit
Step Ta Arwaher Shudert
[Abhabelica ] C Mak: (" Comment: B
Poious | [t | Seeet | Jope Based Mk E |—
3.12Flags

Flags are a special way to earmark students. Different types of flags can be created based on the school’s needs.
Using flags helps the school staff notice that there is something special going on with a student. For example,
the school might want to flag students with severe allergies. Printed lists of students with flags can then easily
be produced and distributed to the teachers. Also, the flag is easily noticeable in the SIS when browsing through
student records. The flags are also visible on the connectEd side.

First the flag has to be created, then it can be assigned to students.

3.12.1 Create Flags

Go to Students -> Custom Fields/Tables -> Flag Definitions. Click Add to add a flag such as “Severe allergy”.
Type in the English Title, then pick a flag colour using the up and down arrows. Click OK once finished. You can
make the flag blink by checking the box “Blinking”. See the screenshot below for an illustration.

ﬂFlags

English Title:
[Eevere allergy
FErench Title:
| Creating a pink flag for “Severe Allergy”

in Students -> Custom Fields/Tables ->
<4— | Flag Definitions

Display Options

15

v Blinking

Previous | Mext | 0k I Cancel
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3.12.2 Assign Flags to Students

Once you have created a flag or flags using the method mentioned above, you can assign them to students after
opening their Student Record.

1. Open Student Records and find the student to whom you want to assign the flag
2. Click the flag button at the top-right of the student record window

@|Student Records - Aaluk, Tunalaaq Tunalaag

File Student Yiew Help / Click here to assign a Flag
Aaluk, Tunalaaq Tunalaaq Aasesaments| [ )
Exams | Choices | Notepads | Custom Fields | Transportation | Lisvary| Discipline ] Locker | 1/
Letters: AJX 2008199 Biogtaphics | Famip/Contacts | Emergency| Enoiment| Attendance| Historg | Timetable | Achievement
Status: This Year and Next Year T —  Custodh
Home Schoo ‘Yes Hichael & Ulipka Aaluk Special Custady? Mo
GN Student ID: 448443472 610 Po 325 Custodian: None
PO BOX 123 Lives With: None
. Pangrittung NU %04 0RO Legal Guardian: None
No Picture B67) 8351345
(Click here to
add a picture)
Bithdale: 12/17/2005 Age:8 + & - Paren - This Year
Gender Femals  Grade 2 Michael Aalul Homeroom: 2 24
Def, Chars: Niugtug, Mis. Doris
Homeroom: 2 24 Advisor Group
Niuqtuq, Mrs. Doris Wigika Ak, Not Assigned
) Grade: 2
Ethricity:  Inuit
- Emergenc: -~ Meataar
Michael Akl [867) 761-4452 Homeroom: 2 24
Ulipka Asluk: (867) 9509017 Niugtug, Mrs. Doris
Advisor Group:
—Step To Another Student Not Assigned
- Grade: 3 [ ]
Previous Mext Select Mame: Custody Print Edit -
[ [De72172014 [01:06 PM

3. Select the flag from the list, e.g. “Severe Allergy”, and click OK

Dml-ndFlage

b
mEmEE —

Click on the flag you want
to assign to the student,
then click OK

/

/

ar S

4. Now the flag should be visible on the top-right corner of the student record, see below for example :

B|5tudent Records - Aaluk, Tunaloog Tunaleeg

“
R a———— = The fla% Severe
en] = A Allergy” has been
Ashdk Tunalasg Tunalasg = .
Cxame l}nicMI Nmﬂ:l l::usbunrl:ksl T'-:mp:ul:liurl L 'H:l Dlibi:i!:l L:-qul assigned successfully.
Leters Al ARETYY Jographics th{ﬂm&l Erm'qa-wl En\:\huu:] mu'd.'.r-'.e] Hnlﬂpl Ti n:i.iml A.cfic\ﬂm.l
Sladiee Thi ¥ ean smnl Ml W Haling fdcimcs Cueicdy
Hone Schol: Yiow Mok L Ak Gpeeciel Cuthocy 7 M
EM Shakrd 10, 44843472 510 Fu 325 Cardix it Hune
A o
g dureg ot T chenn N orme
Mo Pleture T 01 M5
AChick b (1]
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4 Student Registration and Withdrawal

Registering students in SIS is a process that is an equivalent of adding students, using the SIS terminology. A
registration means that a student has been associated with the school for this school year, regardless of how
they attend the school (half time, full time, home-schooled, etc.). Students who are registered with the school
form the enrolment of the school.

When a student leaves a school to go to another community or to another school, the student is withdrawn
from SIS. The withdrawal is always recorded with exit date and a description of why the student left the school.
The student could have graduated or moved to another school, for example.

4.1 How to Add (Register) a Student

This section explains how to register (add) a student in Maplewood. Kindergarten students get a new
registration and a completely new record is created. On the other hand, for students who are transferring from
school to school a record should already exist. The trick is to find that record.

Step 1: Select Add New Students from the Students menu
Step 2: Enter the Surname, Given name and Date of Birth. Use the date widget to pick the date.

@student search E3

whether the student already exists in the database.

0 Enter student's bagic information. Thiz information will be used to verify

Surnarne: IAaIu
Given Name: ITunaIa Click this little arrow to
. open the calendar widget
[ ate of Birth: 12172005 E :l ( which will make it easier
| December | 2005 to set the birthdate
Cancel |
Sun| Mon| Tue|*ed Thu| Fri | Sat
1 2 3

|Select studert date of bith| 4 | 5 [ 5 [ 7 [ 8 [ 3 |10

11 |12 (13| 14 | 15 | 16 iﬁ

18|19 20| 2 22 23 4
2502 | 27|28 29 0 A

[ _ [
Step 3: After entering the three fields, click Search to search for the student in Maplewood’s database
Step 4: Either the student is found immediately in the database and you are taken into the Add New Student
screen with their information pre-filled; or no matching student was found (see below):
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Mo Student Found

':0] Mo students Found that match current criteria,

No matching students were found in the
database. This could be because you searched

the student using an incorrect spelling and/or
incorrect birthdate. Click OK to proceed.

41.1 No Students Found that Match Current Criteria

If no student was found to match the search criteria, then you may have typed an incorrect name or birthdate
for the student. In the next step, the Advanced Student Search screen allows you to see close matches and do
further searching.

’

This screen offers you a selection of students to pick from, suggesting “maybe this is who you were looking for”.
It is also possible that the student did not actually have an existing record yet. This would be the case for
students entering a Nunavut school for the first time, such as Kindergarten students.

Step 5: Look through the results and see if one of the close matches could be the student you are trying to add

to your school:

ﬂndvanced Student Search H=]

0 Multiple matches found bazed on surmame, given name and birthdate, Pleaze select ane of the entries from the following lizt or enter other names
to search on.

—Find Student

Surmarne: I,r.\a|uk [~ lgnome Sumame Birthdate: |12,-'1 29003 E:I [~ lgnore Date of Birth

Given Mame: ITunaIak I lgnore Given Marne Gender
= Male = Female [ Ignaore Gender

tiddle Mame(s): I [~ lgnore Middle Mame(z] ’7

GM Student [D: I [~ lgnaore GM Student |0
Search |

—Search Rezults

AkA | Date of Birth Gender Enty to Elem/Sec | GM Student [D

¢ Aaluk. Tunalaag Tunal... 124174

\ See here for close matches. We have found a match

here for our search. The actual name registered with
was Aaluk, Tunalaag. Click to highlight and select.

udl | i
pi+ Accept and enrol the selected student Detai
" Errol this student as a new student [Student not found in Maplewh &I
AT \> DK | Cancel |
I— Only use this option for students who are
entering a Nunavut school for the first time. It

creates a completely new, blank student record.
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When a match is found, highlight/select the student by clicking on her and choose Accept and enrol selected
student at the bottom. Then click OK.

If you are absolutely certain that the student does not exist in the database, select Enrol this student as
a new student (Student not found in Maplewood) and click OK to create a completely new, blank
student record in the database. A new GN ID number will be generated for the student.

4.1.2 Fill in the Details for an Existing Student

If you selected an existing student using Accept and enrol selected student in Step 5, you will be brought to the
screen below. Fill out the mandatory fields denoted by an asterisk (*). Also fill out This Year’s Grade and

Homeroom on the right.

(] Add New Student - x
S X Fill in the details
Mame hralment Biographics for:
Legal Hame @ |This “Vear and Mext Year ﬂ Date of Bith Gender s |
tatus: see lower
Legal Sumame:  Tunalaaq B o i 05/05/1980 Male
down.
GivenMame:  Aaluk Enty to Sec. Schook 08/06/1985
Middle Mamelz): Entry date to this schaal; 08/22/2014 v: - Entry Date to This
Werfication i - - School: the day the
. Ho Document Provided =Reg Ent. Status: X0 310 - Transfer-in from . v : :
DwemER: = - el | [112 107 Hammond Meril student will be in
Dacument Number: 0: (rigin Schoal ‘:| Urknown ﬂ > g attendance
T T T L izor oL e
Frefened name Evit Date: MM/DDAYYY ]| = o
Sumame: _ o Registration Entry
Exit Descrphion: | Unknawvn J Nest Yoar Status: pick the
Ef:;ed Dest. School | Unknawn 23] | ([Grade: = most appropriate
GM StudentID: 448443472 Ethnicity: Inuit HleesE value
Alias Mames Maother Tongue: English | ﬂ Origin School if
Advizor Group: .
Preferred Language Unknown | J transferring in from
of the Student: h
1zt Reporting Language: Englizh another school
. . Defined Characters
Curtent Home 5 akku School 2nd Reporting Language:  InukRitut |D ﬂ |D ﬂ |D ﬂ |D ﬂ Grade for this year
Schoal: r
Homeroom for this
= Indicates required fields oK, | Eeries] | vear (if applies)
I
Enrolment

e Status: If the student is registering for this school year, set the Status to “This Year and Next Year”. If you
are pre-registering the student for next school year, set the Status to “Next Year Only”

e Entry to Elem. should be set to the first day of elementary school (if known)

e Entry date to this school should be set to the actual date the student starts school

e Set Registration Entry Status by picking from the dropdown. Select most appropriate value. This field
describes how this student came into this school.

e If the student came from another school in Nunavut, pick the Origin School using the dropdown. The
Origin School cannot be your school.

Biographics

e This Year: set Grade and Homeroom to the correct values for the current school year
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e Next Year: set Grade and Homeroom to the correct values for Next Year if you are pre-registering the
student for the next school year.

4.1.3 Fill in the Details for a Completely New Student

If you selected Enrol this student as a new student in Step 5, you will be brought to the screen below. There are
fields with red asterisks (*) beside them in the Add New Student form: these are mandatory fields to fill.
However, fill out as much information as you can. For Registration Entry Status, use “200 — New Registration”

when creating a completely new student record.

ﬂndd New Student =
—Mame — Exrolment — Biographics
Legal Marme Statuis: I This Year and MNest Year j - Date of Bitth %Ender
x I—EH I ale:
* Legal Sumame: I.-'l.bakumova Entry to Elem. IMM.-"DD;"Y"('\"‘I’ [ﬂ;l [EE /202005 = Female
* GivenMame:  [Bababa Entiy date to this schook ~ [1210/2112  [&] | |~ 1pis Year
Middle Name(z] I =Heqg. Ent. Status: |2IJD - New Reagistration j Grade: IK 'I
Een[cl:ff;gz? ICanadian Birth Certificatej Drigin School: IUnknnwn jﬂ IHnmernom: j
Document Mumber: |341 544 E it Diate: |MM£DDW =] Ao
vizor Group:
Freferned name E it Description: ILlnkanﬂ j I j
’ Bhak
Surnanne: I akLmOa Dest. Schaoal ILInknown jﬂ  Mest Year
Preferred IEababa h
M ame: Grade: IK "I
GN StudentID: | =Ethricily: f it || Homeroom:
Alias Mames tMather Tongue: ILlnknnwn j I j
Advisor Group:
Frefermed Language IUnknown j
of the Student: I j
=7zt Reporting Language: IEninsh j Dfired Charmc
— Defined Characters
2nd Reporting Language: |English hd
= | | A Ar Aar =
[~ French Language Entitlement
* Indicates required fields o | Cancel |
| ]

Add New Student form for filling out information for completely new students. Use “200 — New Registration” as Registration Entry
Status for students entering the Nunavut school system for the first time.

Explanation of the fields in the above screen:

Name

1. Legal Surname and Given Name should be taken directly from the Verification Document (such as a

Birth Certificate). Please take care in ensuring that the student’s legal name is used here!

2. Verification Document should be always requested from the student to verify the legal name. If not
available, please make sure to choose No Document Provided.

3. If there are other names the student uses, such as nicknames, they should be entered as either the

Preferred Name or an Alias. Click the Add button to add aliases.
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Enrolment

1. Status:
o If you are pre-registering students for next school year, set the Status to Next Year Only
o If this is a new student entering during this school year, set the Status to This Year and Next
Year

Entry to Elem. should be set to the first day of elementary school for the student, if known

Entry date to this school should be set to the date students starts or started at this school

Set Registration Entry Status:
o 200 - New Registration for new Kindergarten students or for students who have not previously

attended school in Nunavut

o The other values are applicable only if you are enrolling a student who already has attended
school in Nunavut and has an existing record. See the end of the document for a complete
table.

5. Set Ethnicity to the appropriate value
Set 1* Reporting Language and preferably also 2™ Reporting Language if the student’ s family should be
getting reports in two different languages (e.g. English and Inuktitut)

Biographics

e This Year: Set Grade and Homeroom to the correct values under This Year if here if the student is added
during this school year

e Next Year: set Grade and Homeroom to the correct values under Next Year if you are pre-registering the
student for the next school year

4.1.4 Fill in Contact information

Adding Family/Contact information will make it easier in the future for teachers to connect with a student’s
parents or emergency contacts if necessary. Do this be editing the Family/Contacts tab in Student Records. See
the Student Records section of this document for more details on the Family/Contacts tab.

4.1.5 ISSP and French Eligibility

If the student is on an ISSP (Individual Student Support Plan), go to his/her Student Record, go to Enrolment tab,
and click Edit. Check the boxes as appropriate. See illustration below. Click OK once done.
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Lither Fields 1 Pre-Registration for Other Schoals in District ]

Status

% This year and Mext year
™ This wear only
" Mest pear only

" Deleted [withdrawn)

Registration Status:

Origin Language

Entry to Elem. Schoal:  |09/02/2014 =k Preferred Language:
Entry ta This 5 chool: ]WEF ’W‘
Registration Entrp Status: 12t Feporting Language:
‘310 310 - Transferin from a schaol W|th\nﬂ |English ﬂ

2nd Reporting Language:

Iinistiy [nformation ‘U . J
nknawh -
GN Student 10:
Masked | g5, schost Fiter AlSchoos 3|
Alberta Student Mumbe ‘Nakasuk Elern. School lqalit] (Hu, ] ﬂ [~ French Entitlement
Citizenship: e
Jurkocun 2| | e o B[Rt
Student Autharization Expin D ate: Exit Description: Schedule -
i =] ‘Unknown J R P T
Werification Documnent: - . egshation Type
Destination Schook  Filker: A 5 chaols J ’—L|
|Unknown ﬂ ‘ Unknown J
o] b Mumbs
SeumEnt FUhet Resident Board Frograms
Doc. lssue Date: [ 7 =, S ISSP
Mother Tongue: ‘Unknown ﬂ ||: :EE
|Engish = [ 1P
- e Entry Date to Canada: Tagrarn
Canada Birth IZ‘V hd

Ethnicity

Iruit 2

Entered inta Maplewood:

41.6 Home-schooling

——

Check this box if the student is eligible
for French language instruction under
Section 23.

Check any applicable ISSP boxes

Click OK once done

If the student is home-schooled, edit the Enrolment tab and set Registration Type field to one of the home

schooling options as illustrated below. Then click OK.

Aegatzation T pp=

| =

[aroup Home

Hame Schooling S0-100 &

I_.'_.-_ TI r i . J

sl
Werlicalion Documert Destination Schaat  Fikar &1 Schools J
[Unkrraem =l pr— =]
Drocwment Humbsi, | =

Fiezidant Bioard

Do esue Dabe ;o . P—
tather Tangue Irdeminwan ﬂ
|IW|in‘ it |
v B.ur”n Eriny Db ba L '-r.':h

Lanads Bisth == B

Hame Sohooling 100 %
Magnet Faciiy < 50 %

Magnel Faclly S000 %
Magnel Faclly TO0 %

‘rbeead inlo Mapkeeood

=l

[en1/2ms [
|

| Cancel |

4.2 How to Withdraw a Student

This document explains the process of withdrawing students from a school. A student must be withdrawn when

s/he has transferred to another school, has been absent for 21 days in a row (dropped out), or left for some
other reasons. A student that is no longer attending the school should always be withdrawn from the school

even if it is likely that they will eventually return to the school.

1. Go to Student Records and search for the student you would like to withdraw. Open their student record.

2. Go to their Enrolment tab and click the Edit button at bottom right.
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Lo Hars
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ﬂEnrullment - Maluiyuk, Angel {Angel) B

Enrallmert | DOther Fields I Pre-Registration for Other Schoals in District I

— Statu
{7 Thiz year and Mest year
7 Thiz year anly

7 Mest pear anly /
i+ Deleted [Mithdrawn]

— Ministry Infarmation

GM Student 1D IDU2D1 0361
alberta Student Mumber: I

Citizenzhip:
[~

ICanadian Citizen

Student Authorization Espiy D ate:
I_a’_a’_ E :‘

Werification Document:

=
Doc. lssue Date: I_;_;_ E :I

Fother Tongue:

I Unknawn
Document Mumber:

//

information

Click Edit to edit the student’s
enrolment (registration)

— Origin
Entry to Elem. School:  |09/02/2014 S:
mar |0e/27i2012 [ -

IEIEJD'IQD‘I? E:I
Registration Entry Status:

I'IDD 100 - Continuous Fegistration j

Registration Statuz

Entry tg See-
Entry ta Thiz School:

IEninsh 'I

1zt Reporting Language:

IEnin&h 'I

2nd Reparting Languaags:
| I T vi

I French Entitlernent

:M
™[ Preferred Languange:

Set student Status to
Deleted/Withdrawn

\
| |

Change the
Registration Status
to Withdrawn

Origin School; Filter: &ll S chools > |
[ gsamit linniarvik (lqalut] (lgaluit N, ] x| | [ Attendance
— Retirement IF'-"" Time j
E it D ate: |09f21 f2mv E :I
. A S
Exit Description: ~ Registration Type
|21 200 Transferred within Munawut j Y P |

Destination Schoal:  Filter: All Schaols LI

(et
N R s s s

—

I Maani Ulujuk. llinniarvik [Rankin Inlet) (Mu, ] j

> Programs

~
ISSP

— Resident Board

Source:

IUnknown j

Ilnuktitut j
- Entry D ate to Canada:
Bormin
2 Canada IBi[th E :I

[ IEP
[~ IBP
[~ 14P

[~ Alemate Program

r— Ethnicity

Ilnuit 'I

Entered into Maplewood: 05/23/2017

[ ok |

Cancel

|Select the studant's origin schaal from the: list

Give an accurate Exit
Date (the date
student stopped
attending), give Exit
Description** and
assign Destination
School if the student
transferred to
another school.

** see the next page
for Exit Descriptions.

3. Select Deleted (Withdrawn) under Status. This means that the student is withdrawn from your school’s
enrolment and the record becomes available to other schools.

4. Under the Origin section, change the Registration Status to Withdrawn.

5. Under Retirement, set the Exit Date to the date the student stopped attending at the school. Use the date

picker widget by clicking the little down-pointing arrow.
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6. Set the Exit Description by selecting the most accurate option from the dropdown menu. See below the

possible Exit Description values used in SIS.

7. Set Destination School if the student is known to transfer to another school. Note: please notify the

destination school principal about the transfer!

8. Click OK when done.

4.2.1 Exit Descriptions

Exit Description

Use when...

Completed prescribed course
of studies (no diploma)

The student completes legal requirements for attending school in Nunavut but does not
graduate before leaving the school system

Unknown

The exit reason is unknown and it will be filled later once the reason is known

Transferred within school
region

The student transfers to another school within your school region

Transferred within Nunavut

The student transfers to another school in Nunavut but outside your school region

Transferred to other province
or territory

The student transfers to another province or territory

Transferred to other country

The student transfers to another country

Deceased

The student has passed away

Disciplined out

The student has been withdrawn from the school as a disciplinary action

Left school for health reasons

The student has withdrawn from school due to severe health reasons

Seeking employment

The student has withdrawn from school in order to look for work

Gone to work

The student has withdrawn from school in order to go to work

Pregnancy The student has become pregnant and is not in a physical state to attend school
Child care The student is looking after a child and cannot attend school

Sports The student has withdrawn from school in order to pursue sports

Dropped Out The student has not attended school for at least 21 days in a row

Other If none of the descriptions apply, use “Other”

Created in error

The student was enrolled in the school in error and then had to be withdrawn to correct
the mistake

Graduated with diploma
(continuing post-secondary)

The student graduates and it is know that they are going to a certain post-secondary
school after that

Graduated with diploma

The student graduates

4.3 Concurrent Students

Concurrent students are students who are concurrently, or simultaneously, registered in two or more schools. In

Nunavut, there should not be any concurrent students as schools do not normally share students. If a student is

flagged by the SIS as concurrent, then it means that a school has forgotten to withdraw a student when the
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student has left the school. The only exception can be found in Igaluit between the high school and the French

school.

Only one school can be a students’ Home School. The Home School has full ownership of the student record and

has unlimited permissions to the record. The other school will have Home School: No (Concurrent) in the

concurrently registered student’s record and has limited access to edit the student’s core data.

It is important to resolve Concurrent Students by:

a) Finding any concurrent students in the school

b) Determining which school should be the home school for concurrent students
c) Withdrawing the student from the school that is not the home school

4.3.1

Find Concurrent Students

Concurrent students can be detected in the Search Students screen after clicking Student Records:

ﬂSelect Students [ %]
—Eilker Include students registered Incl Al Mames
Search By: IPartiaI Mame j ¥ Both this and next year [V Name Changes
Search On: ISumame j M ¥ This vear anly [nat returning) ¥ Aliases
. Search [
Szt iz I J [V Net year only Matches found on alternate names are highlighted
Search: Ia o U Seniets [ Deleted [withdrawn] with the alternates shown in a tooltip window.

Status Home Schaool
Aggark Jeanne-bdaria Walentina Jeanne-baria 1 g 98 27432
Ahegona Shyanne Shyanne 7 78 33634
Akammak Paul Paul Aggark @ 5 107285
Akilak Hattie Hattie | 94 006051
Akittirg Gilbert Gilbert 1 14 02753¢
Akittirg Pearl Pearl E B/7 ikl
Akoomalik Carlton Harry Carlton Thiz Year Only 12 19589<
Akoomalik Pamela Ernily Pamela 3 38 nan4s4
Akulukjuk Francis Francis 10 Jatsiatatcys
Alagalak, Adin Myles Adin 5 ) R4434E
Alaralak Wincent Wincent 1 14 049645
Alariag Alexander Alexander Allurut Thiz Year Only 12 30590z
Algona Enosh Enosh 4 48, 149871
Ak atukbuk, Carter Carter 1 1 821547
Aliketiluk, Julianne Julianne Thiz Year Only 12 TI4ERS
Alipak Donavan Donavan 8 78 159398
Alookie Tom Tom Alookie Deleted [withd... 2 28 -
[ | 3 I
Total Students: B3 Print | Methad Ok | LCancel

Indication of a
Concurrent
student

Also, if you open the student’s Student Record, the sidebar says: Home School: No (Concurrent)

ﬂstudent Records - Akammak (Aggark}, Paul

File Student Yiew Help

Akammak [Aggaik], Paul

Letters: AdY
Status: Thi
Home Scha
Alberta Studen

2003788

No Picture

[Click here to
add a picture)

Bithdate: 05/12/1999 Age: 15
Gender:  Male Grade: 8
DefChas: @ O 0 O
Homeroom: Mot Assigned

Assessments |

Ekamsl Chnicesl Notepadsl Custom Fialdsl Transpoltaliunl L\braryl Discinlinel Lackell
EiUg[aphiCSI Fam\lw’Canlactsl Emergencyl Enmlmenll Attandancel Historyl Timatab\el Achievememtl

M= E3

]

— Mailing Addr r— Custod
Peter & rvonne Akammak Special Custody? No
40F.0. Box 96 Custodian: None

Baker Lake Alberta X0x 141
[867) 476-9595

Lives With: None

Legal Guardian: None
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Parent

Peter Akammak

“vonne Akammak

r This ‘Year

Advisor Group:
Mot Assigned

Cell: [867) 521-2762

Homeroom: Mot Assigned
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To produce a list of concurrent students in the school, follow these steps:

1. Go to Student Records
2. Type “%" as the Search word (means: show everything) and click Search:

SJSEIE:I: Students

Search [

Filter

Search By |Partial Name =
Search On: ISumame j
Search Item; J
Search: Iﬁ

v Use Soundes

3. After the search results show up, showing ALL students, sort the rows by Home School by clicking over the
Home School column. Click once more on it to sort all the No (Concurrent) students to the top of the list.

Now you can see all your concurrent students at the top of the list!

SJSelect Students
— Filter Include students registered Incl Al Mames——
Search By: IPaltiaI M arne: j ¥ Baoth this and nest year ¥ Mame Changes
Ssarch Un: |Sumame =l M [ ¥ This pear orily [not returning) WV Alisses
. Search
Search lten: I J [V Mext year anly Matches found on altemate names are hig
Search: |°/= v Use Soundex [V Deleted Wwithdrawn)] with the altematw
 ——
; e
Apzaktaun Charlotte Charlotte Alariag Deleted [withd... Mo 2 28,
Mitzima Geetesta Geeteeta Muckpa Deleted [withd... Ma 12
Mutarariag Anthory Anthony Matanine 1 Deleted [withd... Mo 12
Olapuk. Joshua Brandon Joshua 1 Deleted [Withd... Mo 7
Aaluk Tunalaag Tunalaag Tunalaag 1 2 28
Aggark. Jeanne-taria Walentina Jeanne-taria 1 9 94
Shegona Shyanne Shyanne 7 T8
Akilak Hattie Hattie 9 94
Likitting Gilbert Gilbert 1 14
Aikitting Pearl Pearl E EAT
Akoomalik, Carlton Harry Carltan Thiz "ear Only 12
Akoomalik, Pamela Ermily Pamela 3 38
Akulukjuk, Franciz Francis 10
Alagalak Adin Mylez Adin 5 Ra
Alaralak Wincent Yincent 1 14
Alariag Alexander Alexander Al This Year Only 12
Algana Enosh Enozh 4 44,
il |

Click on Home School
here to sort the
students by their
Home School status.

Click AGAIN to get the
No (Concurrent)
students to the top.

4.3.2 Resolve Concurrent Students

Now that the concurrent students are known, it is important to determine if this school is supposed to be their
Home School. If not, then the students must be withdrawn from the school.

You can see what the other school is by opening the concurrent student’s record and clicking the Other Schools
button in the sidebar on the left. There you can see the other school who is claiming the student.

After determining which school should “own” the student and has the student in physical attendance, the other
school must withdraw the student following steps in section 4.2. A phone call with the other school is usually

required to sort out these situations.
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5 Staff Records

Staff Records are maintained in SIS for all teaching staff and staff that need to use the Student Information
System. Staff records do not contain as much detailed information as the Student Records but are similar in

nature. For staff, the most important information to record are names, security roles that limit access to various

parts of the system, teacher certification numbers, and teaching timetables.

5.1 Add Staff Members

Add all teaching staff into your school in SIS. The process is similar to adding a student but simpler.

Go to Staff -> Add New Staff Member and fill in the information as show below:

Enter the name of the staff member. It is not necessary to
include both Surname and a Legal Surname. Middle Name
and Title are optional as well. The Usual Name will
automatically populate with the first name.

B)Add New Staff Member

Gender has to be entered.

Sumame: |Smith Gender -
[ " Female  Male

Legal Sumame: |
Given Name: | Tiktala Birthdate: IMM/DD.-’YYYY : ‘
Middle Name: | Title:  [Ms.
Usual Name: Tiktala

Role: Teach?
Teacher Cert.#: ISB‘EIEISE‘_ connectEd Security roup: | Teacher

Birthdate is not
necessary to include

/

K Select a connectEd
security group if the
staff member will be
connecting through
connectEd. The default
is Teacher and this

_—

works 99 % of the time.

An employee number must be The Nunavut Teacher

The Role defaults to T for

created and must be unique. Use the
following convention to create the
number:

<School Number><4 digits>

For example at Jonah Amitnaaq
Secondary School, 0580001 would be
the first staff member, 0580002
would be the second staff member,
etc.
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certificate number must be
entered here. If the staff
member is not teaching,
then it can be left blank.

Teacher and the Teach?
checkbox should be checked.
Use Role = P for Principals and
Vice-Principals. Consult the
Notes for more information if

this person has a different role.
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51.1 Role

e Roles are predefined settings in the database which can affect what or how a user can access menu
items and fields. The default is T for teacher. The following Roles are possible. The ones highlighted blue

are relevant to schools.

o T = Teacher

o P
o D
o

C

e ConnectEd is the service that Teachers access via a Web browser to connect to the database. The
ConnectEd Security User Group will default to Teacher and is fine in most cases. However, there may be

Principal
SST (Student Support Teacher)
SCC (School Community Counselor)

other user groups in the future.

e The Teacher Certification Number needs to be entered for school reporting if it’s available.

5.2 Remove Staff Members

When staff leaves your school for good, you should remove their staff record.

1. Go to Staff -> Staff Records

2. Type the first letter of the last name of the staff member (e.g. ‘a’). Double click the name of the staff member

when you see it show up in the list.

mSElEEt Staff Member

Staff Member

|d
Staff Member

Akana-Power, Helen

Alagiak, Bella

Statuz

o]

Cancel

Type the first letter of the last
name of the staff member

Double click the staff
member’s name to open
his/her record
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3. Go to Timetable tab. If there are Classes showing in the Timetable tab, then you cannot remove the staff
member; you will first have to go to File -> School Setup -> Classes to unassign this teacher from any classes that
she may be teaching. The teacher below has nothing and is ready to be removed from the staff records.

ﬂstaﬂ' Records =1

File Personal Employment

Amagoalik, Malaya [Mrs. ] Biographics T Employmentl Certifications I LCustoni P No_tepadl
Letters:  bp 000000956446 imetable - Day 1

- \
Statuz:  This year and next year Per. I Clasz ITitle I Rioom I Stu\

Sem. 1
1

N
\

Teacher Cert. #: 0000001 749

N O Pictu re \ This teacher has no
Sem. 2 classes assigned to her
(Cli':k here to 1 |< and she is ready to be
add a pict ire) : / removed from the
1 / system.

— Step to Another Staff——————————— \
& Thi
Previous Mext Select I s el et i

I [Crrzarzor4 [0421 FM

4. Go to Biographics tab to make sure the teacher has not been assigned to a Homeroom. If the teacher has
been assigned to a Homeroom, then you must first go to File -> School Setup -> Rooms/Homerooms to unassign
the teacher from the Homeroom. The teacher below has "Not Assigned" next to Homeroom and is good to go.

ﬂstaﬂ' Records [_ =] =]

File Personal Employment

Amagoalik, Malaya [Mrs.] i I Timetable I Emplo_l,lmentl Certifications I LCustom Fieldsl No_tepadl

Letters: bp 000000956446 — Mailing Addre: =

Status;  This year and next year ﬂ léirl'?du;g?: English
®0x 141 Gender: F - Age:

Teacher Cert. #: 000000174954 [BB?] 520-2638 Role: Teacher Teach?Y
Amagoalik Malaya Malaya@EM
aplewood.com hd

N P A t — Personal Information————————————
ﬂ |C u r'E M arital Status: —Wehicle
CI' k I- t Spousze's Name: Type:
1C 12re to Previous Mame: Malaya .
( . Health No.: 664134514922 ol )
add a picture) e —— This teacher has no
( — This Year N\ Homeroom assigned to
Homercom: Not assigned her and she is ready to be
i~ Emergency Infarmation removed from the system.
- Mext vear
Homeroom: Mot assigned
— Step to Another Staff
Previous Mest Select I Name | Edit |

| [O7/za/2014 [0425 FM
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5. Finally, go to Employment tab and click Edit.

ﬂstaﬂ Records M=

File Personal Employment

ﬂiugraph\csl Timf{ltable Custo Fialdsl NULEpadl

Akana-Power. Helen

Letters:  aa 000000890001 — Teaching Histor
Status: This year and next year Teaching Since

At This Division:
Teacher Cert.H: At This School

Source School:
Unknown
Transfer Date:
Destination Type:
H Destination 5chool:
No Picture [l

Employment Type: Full Time

{Click here to
add a picture)

= ™N
Step to Another Stalf
’7 Brevious | Hext Select I‘ ( Edit >

6. Select Deleted (Ret./Trans.) and click OK.

ﬂEmplurment Record E3

Teacher Certificatet:

— Teaching Histomy

Teaching Since: I WM DD AN :I

Status

™ This year and next vear
" This year onl

At This Divigion: I MM DD Y :I
At Thiz Schoal: I MDD Y :I
Source School

IUnknown j
Transfer Date: I 03/03/2013 :I

Destination T ype:
IDthel j

Degtination S chool:

Return D ate: I MM ADD S :I
Employment Type: IFuII Time vl

[Select the staff members's status. T

If this area is grayed out, it means that you
cannot Delete the staff member yet because
s/he has been assigned to homerooms or
classes. If so, go back to steps 3 and/or 4 to fix
this. Then come back here again.

5.3 Teacher Accounts

When the school’s SIS administrator add staff members using the Staff menu, their connectEd accounts are

created automatically; there is no need to create them separately or to send account requests for them. The

accounts just need to be printed from SIS by the administrators of the school, then provided to teachers:

1. Go to File -> Change Security -> Maplewood connectEd Security
2. Open User Manager by going to Users -> User Manager
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ﬂ Maplewood connectEd Security Administration -... — [0 x|
File Policies Defaults | Users Help

- Manager...
Permissions Manager...
Accounk Settings Manager. ..

Prink Users, ..
Send Account E-mail...

[wiew, edit, add and delete uzer accounts. | 87262014 | 02:08 PM

3. Once the User Manager opens, select User Group of Teacher at the top:

[Juser Manager -0l =|
Filter Accounts:
On Select Al

it Select Mone

| Description | Active | o
es
aihe i es
ad Eetoolook, Kevin ez
an Eetoolook, Mary Yes
aa Etunga, Peggy Yes
ac Hill, George Yes
av Hallingzwarth, Rohan Yes
an Immingark., Christine MNa
ak. Ittunga, Ellen Yes
az K.avanagh, Deirdre Yes
au LeBlanc, Lauren es
ag Lee, Jonathon Yes
an McFadden, Jordan Yes ﬂ

sad | Edt |  Delete Piint Done |

|Choose which group of account you want to select,

4. Click Select All at top right. Then click Print at the bottom:

ﬂ User Manager
User G ; Filter Accounts:
€1 laroup: |Teacher ﬂ  On
Uger Mame: | (+ OFf Select Mone

Lser Mame | Full Mame | Description | Achive | -
ay Akerley, Bil ez

aw Corbett, Alizarn Yes

ad Eetoolook, Kevin Yes

an Eetoolaok, kam Yes

aa Etunga, Peqay Yes

ac Hill. Gearge Yes

av Hollingzwarth, Rohan ez

an Immingark., Christine Mo

ak. Ittunga, Ellen ez

az ¥.avanagh, Deirdre ez

au LeBlanc, Lauren Yes

ag Lee, Jonathon ez

aq tcFadden, Jordan ez j

add | Edit Defete Pint | Done |
N —
[Prirtt selected accounts.

5. In the following Print User Accounts dialog, select List (One account per line) under Print Format:
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H Print User Accounts - 1Ol x|

" Detailed [One account per page]

Security Mote
r
r
=
[
ak | Cancel |

6. Once the report opens, click Print to send it to your printer or click the little arrow next to the Print button
and select Save to PDF to save the report in PDF format. Save the PDF to the Desktop so that you can easily find
it.

ﬂPrint Preview - (O] x|
171 R, #
Zoarm Seal Prink
Print .
MNetsilik llihakvik Current Page

Save to POF

Teacher Account List

Full Narne | Usar Marne Faszword
Active

5.3.1 Reset Teacher Passwords

We have provided each school principal with the permission to go in and reset teacher passwors in SIS. Itisin
your best interest to ensure your teachers know their password or have it easily accessible. Otherwise, you will
be resetting passwords more often than you ever want to. Some schools keep a “password book” in the school
safe to teacher passwords can be easily retrieved.

ConnectEd passwords and accounts have been set to never expire. How your school manages staff passwords is
entirely a school matter.

The SIS Administrators have set permissions and user accounts so that teachers have the ability to perform daily
tasks without hinderance. Please follow the instructions below ONLY to change a teacher’s password.

1. Go to File -> Change Security -> Maplewood connectEd Security:
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_'ianlrwnml Enterprise (Elementary) - Sam Pudlat School
Fle Students Staff Reports Incderts Attendance Marks Scheduing Hep

‘ Changs Date

School Setup »

Mairtenance 4

Imgort 3

Web Update Close
—— ymation:

Printer Setup :
—

Seflanguage P Rrmaca

Maplewood News Centie

2. A grey full-screen window will appear. Choose Users -> User Manager:

ﬁ]Maplewond connectEd Security Administration - Sam Pudlat School

File Policies Defaults | Users

ermissions Manager...
Account Settings Manager...

Print Users...

3. From the User Manager window, click the teacher name and then click the Edit button:

iilhrr Manager =1 E3
User Grow: [z =] sy Setect Al
 On Eiaf | ____l
Uszer Name: l « Off Stid=ris I Select None I
User Name | Ful Name | Descipton | Active | o
AKF Adla, Areg Yes
LKL Adls, Koonco Yes -

Click on the teacher whose password you
want to reset and then click the Edit

as Adla, Qatauga Yes
ADMINISTRATOR  ADMINISTRATOR Defauk administrato. .

AEA Akesuk, Eva

AKG Akesuk, Josnre button lower down.
AKD Akesuk, Maic

AEH Alznaqg. Niviagsi Ki.

AKX B Alarag. Ta) &

AK| Ashevae, John
AXE Ashoona, Jearita
ac Bel. Kmawk

oeue | P | Dove |

4. Next you will see the Account Properties for — (user name) window which looks like this:
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ﬂ Account Properties for - MKing (King, Michael) |

User Mare l Settings ] zer Groups] Permissionsl Login Hoursl

Account Information

Uszer Mame: MKing
Full Mame: King. Michael

FPazzword Question: What iz the name of my simian fiend?
Password Answer: Cheetah

Key: 20R 3537551

Edt |

Dione

Change Key

5. Go to the Settings tab and click on the Edit button. If the Account Locked Out box is checked it needs to be

unchecked:

ﬂ Account Properties for - MKing (King, Michael} ﬂ

31 Gmups] Permissionsl Login Hours]

ﬂ User Settings For - MKing {King, Michael}

User Mame and Description

Account 5etl

Go to the Settings tab ...

User Mame: ‘MKing

Full Name: [King, Michael

[v Account Active [ T CrEnge Fassmond

[v Account Never Expires [ Must Change Pazsword

v Pazzword Mever Expires v Account Locked Out

Activation and Expiry Dates

Account Activation D ate: |5,.?25£2E|‘| 5 10:54:00 &k

Account Expiry D ate: |N ane

Drescription:

Key: 20R 387551

Account Activation

v Active I

teation Date/Time: [ g5,26/2015

Account Settings

[v Password Mever Expires

[~ LCan't Change Password

at Mext Login

... and clear the Account
Locked Out checkbox

Account Expiry
[v &ccount Mever Expires

07/23/2M5

Expiry Date/Time:

Change Pazsword | QK. | Cancel |

| 7/28/2015 | 03:47 PM

e
( Edit )
B

.. click on Edit ...

Done
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6. Now let’s reset the password. Click the Change Password button in the same window:

ﬂ User Settings For - MKing (King, Michael}) x|
Uszer Mame and Description Account Settings
Uzer Name: |MKing Iv¥ Password Newver Expires

[ Can't Change Password
Ful Namme:  [King, Michael = !

[ Must Change Password at Nest Login

Description:

Key: |20R 387551

Account Activation Account Exping

[ Active ¥ v Account Mever Expires

Activation Date/Time:  [[526/2015 Expiry Date/Time:  [1j7,20,9015

‘ Change Password | ’ ak | Cancel |
I

| | 7/428/2015 | 03:47 PM

7. In the Change Password window you will be asked to enter the new password and to enter it again for
confirmation. Also, enter a password hint and the answer to the hint (the hint cannot be the same as the
password). It is advisable to have the teacher present to set the password, hint question and hint answer.
Once you have entered the information, click the OK button.

ilchange Password B3

Enter Password: Il The Hint Question and Hint Answer could be
something like:
Hint Question: “What is my favorite food?”

Hint Question: I / Hint Answer: “Nattiminiq”
I «—

The hint question and answer can be used by the
teacher to reset their password by themselves.

Confirm Password:

Hint Answer:

| oK I Cancel I

8. We are done unlocking the account and resetting the password! Click the OK button, click the next Done

button and choose File -> Exit from the menu at the top left corner to exit connectEd security.

Have the teacher then attempt to log into their ConnectEd account. If they are unsuccessful, you may need to
do this process again.
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6 Setting Up SIS for the Current School Year

This section explains how to set up SIS for the school year in the fall, the ‘Current’ school year. The work consists
of updating staff lists, setting up the Calendar, setting up Classes File, assigning Homerooms (if applicable),
assigning Classes and printing reports to verify that the work has been completed correctly.

6.1 Read First

1-SYSTEM DATE WHILE DOING SETUPS: It is strongly recommended to set the system date using File ->
Change Date to the first day in the calendar (first day of school for students) especially when working with
student timetables. This way any class that gets added to a student's timetable will have an Add date of the first
day of school. If the class Add date is later than the first day of school, then no attendance can be recorded
between the first day of school and the Add date. The Add date can be cleared afterwards but this means more
work.

2 - CALENDAR START DATE: the first available date in the Calendar should be the first day of school for
students. To check this, go to File -> School Setup -> Calendar -> Edit. The first date in the calendar that is not
greyed out is the first day of school for the current year. Ensure that date is correct.

6.2 Update Staff list and Print List of User Accounts

Newly arriving staff need to be added to the system and leaving staff need to be removed if you have not
already done this in the previous spring.

Quick steps for adding staff: Go to Staff -> Add New Staff Members. Fill in name, employee number (school
code + four digit sequential number, e.g. 0580001), Teacher Certification Number and Gender. Use Role =T for
teachers, S for Secretaries and P for Principals. Click OK.

Quick steps for removing staff: Go to Staff -> Staff Records and search for the staff member (type one letter of
last name). Double-click on the staff member to open his/her Staff Record. Please note that you cannot remove
a teacher who is assigned to a class or homeroom; you may have to un-assign them from a class or homeroom
at File -> School Setup -> Rooms/Homerooms or File -> School Setup -> Classes. Finally, you can go to the
Employment tab and click the Edit button. After that, click the Deleted (Ret./Trans.) radio button to remove the
teacher, then click OK.

Additional notes on removing staff:

e If you already removed staff in the previous spring, you probably marked the staff members as “This
year only”, which caused those staff members (the same way it does with students) become Past Staff at
the end of the previous school year

e If you are removing current staff, ensure you do not permanently remove staff (there is a checkbox for
it) from Maplewood as they need to become part of the historical data we retain year to year
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Detailed steps for adding and removing staff can be found in section 5.

6.2.1 Print a List of connectEd Accounts for Teachers

Once finished adding and removing staff members, it is recommended to print out a list of connectEd user
accounts for the teachers. That list will show usernames for everybody and, additionally, passwords for
completely new teachers who have never logged in before.

Detailed steps for printing user account lists can be found in section 5.3.

6.3 Set Up School Calendar

6.3.1 Verify Calendar Start and End Dates

Go to File -> School Setup -> Calendar -> Edit. The first available date in the Calendar should be the first day of
school for students. The first date in the calendar that is not grayed out is the first day of school for the current
year. Ensure that date is correct. Also check the last day in the Calendar in a similar manner.

6.3.2 Add Holidays, Professional Development and In-Service Days

We have already put national statutory holidays into the calendar. Please add local holidays, Professional
Development (PD) and in-service days to your school calendar. Those days will be removed from students’
possible days and no attendance collection is expected on those days.

The blue date is the currently selected date (September 3 below). To set PD days, select the date by clicking it
and then click "Board" at the bottom. That will make that day a Board (PD) day (). Put in all PD/in-service
days and holidays (). Key point: any colorful day in the calendar means "no school for students" and
reduces their possible days.

Once you close the Calendar, it will ask you to save the changes. Select “Yes”.
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iJSchunl Calendar 2012-2013 - Inuksuk High School E3 ]
T Check that the first and last
Ele B Ly available dates in the
July 2012 August 2012 September 2012 Octaber 2012 |; Calendar are the first and
Zum | Man| Tue |%ed| Thu | Fri | Sat | Sum | Maon| Tue | wed| Thu | Fri | Sat | Sum | Man| Tue | wed| Thu | Fri | Sat | Zum | Bon| Tue | Wed| Thu | Fri | Sar last day of school for
1|z 3|45 || 1 ]2 s & 1 12| s]|a H students.
AR EREREEEBRERERE:: BEHBEEE - BEE
5 (6 [ [ [ 2o 2t [z |z || s e | w]e| a0 |w| 5]l gl =TT In this example, August 27 is
22 |2z | 2a | o5 |26 | a7 | 28 | 4 o FAE ] tipet=TE=T=T5 | 20 | 21 | 22 | 21 |22 |25 |24 | 25 |26 | 27 the first day and June 20
ENED C: [ 2r ] 29 30 | 3 2n |24 | 25 |26 | 27 |28 | 23 o5 |23 | @0 | B last.
30
Hovember 2012 December 2012 January 2013 February 2l]1 3 |
Zum | Mon| Tue | wed| Thu | Fri | Sat | Sum | Mon| Tue | Wed| Thu | Fri | Sat | Sum | Maon| Tue | Wed| Tha | Fri | Sat | Sum | Man| Toe | Wed Fri | Sat
12| = 1 5 H K
4|5 |e|v|s|alw]e|s|a|s]|e|v]|a|e|r|a]a|[w|[n|r]s T,O ma.ke adatea .Hollday,
i I s w s w05 e n e ] 5| s ens] 6|0 first click the day in the
A E 24 o |2t | ze | ea 24| oas | o | 0 Calendar so it is highlighted
25 (26 | 27 |25 [ 29 | 30 24 | 25 | 26 | 27 | 28 B EESED 24 dark blue, then click the pink

button. Then click on

March 2013 April 2013 May 2013 June 2013 some other date and you will
Sum | Maon| Tue | ed| Thu | Fri | Sat | Sum | Man| Tue |%ed| Thu | Fri | Sat | Sum | Meaen| Tue | w'ed| Tha | Fri | Sat | Sum | Man| Tue | %ed| Tha | Fri /-/ see that how‘the date has
gl & M 5 slTalal o =71 changed to pink.
s | a|s|e|7e|a|7|e|s|w|nfw|[w]|s|6|7]|s]|a[wo|n]|zl s 5 sw 8
ol e e s | e [ s e v e e o 0| | 12 a | s day button should be
1T 1 | 18 a0 | &1 | 22| 23| 2| 22| 23| 24| 25 I IR (N ﬁ 20 | 21)| 22 used for PD days.
TR a0 |22 | 29 | 30 25 | 24 | o5 | Nl =3
Ta1 | —1 30 hd is reserved for
Marmal - Special Grant Day Bnard Bemove | Optiohs... | Dahe | unexpected closures. Yc?u
should not need to use it at
| N—— | 07/28/2014 [11:35 AM this point.
Half day closures

Half day closures cannot be handled in the calendar so do not worry about those yet.

Exam Days (YELLOW)

Exam Days will also remove that day from the possible days for students. Avoid using Exam day altogether. If
you feel that you must use them, please contact the SIS Coordinators first.

6.4 Set Semester Dates and Reporting Term Dates

If your school uses semesters, then you have to set the date for when your semester one ends and semester two
starts. Additionally, you need to set your reporting term (typically three or four reporting periods) dates for
report cards. The reporting term dates may or may not coincide with your semester dates.

Semester/Term dates are important to set up because they define when semesters flip and
schedules/timetables change in Maplewood. They do not need to be set if the school only has full-year classes
(school is not semesterized).

Reporting Term dates are important to set up because they capture the period of time for which attendance
totals are collected in report cards. Use the actual start and end dates of your reporting period. All schools need
to set these.

61



Setting Up SIS for the Current School Year | Set Semester Dates and Reporting Term Dates
6.4.1 Set Semester/Term Start and End Dates

Semester/Term dates are important to set up because they define when semesters flip and
schedules/timetables change in Maplewood. They do not need to be set if the school only has full-year classes
(school is not semesterized). Elementary schools do not have this option.

1. Go to File -> School Setup -> Calendar -> Edit
2. Go to Edit menu and select Semesters as shown below:

ﬂs:hool Calenday 2012-2013 - Jimmy Hikok School

File | Edit Help

August 2012 September 2012 October 2012 |;
m} Sat | um | Won| Tue | Wed| Thu | Fri | Sat | Sum | Moo | Tus | wed| Thu | Fri | st | Sum | Mon| Tue | wed| Tha | Fri | sat
1 7 1[a]s] s 1 1[e|as]a]s] e
T | w|s|e|rf[a]|a|nw|n a5 |8 |7 STHSm e s

5 | BT T T3 L 21 [ 12 |13 | 4| 15 | 16 | 1T 18 BN ] "2 13 14 15 Wop1s e AT | 18 | 13 20
22 |23 |24 | 25| 26 | 27 [ 25 [ 19 (20 | 21 (22 |23 (24 | 25 | 16 | |16 |19 |20 | 21| 22 | 21 |22 |23 |24 | 25 | 26 | 27

29 [ 30 [ = 26 | 21 | 28 |23 |30 [ = 23 |24 | 25 |26 |27 (28 | 23 |25 |23 [0 [ m
30
Movember 2012 December 2012 January 2013 February 2013
Sum [ Men| Tus [wed| Tha [ Fri | sat | sum [Mon] Tue [wed| Tha | Fri [ sot | sum[Man| Tue [wea] Tha [ Fri [ st | sum [mon] Tue [wed] Tha | Fri [ sae
1z = 1 BRI 1] 2

4 5 & 7 & 3 10 2 4 5 L 7 & L] 7 & 3 w1 12 3 4 5 & 7 & |
1514 15|16 17| 18 13 ool 213 14 15 16
o222 23 | 24| 25 o6 o’ 1 a0 | 2| 22 2o

25 | @ | 2| s | 28 | @0 27|z | e | E0 | A 24| @5 | 26| 27| 2
March 2013 April 2013 May 2013 June 2013
Sum | Men| Tue [wed| Tha | Fri [ st | sum | Mon| Tue [wed| Tha | Fri | sat [ Sum|Mon| Tue [wed| Tha [ Fri | sat | sum [Men| Tue [wed| Tha | Fri [ sae
1] 2 s s[a]s| e HEED 1

3 4 5 L 7 & 3 T & LI ] 1n |12 13 5 L 7 & 3 |10 1 2 3 4 5 L 7 &
10 " 12 13 4|15 R R R R [ - R &) LU BRI L R L 18 3 (1w "2 )13 14 15
s 19 20 21 22 | 23 | 2|22 23 | 24 | 25| 26 | 27 | 18 H 21|22 |23 |24 | 25 | & | 17 [ 15 |13 |20 | 21| 22

2 |25 |26 [ 27 [ 28 30 |25 |23 [ 80 26 |21 |28 |23 [ 80 | = 23 (24 [ o5 [ee [ar[2s [ 2a

B | | a0 ~|
Mormal Huoliday Special Grant Day Board Bemove | Options... | Daone |

| [1/21/2013 [11:43 4M

3. Next, Semesters and Terms are displayed on the Calendar with different colours. To change the
Semester/Term start and end dates, click-and-hold the last day and drag it to the correct date. When you drag
the date, the pointer should turn into a double-headed arrow.
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Edit Semesters & Terms E3

Julp 2012 August 2012 September 2012 October 20012 =
Sum | Plon| Tus | wed| Thu | Fri |

Click-and-drag the end date
of the Term or Semester to
= the desired date.

Mlon| Tue | ‘wed| Thu Mlan| Tue | Wed| Thu | Fri

Movemnber 2012
Zum | Plon| Tus | wed| Thu | Fri

December 2012 January 2013
Sum | Mon| Tue | wed| TheFri .47

L1

February 2013

March 2013 April 2013
Tue | ad Mon| Tue | ed| Thu | Fri

Map 2013
Tue | wed| Thu | Fri

June 2013

Click the Summary button to
see a summary of the dates

Click and drag a term's start or end date to adjust it Summary... QK | Cancel

4. Click the Summary button to see a summary of the dates to verify them.
5. When done, click OK. Back in the Calendar, click Done to exit and save the changes.

6.4.2 Set Reporting Term Dates

Reporting Term dates are important to set up because they capture the period of time for which attendance
totals are collected in report cards. Use the actual start and end dates of your reporting period. All schools need
to set these.

1. Go to Marks -> Topic-Based Marks -> Define Terms. The screen below will open. You will see the Reporting
Term start and end dates on the right. The Reporting Terms in your screen may differ from this slightly.

ﬂDeﬁne Terms M=l 3

 Filter

Filter: I j M
Search: I Search

V4 N\
Titl | Deseoription | |dentifier /l Start
First [SEC)
Fourth [SEC)
Second [SEC)
E Teim 1 [ELE
Tem 2 [ELE...
Tem 3 ELE...
Third [SEC]

11/16/2012
£/28/2013

1 12
3/A15/2013
£/28/2013
3/29/2013

Click the Edit button to edit the selected
Term

add | Edt | Delete Erint Dane
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2. To edit a Term, for example Term 1 (ELEM), highlight it and click Edit at the bottom. Change the Start Date
and End Date by using the date pickers on the right. Click OK to save and exit.

|dentifier:  |EOD
— English Definition — Term Diat
—
Title: ITerm 1(E LED Start Date: 08/27/2012 E :[
End Date: 1207202 E :l
Description: I
~Map to School Schedule——————————
— Erench Definitian Term: Nat Defined -
Title |
Description I
[~ Only publish to Parents/Students site as of this date I E :I
Homeroomsz/Classes [104) |
Code | Seclion | Fioom | Desig... | Title | Homeroom -
ART 1 a " Fine &tz 1 Mo
ART 1 b " Fire &tz 1 Mo
ARTZ2 a * Fire &t 2 Mo —
ART3 a " Fire Arts 3 Mo
ART4 b " Fine &rts 4 Mo
ART4  n " Fire Arts 4 Mo
ARTE b * Fire &rts & Mo
ARTS n " Fine Arts 5 Mo
ARTE a " Fine &tz B Mo
BF 1 a = Brighter Fut.. Mo
BF 1 b S Brighter Fut... Mo
BF 2 a k3 Brighter Fut.. Mo
BF 3 a = Brighter Fut.. Mo
BF 4 a = Brighter Fut.. Mo
BF 4 n S Brighter Fut... Mo
BF S b k3 Brighter Fut.. Mo
BF S n = Brighter Fut.. Mo
RF R A £ Rrinhter Fit M LI
Assign | FErint |

Change the reporting term start and
end dates here. You should use the
actual start and end dates of your
reporting period. DON’T FORGET TO
SET THE YEAR AS WELL.

Tip: click the little down pointing arrow
to access the date widget.

List of classes that have this reporting term

Previous |

1=
o
=

oK €—camr=—

Click OK when done.

6.5 Assign Students to Homerooms

Next, assign students to Homerooms if that has not already been completed during the previous spring.

Normally only K-8 or K-9 grades are assigned to homerooms in order to provide a grouping for them for
homeroom AM/PM attendance collection. In senior high grades (10-12), schools must do period-by-period
attendance and homerooms are not required but you can still assign senior high students to homerooms if you

want to use homerooms for grouping or emergency lists.

6.5.1 Configure Homerooms

All rooms used for classrooms need to be entered into SIS. To add rooms or designate a room as a homeroom,
go to File -> School Setup -> Rooms/Homerooms. Review the list of homerooms. If needed, add new ones or
edit existing ones. See below an illustration on how each homeroom should be configured.

NOTE: To assign Teachers to a homeroom they must first exist as Staff.
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Enter a value in Room Number. If you do not use Room
Numbers at the school, you can use the same value here as for

Designation. Or just sequentially number your rooms (1, 2, The Designation usually has th? grade
3.) number and the group letter, like 1A, 2B or

9A.

!]Rooms/Hom.'rooms

Room Number: |211

r~ Homeroom ] Enter the homeroom teacher by
ﬂ F lcecan Designation:  [118 / selecting from the list.
If the room is used
as hom‘eroom, Teacher: | Adams, Benjamin Mr. ~|
check this box.
Altemate: X

st cae| 0| :

f INS
: \ Some homerooms may have two
/ teachers who look after the
homeroom. Enter the second
Click the OK to save the room and close it. teacher here if applicable.

6.5.2 Assign Homerooms by Grade

Usually homerooms are assigned by grade: every student in one grade is assigned to one homeroom. However,
often there are more than one homeroom per grade. Homerooms are assigned differently in these situations.

The school has only one homeroom per grade

1. Go to Students -> Assign Homerooms -> Sequential by Grade

2. Select the Grade at the top (e.g. K)

3. Select the Homeroom for the grade and click Add to move it to Selected Homerooms
4. Click Assign to assign students to the homeroom
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ﬂnssign Homerooms !E[ |

Select the grade that you
Grades: I K. s I want to assigns the

Homeroom to

—Hamerooms
Selected Homeraoms
104 2G Arreak, Gesbowah 138 K. Sugzlak, Rachasl
125 4E Arnak.allak, Esther
126 1c K.uak, Carmen
127 4/8C Harbidge, Carrie
128 14 Kpak, PitSEDlak, Al Select the Homeroom
. Sugzlak, Bachas and click Add to move it
139 AL kilton-Epak., Linda to the Selected
1 4':' 3':' .ﬁ.rnakallak, DDFIEIh Homerooms

14 A/EC Kilukizhak, Connie

142 GC Cull, Chrigtine

144 25 Enook, Susie
Bemove R ermowe Al
— Azzighment aption:
{* Alternate through students
™ Assign sections of alphabet A gsign | e —— Click Assign to start
= | = | assigning
| [OWR [12/6/2012 |11:16 AM

6.5.3 Assign Homerooms Individually

In bigger schools there may be more than one homeroom per grade. For example, there could be two grade two
homerooms: 2G and 2S. In this case it is best to assign all students to one homeroom first (2G) and then go
individually through all the students in 2G and change them to 2S where necessary.

1. Assign all grade two students to one of the grade’s homerooms (e.g. 2G) by using Students -> Assign
Homerooms -> Sequential by Grade (see previous section).

2. Go to Students -> Assign Homerooms -> Individual Assignment to move students from 2G to 2S

3. Pick the Grade (in this example it’s grade 2) from the dropdown menu.

ﬂlndividual assignment M=l E3

Select studentz bp———— Grade

= This year's grade E ~] Select tr:f gr?de v;i)th which you
. are working (e.g.

" This year's homeraonm

Azzigh | Erore I Click Assign

| [OvR [12/672012 [11:45 &M

4. After clicking Assign to start the individual assigning process, you are brought to the following screen:
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ﬂlndividual student Ed |

Student; Akoamalik., Carsan Student name

Harmeroom I 104 2G Aneak, Geebowah ;i The homeroom the student is currently in, 2G

5. Change the student to the correct homeroom, if necessary, by using the dropdown menu. Click OK to move to
the next student in the grade. The system will take you through all students in the grade and you can change the
homerooms where necessary. At the end of the process, you should have all the correct students in homerooms
2G and 2S as per the grade two example.

Sjlndividual Student |
Student: Akoomalik, Carson
Homeroom I 44 25 Enook, Susie j The new homeroom is set to 25

Click OK to move to the next student

I 1 I
I:I k. I [T | [ | I

After completing Homeroom assignments, verify the homeroom lists by printing them. Steps on how to print
homeroom lists can be found in section 9.2 Print Homerooms Lists.
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6.6 Review and Edit Classes File

The Classes File consists of Classes. A Class is a course code taught by a teacher, at a certain time, to a specific
group of students. The Classes File defines who is teaching what and when at your school.

Go to File -> School Setup -> Classes to open the Classes File. Typical rows in the Classes File look like this:

ﬂ[lasses File

Occupancy column shows

Eile Edit Search Help how many students are
Classes already assigned to the class
Sem. 1.2 Term 1 Day 1 z with Unazzigned Patterns: Yes
Clazz Code | Sem. /T eﬁ Set | Sem. /T ermn Pattern | Day/Per. Set | D ay/Per.Pattern | Teacher | Qe /Cap. il
LOC1290 b Semestgred Sem 2 Single Per 2 Mot azzigned 0/30
LOC2290 a Semeslered Sem 1 Single Per 3 Mot azzsigned 0430
MaT1793 a Semgztered Sem 1 Single Per 4 Funnuk, Christina krs. 11430
MAT1793 b Semestered Sem 2 Single Per 1 Kunnuk, Christina krs. 1130
MaT2793 a Semestered Sem 2 Single Per 4 Imingmak-Learn, Ross 10430
MATI?H3 a Semestered Sem 2 Single Per 4 minarnak-Learn, Ross 43/30
MRCIO0M & Semestered Sem 1 Single D=e 7 L ol bimberly brs. 0/30 —
MRC20010 a Semestered Sem 1 Single Add, Edit and Delete buttons  |imberly Mrs. 0430 -
4 I J/ to work with the Classes File _,IJ
4
add | Edt |  Dekte | Print | Dore |

/

Above, MAT1793a and MAT1739b are two sections of MAT1793 differentiated by section letters “a” and “b".
Separate sections are required when a class is taught either at a different time, by a different teacher, or to a
different group of kids.

Review the Classes File completely and edit entries to change the teachers or the timetable of the class.
Add entries as necessary. Delete unnecessary entries.
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6.6.1 Add or Edit a Class

Click the Add button in the Classes File to create a new class or select an existing class and click the Edit button
to make changes to it. Fill in information as illustrated below:

The Course Code for the

class assigned

The Secti

but you can also change
it manually

The CTS button
is used with CTS
Master Classes

on Letter is
automatically

The Teacher responsible for
marking the class and doing
attendance if the class has a
schedule assigned to it

[classe

Courze Code; Sechion:

|EL41104

Clazz Teacher:
| B azzett, Adam

Additional Teacher:

| Mot azzigned

L

Dreliven:

El

|Semester caurzse for credit

[ Continuouz Entry

M urnber 2ats:

Credit W alue:

Fultiple Rooms:

Clazs Starting Bate
01/28/2015 15 ~

[ 30

| 5.00

-

=~

Clazz Ending D ate
\06/1E6/2015 (2]

Boom Mumber: |1 14

Feportable [w

Calculate minutes from period times [+

[ Special Schedule

Minutes/Day: | O

Grouped Clazzez Language
Mone Selected ﬂ Select Englizh -
Schedule:
Semester/T erm | Dray/Period i‘
Set Fattern Set Fattern
1 |Sr.High ﬂ|5&mester 2 ﬂ|Ever_l,l day u:h:nﬂ 56 ﬂﬂ
Report Card | Previous | Ment | Exam | ] 4 | Cancel |
| [INS

The Room Number for
the class (optional)

The Reportable checkbox
indicates whether marks
should show up on the
report cards. It should be
unchecked for CTS Master
Classes.

Use Special Schedule to
set timetables to classes
that have an unusual
schedule

*

v

Further details on some of the key fields above

The Schedule of the class,
set with Patterns. If there
are no suitable patterns
for the desired schedule,
use Special Schedule
button above to schedule
the class.

Semester/Term area
shows the duration of the
class, e.g. “Semester 1”.

Day/Period area shows
the weekly schedule of
the class, e.g. “Every day
periods 5/6”.

Field Explanation

Course Code

K-9 Course Codes

Defines the course code taught. Use the Approved Course List to look up senior high course codes (ask for a PDF list if needed).
7000MATa is an example of a course code for grade seven mathematics. You can see an explanation of K-9 course codes here:

Semester/Term

Pattern document.)

Defines the duration of the class, e.g. Full Year or Semester 1 or Semester 2. (The actual semester dates are set earlier in this

Day/Period Pattern

Defines which cycle days and periods the class takes place in, for example “Block 1” could refer to “Periods 1 and 2 of every
cycle day”. The Day/Period patterns are created and named individually depending on school. SIS Coordinators can set them up
for you. Floater pattern means ‘no timetable has been assigned to this class’ and is used with CTS modules and often but not
always with junior high classes.

69



http://nunavutsis.wikispaces.com/file/view/Elementary%20Codes%20Explained.pdf/443067200/Elementary%20Codes%20Explained.pdf

Setting Up SIS for the Current School Year | Assign Students to Classes

Scheduling a Class

Scheduling or timetabling a class means defining the specific weekly timetable for the class by using Patterns

(Semester/Term Pattern and Day/Period Pattern columns in the Classes File) or Special Schedule.

e (Classes are timetabled in order to enable attendance collection for them on period-by-period basis.

That is the primary reason for timetabling.

e To not schedule/timetable a class means giving it a “floater” day/period pattern (= no schedule)

e Typically K-6 classes are never scheduled

e Grade 7-9 classes are not scheduled if the school does AM/PM attendance in those grades. If you want

to do class-by-class attendance in junior high, then just timetable all junior high classes.

e All grade 10-12 classes have to be timetabled because attendance is collected per class

Here is an example of a fully scheduled class where the schedule has been established with Patterns. The

duration of the classes is set under Semester/Term area and the weekly schedule is set under the Day/Period

area:
Schedule:
Semeszter/T erm | Drap/Period i‘
Set Fattern Set Fattern
1 |Sr.High ﬂ|5&mester 2 j|Ever_l,l day u:h:nﬂ 56 jﬂ
Feport Card | Previous | et | Exam | 0k, | Cancel |
| ILE

This class has a duration
of Semester 2 and it
takes place in Periods 5/6
every day

Note that each school can
set up and name their
Patterns the way they
want).

A floater class has its Day/Period Pattern set to “Floater” as shown below. This means that no schedule has been
assigned to the class.

Schedule:
Semester/Term Dap.Period i‘
Set Patterm ﬁt | Patter 4,/
1 |E|ementar_l,l j|FuI|year % j|FIDater ﬂ
Fepart Card | Previouz | et | E xam | 0k, | Cancel |
[There are B records in file. | INS

This class is a “floater”: it
has no schedule and no
attendance can be
collected for it. Floaters
are used in for
elementary school classes
and CTS modules that
have a Master Class.
Marking is still possible.

Special Schedule button (see previous page) should be used to schedule the class that cannot be scheduled with

Patterns as show above.

6.7 Assign Students to Classes

Once you have assigned homerooms and the Classes File looks correct, you can assign students to their classes.

Without doing this step, teachers cannot do attendance or give marks to students as the students do not have

any timetables assigned to them.
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6.7.1 Assign Classes by Homeroom

The pre-requisite for assigning classes by homeroom is that you have already assigned students to their
homerooms. See section 6.5 Assign Students to Homerooms on how to assign students to homerooms.

Typically every student in the homeroom group takes the same subjects (Classes), at least in K-9. It is simple to
assign student to their classes based on the homeroom they are in.

If you are in a pure elementary school with a Maplewood Elementary license, the assign Classes by Homeoom
process has been combined into the Rooms/Homerooms function. Go to File>School
Setup>Rooms/Homerooms to get the homeroom listing.

Boom Number: — [235 - Class Association
7
¥ Homeroom |

Homeroom Agsoc, | Course | Section | Room Teacher Auto Assign [ L~
Designation: e [ [7000ELS [a Mot Assigned | Fubio, Carn es 3
[T |7000ELA b Not Assigned Strutz, Rob es 3
Ty T = | 7O000ELE | o Not Assigned | Tucker, Bonila s 3
[Tucker Borie =l | 7O00ELA |d Not Assigned es 3
Altermate: INDI assigned j [ | 7O000ELS e Mot Assigned | \Ward, Andrew es 3
[T |7000FRA | b Not Assigned Savaria Durand, es 3
T |7O00HEL [ 2 Mot Assigned Fubio, Caryn Yes 3
[ml TOOOHEL | b Mot Agsigned Stutz, Rob es 3
[ |7O00HEL ¢ Not Assigned Tucker, Borita es 3
T [7O00HEL [d Nat Assigned Yes 3
[l TOOOHEL | e Mot Assigned “wfard, Andrew Tes 3
T |7o00LA [a Not Assigned Stephens, Peesee es 3
[ |700LA |b Not Assigned Akulukjuk, Lessis Yes 3
[l To0o0Ls c Mot Assigned Stephens, Peesee es 3
T |7oo0Ls [d Not Assigned Akulukjuk, Leesie es 3
[ |7000LA [e Not Assigned Stephens, Peesee es 3
T | 7000MAT] 2 Mot Assigned Fubio, Caryn Yes 3

[ | 7000MAT | b Mot Assigned Strutz, Rob ‘fes s
4 »

N Section|  The Ao Asion festure llows  clss 0 be associated with the sudents in
a homeroom automatically. [F this option is nat selected the claszes will nat
be assigned ta the students automatically
Add Grade I Remave Grade
Repat Card | Previows | Next Cancel
[Read INS

Add a grade and choose the Classes that should have the homeroom roster applied, then click OK.

For K-12 and Senior Secondary schools you will need to follow the directions below to perform class assignments
by homeroom.

Let’s assume we have the following homerooms and students have been assigned to them:

ﬂRuum,.-"Humeruum File =]

File Edit Search Help
Do | W | D, || Temeier L I Veggher )0e.
Bt _',-'S Bt Nakshuk, Leona Mot aszigned 18
ety 1= iy Drukfett, M arjorie Mot azzigned 17
a4 1= b, Wile, Aaron Mot azzigned 18
G/7B e G/7B |zhulutak, Magge Mat azzsigned 19
a/968 YES 3/98 Smith, Ay Mot azzigned 17 LI

Also, the Classes File (File, School Setup, Classes) has already been set up and looks like this:
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mtlasses File H=] B3
File Edit Search Help
Sem. 1.2 Term1 Day1,.2.3456 Per. 12345678 Include Claszes with Unazsigned Patterns:

Clazs Code
EOOOELA: . Full pear Floater Is qgie
BO0OFMA & <€ be—tlisks Eallizoms I Elest blelezskoetcars
EDDDFN'ﬂ,‘b < Ir_ l-ligln |} o El-ctar El-tar | L‘LM’,H ::. SR
BOOOHEL a Jr. High Full year Floater Floater Makazhuk, Leona
BOOOHEL b Jr. High Full year Floater Floater | shulutal, M aggie
BOO0ILA & Jr. High Full wear Flaater Flaater M akazhuk, Leona
GO00ILA b Jr. High Full year Floater Floater | zhulutak, taggie
BOOORAT a Jr. High Full year Floater Floater Makashuk, Leona
BOOOMAT b Jr. High Full year Floater Floater | shulutal, Maggie
BOOOFED a Jr. High Full year Floater Floater Hodgers, Lee
GOOOFED b Jr. High Full year Floater Floater Hodgers, Lee
BOOOSCH a Jr. High Full year Floater Floater Makashuk, Leona
BOOOSCH b Jr. High Full year Floater Floater | shulutal, Maggie
BOOOSEM a Jr. High Full year Floater Floater K.anayuk, Oleepeeka
BOOOSEM b Jr. High Full wear Floater Floater K.anayuk, Oleepeeka
BOOOSHO & Jr. High Full year Floater Floater K.eenainak., Simeonie
COOOCHO b Ie blicl, Evll ez Eloatar Eloatar K asmzimal Cirnzcue

1. Go to Students -> Edit Timetables -> Assign Timetables by Group

2. Set Homerooms as the Assignment Order
3. Multi-select (CTRL + click) all the applicable classes (in this example 6A classes) that you want to assign
4. Make sure Add Classes to Timetable is selected in the lower left portion of the dialog

5. Click OK to move to the next screen. That’s where the Homeroom is selected

ﬂnssign Student Timetable - This Year

—&zzignment Order
" Alphabetically
" Grade

=]|

— Classes

BO00ELAa English B
BOOOELAE English B

Select Homeroom as

&+ Homeroom 4
" Defined character
£ Irniguiny List

" Excursion List

= |n a specific class

' Add Classes to Timetable

Imetable

" Beplace Timetable

[~ Ewxclude Concurrent Students

v Check prerequisite courses

[T Adjust Student Fees For &dd/Crop Courses

bUUUFMNAS Fine arts b
EBO0OFMAL Fine artz B
EOOOHELa Health B
BOOOHELE Health &
EBOODILAE Tnuktitut B
BOO0ILAE Inuktitut B

BO00MAT & Mathematics B
BO0OMATE Mathematics B
BOOOPED & Physical education &
EBOOOPEDL Physical education 6

Assignment Order

Note that there are
two sections (a and
b) of each grade six
class because there
are two homerooms
for grade six
students (6A and
6/7B)

Multi-select all the 6A (for
example) classes by holding
down Control (CTRL) and

clicking the classes with the
mouse

Click OK to move to

oK 4

—ari-e]

the next screen

[ovR [12/18/2002 [10:47 &M

6. Next, select Individual Homeroom and select the homeroom from the dropdown.

7. Click Start to start assigning classes to students in the homeroom.
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] ekt emeeam ( Select Individual Homeroom
Firzt Homeraom
B4 B Makashuk, L. [ First in list
T 7 Fiabd 5. Select the target Home.room from the
G4 B Makashuk, L. dropdown menu. In this example, we
B4 8a Duffett, M. select the 6A homeroom
94 94 Wil A .
B/7B 5/78 Ishulutak, M. e Lisstinfis
8/98 8/9B Srith, A,
Homerooms sart by————
=" Boom number
" Designation
" Teacher
Click Start to start assigning
51 t< | | the selected classes to
& | s | students in the selected
homeroom
|Select first homeroom [ovR [MzAs/zmz [1053aM

To make sure the timetable changes show up immediately on the connectEd (teacher) side, run Correlate
Database: File -> Maintenance -> Topic-Based Marks -> Correlate Database!

6.7.2 Assign Classes by Grade

Some classes are taken by the whole grade. For example, grade 10 students could all go to the same Physical
Education class or Aulajaaqtut class, regardless of what homeroom they are in. In this case it is most efficient to
assign the class by grade.

Let’s assume all students in a certain grade are taking a certain class.

1. Go to Students -> Edit Timetables -> Assign Timetables by Group

2. Select Grade as the assignment order

3. Select the class on the right by clicking on the class (e.g. ELA20-2a)
4. Click OK

5. In the next screen, select the grade for the class (e.g. 11)

6. Click Start to start assigning the class to the whole grade of students

To make sure the timetable changes show up immediately on the connectEd (teacher) side, run Correlate
Database: File -> Maintenance -> Topic-Based Marks -> Correlate Database!

6.7.3 Assign a Class to a Specific Group of Students

Because each student in high school may have a different set of course choices, students in high school grades
most often cannot be assigned to class by grade or by homeroom. Instead, students are individually assigned to
their classes.

Let’s assume that just some students are taking a certain class and we want to select the students individually.
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1. Go to Students -> Edit Timetables -> Assign Timetables by Group

2. Select Alphabetically as the assignment order

3. Select the class on the right by clicking on the class (e.g. GYM10-3a)

4. Click OK to move to the next screen

5. In the next screen, select By Group and click Add to start adding students to the group

ﬂSEIected Methodslzhabetically

'@ assign Student Timetable - This Year E

A  Claszes " ByRange

I r— Lizt of Students

ELAZ0-2b English language arts 2D-Z;|
EL430-2a English language arts 30-

" Homeroom ELA30-2b English language arts 30
: EMW30 a Ervironmental studies 35
" Defined character FAS3T 20
" Inguiry List FASZ2130a
™ Excursion List FAS21G0 .
= FOUZ20-2a Foundations of mathemat
= In a gpecific clas: FOLI2. i athernat

. . - educat]
~Assignment Options GYMAT el education 30 J
'y A ILAT0 & Inuktitut 10
&dd Clazzes to Timetable 10530 o Ikt 12 LI

" Delete Classes from Timetable

" Replace Timetable

oK Cancel

[~ Exclude Concurent Students I

W Check prerequisite courses
[~ Adjust Student Fees Far Add/Drop Courses 0K | Cancel |

[ 8/zmz [O1-19FM

6. Search for the student by partial name. Select the student once found and click OK to add.

@select Student By Partial Surname [ x|
Paitial Name Type the partial name of
|*"-"- <€ the student, such as “A”
Student I Status I Home School I -

Akpalialuk, Alerandria Tina

Akpalialuk, Ben

Ak paliahilk, Clara

Akpalialuk. Diana Dlanie —
Akpalialuk, Eva

Select the right student

Akpalialik, Mika

Ak palisluil, Parmela

akpalialuk, Samantha

Akulujuk, Billy

Akulujuk, George

Akulik Jnzenkb ll

Print | |T<= B—— : Click OK to add the student

to the collection

7. Add all the students to the collection in similar manner
8. Eventually you will have a list of students in the box:
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ﬂﬁelected Method - Alphabetically E2
" ByRange  * By Group
r Lizt of Students

Alkpalialul, Alesandria Tina
Alkpalialul, Clara <
Akpalialuk, Joanasie

Students that have been added to
the collection

; ; Click OK to assign the class to
([ Sy these students

9. Finally, click OK to assign the selected class to these students!

To make sure the timetable changes show up immediately on the connectEd (teacher) side, run Correlate
Database: File -> Maintenance -> Topic-Based Marks -> Correlate Database!

6.7.4 Set up Homeroom Attendance Classes

This section only applies to K-12 schools and secondary schools. In pure elementary school, homeroom-based
attendance is ready to go after students have been assigned to their homerooms.

In order to do AM/PM attendance in K-9 grades in secondary schools, homeroom attendance classes need to be
created in the Classes File for each homeroom. They use course codes such as ATTAM1, ATTPM2, ATTAM?2,
ATTPM2, the number indicating the grade. The attendance classes will act as a vehicle for homeroom-style
attendance collection during AM and PM.

The attendance classes have to be assigned a schedule in the Classes File by using AM and PM patterns. All
other classes for that grade must be set as “floaters” (= no timetable) to avoid timetable conflicts.

Example homeroom attendance classes in the Classes File for K-9:
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.
[Jclasses File 1Ol =|
File Edit Search Help
Sel m 1 Day1.2.3456 Per. 1.2.3.4.56 Include Classes with Unassigned Patterns: Yes
Class Eodk | Sem./Ter.. | Sem./Ter.. | Day/Per. .. | Dap/PerP... | Teacherﬂ
ATTAMT a Full year Full year Attendance A Panigay.
ATTAMZ a Full year Full year Attendance A Itunga,
ATTAMI a Full year Full year Attendance A Meevear
ATTAMA a Full year Full year Attendance A Oleekat:
ATTAME a Full year Full year Attendance A Etunga, ~
ATTAME o Ful vet Ful vet P Kava In K-12 and secondarY schools,, AM/PM attendance for
ATTAMT a Full pear Full year Aftendance  AM Thomsal K-9 must be set up using attendance classes for each
ATTAM? b Full year Fullyear  Attendance  AM Les. Jor homeroom (your school may require a different set of
ATTAME a Full year Full year Attendance A Fike, v .
ATTAMS a Fulyesr  Fulpear  Attendance &M Hill Gea : attendance classes depending on your homerooms). SIS
ATTPMI1 a Full year Full year Attendance  PM Panigay. Coordinators can help you set them up.
ATTPMZ a Full year Full year Attendance P Itunga, J
ATTPM3 a Full year Full year Attendance P Meevear
ATTPM4 & Full year Full year Attendance  PM Oleekat: Students are assigned to these classes based on their
ATTPME a Full year Full year Attendance P Etunga,
ATTPME a Full year Full year Attendance P K.avanag homeroom.
ATTPMY a Full year Full year Attendance P Thomszot
ATTPMY b Full year Full year Attendance P Lee, Jor
ATTPME a Full year Full year Attendance P Fike, v
ATTPMI a Full year Full year Attendance  PM Hill, Geo
ATTPME Full year Full year Attendance P Eetooic,j
3
N |
sad | Edt |  Dekte Prirt Done |
[ )

Configure Homeroom Attendance Classes

e An “Attendance AM” class will span the first morning period and an “Attendance PM” class will span the
first afternoon period of every cycle day. SIS support can help you set up this schedule using "AM" and
"PM" patterns

e The homeroom teacher should be set as the teacher for the attendance classes since they are expected
to do attendance on the students in the homeroom

e The Reportable checkbox should be unchecked for Attendance AM and Attendance PM classes in the
Classes File.

Assign Students to Homeroom Attendance Classes

If you have completed assigning students to homerooms already, then go to Students -> Edit Timetables ->
Assign Timetables by Group, then pick Homeroom as the assignment order and multi-select (press CTRL key and
click with mouse) the two attendance classes for that Homeroom. Then click OK. In the next step, check the
Individual Homeroom box and then pick the correct homeroom for the dropdown menu. Then click Start.

To make sure the timetable changes show up immediately on the connectEd (teacher) side, run Correlate
Database: File -> Maintenance -> Topic-Based Marks -> Correlate Database!

6.8 Set up CTS Classes Using a Master Class

This section explains how to set up CTS courses so that several of them can be taught at the same time by the
same teacher. In this scenario, a Master Class such as CON0001 is created first and timetabled, and then the

actual CTS courses (modules) with the appropriate course codes are created as Floater classes (no timetable)
and included in the Master Class.
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Rationale: CTS modules are often taught at the same time by the same teacher and a student may be working
on more than one CTS module in that same time slot. To schedule all the modules and assign them to the same
student, or students, would lead to a timetable conflict. The solution is to only schedule the CTS Master Class
and assign that to the students, thereby not trying to force many classes to the same time slot.

e Master Class:
o Is used only for attendance collection

o No mark is expected for the Master Class
o Has atimetable to make attendance collection possible
o lIs associated with CTS courses/modules
e CTS courses (modules) under the Master Class
o Is used only for collecting marks and not for attendance

o No timetable (= floater class) and no attendance is collected for it

Create CTS classes (individual courses/modules)

Go to File -> School Setup -> Classes. Add your CTS courses/modules (e.g. FAB1010) to the Classes File using the
Add button. Set them up as floaters as shown below:

ijtlasses
Clagzz Starting D ate

LCourse Code: Sectior: Mumber of Seatz: [ 20 F -
|FAB1D1D — 1 1=l c1c 30 |/ ==l Select the CTS course code (e.g.

ST =] =] Lredit ¥ alue: 1.00 Clazz Ending Dafe
Class Teacher i Y FAB1010) and set the Class Teacher

Syt —— Multiple Fooms: r —
I.’-‘«udlakiak, M alapa bz <= Bioom Number: I ﬂ
Additional Teacher:
INDl a$_si - j Hepotable v [” Special Schedule
d Calculate minutes from period times W Edi
Type of Courge: —l
Minutes/Day: | ]
IF!eguIar j inutes/0ay
Defiven: Select Semester/Term pattern (class
ISemester course for credit j duration), for example “Senior
-4 High/Semester 1”
— Grouped Classes Language
INone Selected j Select | |7|English vl
o
— Schedule: //
Semester/T erm / Periodlz) ;l
Set Pattern Set Fattern Set the Day/Period pattern as
1 ||Senior High = || Semester 1 i j Floater <€ _: ¥ “Floater/Floater”
Feport Cardl Exam | Add | ] I Cancel |

I [NS

Repeat this until all the CTS courses/modules have been added to the Classes File. It does not yet matter which
students take which ones as long as they are all there.
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Create the CTS Master Class - Important update August 2017!

Go to File -> School Setup -> Classes. Below is an example Master Class called CONOOO1. As you can see, it has
been timetabled since it will be used for attendance collection purposes.

Check Reportable for the Master Class.

Click the CTS button to start adding CTS courses/modules to it

In the CTS Classes dialog that opens, check Master Class

Select the included CTS courses/modules by clicking the appropriate classes in the list
Click OK when done.

vk wnN e

cl x
[Iclasses X __—— Click the CTS button to

start including CTS

LCourze Code:

con ] ithe

35 | eacher:

Section: Number of 5 Clazs Starting Date

|- B crcedtvaie: [oo0 08/18/2017 |21~

Multiple Rooms: [ Clasz Ending Date master the class

|Disen. Bl Tl BoomMumber [116 <] | [m/10/2018 [&]~
Additional Teacher:

Feportable  [w
i - - Mak re Reportable i
|N0lt assigned J Calculate minutes from period times W  cpec € sure Repo table is
Dreliven: Pecis checked

inutes/Day: 1]
|Semester course for credit J e

courses/modules in the

Grouped Claszes Language
The Master Class has been

- English -
fo e = % — | fully timetabled as it
S chedule: / fulhvtime

Semester/Term | Day/Period il
Set | Pattem Set Pattern
1 |High Schonl v |[Sem 1 5163 ~r|cTs1G3 =+
Report Card M&am | Code Detalz | 0]4 | Cancel | Under Report Card/ no
S —— .
| — Terms or Topics should
be entered!!
[ assign Class Terms and Topics - CON 1a x|
Tems Tapics
Tem [weigh | Topic [weight |

No Terms or Topics

m \ should exist for CTS
\ Masters. If there are

existing Terms, click

-—

41

Edit, use the Unselect

All button to remove
il and apply by clicking

Edit Edit
Done

[11/08/2017 [04:53 PM

A

78



Setting Up SIS for the Current School Year | Set up CTS Classes Using a Master Class
When you click on the CTS button, you will see this dialog:

BlcTS Classes | Check the Master Class
¥ Master Class <€ checkbox to indicate that this is
CT5 Modules a Master Class
COM31050 -
COM3IT15a _I
COM3115R
CONDOD1b Ot
COMO00Z0 Select CTS courses/modules for the
COMO003a o
CON1010y Master Class by clicking on them. Select
CN1D1 D E the ones that apply. This is done to
|‘E|;|r:.111j <€— associate the CTS modules with the CTS
Elfl N11 5;:|_|i:. Master.
CON1140a =l
0k I Cancel |

Assign students to the CTS courses/modules

Now you just need to give the CTS classes and the Master Classes to the appropriate students.

Go to Students -> Edit Timetables -> Assign Timetables by Group. Select Alphabetically as the Assignment
Order. Highlight the class you want to assign students to by clicking it on the right. Click OK.

ﬂnssign Student Timetable - This Year E3 |
—hizg rder — Clazzes

v Alphabetically

A\

COM31150 2 production 2 - Multi-select both the CTS
COMO001a Constiuction shop grade é

COMOOD b Constuction shop grade T Master and the CTS
CONOO0Za Constuction shop grade—! .
CONOD0ZE Construction shop grade modules by CTRL+clicking
COMO003a Constuction shop grade
COM10100 Construction tools & mate on the rows. You may

EDN'ID'I Dz Conztruction tools & mate have to scroll up or down
a Praduct management / P
n to find them.

" Homeroom

" Defined character
£ Inguiry List

" Ezxcursion List

= In a specific class

— AEzir o ——
< * Add Classes to Timetable
I ——

" Delete Claszes from Timstable

_|_|_|r111 30b 5
LOMT140a [
COM1140b Turming operations
COM1160a Manufactured materialz _I

" Replace Timetable

[~ Exclude Concurrent Studemts

Once ready, click OK
v Check prerequisite courses — | ’

[ Adjust Student Fees For &dd/Drop Courses

Cancel |

| 03:57 PM

OvR | 07304205

In the next screen, select By Group. Click Add to add the students to the list who are taking the class. Once you
have added all the students, click OK to assign the class to them.
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ﬂSEIected Method - Alphabetically
C ByRange  © ByGioup < Select By Group
r List of Student:

Akavak-flaherty, Jordon
Barkley, Shannon
Chislett, Marcus

Add students that are taking the
class by clicking the Add button and
searching form them individually

Click OK when ready to assign the class

1 to these students

/’
oK (Eancel |

To make sure the timetable changes show up immediately on the connectEd (teacher) side, run Correlate
Database: File -> Maintenance -> Topic-Based Marks -> Correlate Database!

6.9 Correlate Database

Every time changes have been made to the Classes File, which we worked on in the previous section, the
database needs to be correlated using File -> Maintenance -> Topic-Based Marks -> Correlate Database.
Otherwise the changes made on the admin side will not become immediately visible in teachers’ connectEd Web
portal. Running Correlate Database ensures that the teachers see in connectEd what the admins are seeing in
the remote desktop.

If you ever find that teachers are seeing one things and you are seeing another, then it is an indication that
Correlate Database must be run. Run it from File -> Maintenance -> Topic-Based Marks -> Correlate Database.

6.10 Verify Work

Once you have finished assigning students to homerooms and classes, you should print out homeroom, class
lists and timetables for students so that you can verify students are in the correct homerooms and classes. You
can find all basic report options under Students -> Print Lists. Detailed instructions on how to produce these
reports can be found in section 9 Reports.
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7 Attendance

Attendance is collected in SIS on a daily basis. Both the office and the teachers play a role in the daily attendance

routine and have their tasks. It is important to adhere to the daily routine. Backfilling attendance for days in the

past when attendance collection was missed is always more tedious than doing it on the day of.

7.1 Daily Attendance Routine

7.1.1

Elementary schools

In elementary schools (schools that do not offer high school grades), the attendance routine is simpler. There is

no need to initialize attendance or to print the Report of Classes Missed. All the office needs to do is change the

System Date on a daily basis. Teachers have the ability to enter excuse reasons for students directly in

connectEd. This is not the case for secondary schools.

Daily attendance routine in elementary schools (* denotes a mandatory step):

# | Task Menu item Explanation

1 | Change Date*: File, Change the system date to current date
Change Date

2 | Excursion Lists Attendance, Set attendance for groups of students, even the
Enter Attendance, whole school, at once. Example: school closures
Excursions due to weather or breakdown.

3 | Enter Homeroom Attendance | Attendance, Set attendance for students in a specific
Enter Attendance, homeroom (AM or PM); monitor if teachers
Homeroom Attendance have collected their attendance for the day

4 | Print Today’s Absentees Attendance, Print a report of students who were absent from

Print Today’s Absentees

school for the AM, PM or both.

Step one should be done first thing in the morning to allow teachers to enter attendance.
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71.2 K-12 and Secondary Schools

In schools that offer grades 10-12, the daily attendance routine is as follows.

While Step 3 — Input Excused Absences is not mandatory, it should be used as often as possible when the
parents have provided an excuse reason for an absence for a student. Otherwise the student’s absences is a
truancy.

Daily attendance routine in K-12 and secondary schools (* denotes a mandatory step):

# | Task Menu item Explanation

1 | Change Date*: File, Change the system date to current date
Change Date

2 Initialize Attendance* Attendance, Initialize attendance collection for the day
Enter Attendance,
Initialize Today’s Attendance

3 | Input Excused Absences Attendance, Input excused absences - IMPORTANT
Enter Attendance,
Excused Before Homeroom

4 | Excursion Lists Attendance, Set attendance for groups of students, even
Enter Attendance, the whole school, at once. Example: school
Excursions closures due to weather or breakdown.

5 Enter Class Attendance Attendance, View or set attendance for students in a
Enter Attendance, specific class; monitor if teachers have
Class Attendance collected their attendance for the day

6 | Print Report of Classes Attendance, Lock attendance for the day and print a

Missed* Print Report of Classes Missed report of attendance for the whole school
for the day

Step 6 may be done first thing in the morning to lock down previous day’s attendance, followed immediately by
Steps 1 and 2. This method allows teachers enter their attendance until midnight every day. This is the
recommended method.

Step 5 is only necessary if teachers are not entering attendance themselves directly into the Maplewood via
Maplewood connectEd (example, when a substitute teacher is taking attendance). However, you can also use it
to monitor if teachers have been taking their attendance today.

7.2 Modify Past Attendance

721 Elementary Schools

In elementary and middle schools attendance can be entered for past dates by teachers by using the date picker
in the attendance entry screen. However, staff are strongly encouraged to ensure their attendance is completed
each day. The date picker in connectEd is illustrated below:
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Homeroom: 4 28

Attendance Taken:
Marning:

Boudreau. Rene

Selected Date: 09/06/2010 L
Administration Date: Mond: E El

Linal Day)

Sun Mon Tuwe Wed Thu Fri Sat

3 =] 7 8 )

Absent/Absent

. 12 13 14 15 16 17
Afternoan: 13 20 21 22 23 24
26 27 28 29 320
Student Current (AM/PT) Morning Afternoon
Bird. Angelina Late/Present [ (&

=]
=

[
=

Buzit. Tiffany General/Present

The office can also enter past attendance. Select Attendance -> Enter Attendance -> Edit Student’s Attendance.
The following screen opens up:

ﬂSelect Student By Partial Surname E

Partial Mame
I

Student

Status Home School

< Mone >

Enter a few letters from the student’s last name and his/her name will show up in the search results. Double-
click the student’s name. Next, the calendar screen opens up. Select the past date by double-clicking the
desired date.

ﬂnttendance Register: Aupilardjuk, Sasha {Sasha) [_ 0]

August September October Mowember Legend
Sun Mon Tus Wed Thu Fri Sat |Sun Mon Tue Wed Thu Fri Sat |Sun Mon Tue Wed Thu Fri Sat |Sun Mon Tue wed Thu Fri Gat
12 3 4 1 12 3 % 5 © 12 3
5 6 7 8 3 f fi|? 3 & 5 & 7 &|[7 & 3 @ f @ G|+ 5 6 7 8 3 0 Excused
SIS I N T T = SO S IRE - - Ot R - W e
G fEMaz 23 ozt 5|6 WOl B 20 2 x| 2z 224 3/ 2 o | B o2 A 22 2 o
i 27 28 28 W B oio24 5 26 27 28 oo | 2@ o@m H 526 & 28 28 a0 Dther ]
December January Febiuary March
¢ Sun Man Tue wed Thu Fri Sat

Sun Mon Tue Wed Thu Fri Sat [Sun Mon Tug Wed Thu Fri Sat |Sun Mon Tue wed Thu Fri Sat
1 40 1

2o 4 85 e 7 e fe 7o 8 0N o= 4 & & 7 & 5[ 4 B & 7T o8 9

I - I S T T - - O TV I T T S T U | O FI < LS - B

O 18 W8 20 2 e o0 20 22 23 24 25 25|17 8B 19 20 2 22 @01 B W o0 A 2@ o

- T - I B = R ] 2428 M 27 28 428 27 o8 oW
03

Ll (GE June July

Sun Mon Tue Wed Thu Fri Sat [Sun Mon Tue Wed Thu Fri Sat [Sun Mon Tue Wed Thu Fri Sat |Sun Mon fus wed Tho Fi Gat

2 3 4 5 § 1 2 3 4 1 12 3 4 5 B

To& 8 won o2 op|co o6& Fo8 3 W 0| 3 4 & B T S F o8& 3 WA B

RS | |- T T | T R I T L T - T I | N~ < O C S L L - S A T 1]

EE- e L B
25 23 30

RERE -3 I - B
26 27 28 29 30 A

€ 17 1’8 1@ 20 2 2
23 24 25 26 27 28 29

21 2 oz 24 2/ o 7
28 29 ;0 3

Edit

I Done I

OvR [8/27/2m2 [17:20 AW

Hotes Summary |

Print

hllendance information for current year (click on month kitle to expand]

Set the attendance by clicking on the row and using the dropdown to select the appropriate attendance code:
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December

Sun Mon Tue Wed Thu

2 3 4 8 B
I |1 | B O
LI A - - i 1]
25 2627

Moming
Afternoon

April

Sun Mon Tue Wed Thu
2 3 4

T8 3 W of
AET R P )
21 22 22 24 5
252 0

C Compassion

E Excursion

a2 x 22 23 24
25 27 28 23 W H

Sul
|L|st|ng of attendance
i

—_—
LERER R L T A

F Fam. trip

G Grant day

H Health

L Late

| Done I

Frritit

0 On land

= _|DVF! |8£31£2D12 |DB:15F’M

Once done setting the attendance, click OK to accept the changes and Done on the Calendar window if you are

done with the student.

722 K-12 and Secondary Schools

Schools using the period-by-period attendance (high schools and K-12 schools) cannot change past attendance
days through connectEd. Instead, past attendance must be edited by using the Display/Modify Register function

in the admin system.

If no attendance is collected, every student will be set by the system to be Present. Therefore, there is no need to
go back and do past attendance for students who were present; it is only necessary to go back and correct
attendance for students who were absent (truant or excused).

Select Attendance -> Display/Modify Register. You will get the Select Students by Partial Surname screen:

ﬂ Select Student By Partial Surname

Partial M ame:

|

x|

Student | Statug

| Home 5 chool |

Aipellee, Boyd

AIFELLEE. JOSEPH [Joseph)
Aipelles, Nora

Aipellee, Qaluraut Jr Kevin Pitsiulag
Aipellee, Tristan

Aipellie, 5arapy

Amarualik., Darlene
Angnetziak, S ammy
Angutikjuak, Jaow

Apak, dlizon

Apak, Alonzo

Apak, Angus

Apak, Arlene

Anak Rertha

Print |

Method | ok |

Cancel

=
|

Enter a letter or two from the student’s last name and his/her name will show up in the search results. Select a
student to work with by either double clicking on the student or highlighting and clicking the OK button.
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If you wish to do a more advanced search, click the Method button. This lets you choose a particular pre-filtered
set of students. For example, if you select Class List, you will get a screen which displays all the classes available
in the school. Choose a class from the list to see only the students from that class.

After double-clicking on a student, he student’s attendance register opens:

| Senardary nittardarce - Bl jsk, Sanka |Sasaa)

Camnr . 50l Doz b e
Moy, Augscl 7, AN
Foes of Rpzha #

T #l ey Huosmad

Tagew | b

I Hest sy et
LCala Pavad * Fexz2 e 3 Panad d Fomc 5
| | Ceomts | e | e v | T ]

To make changes to the student’s past or future attendance, it is best to use the Calendar button. Detailed
instructions can be found in section 3.8.1 Edit Student Attendance Register.

If you want to assign a certain attendance code for a range of dates, use the Add button. Detailed instructions
can be found in section 3.8.1 Edit Student Attendance Register.

7.3 School-Wide Closures

This section explains how to deal with attendance on days when the whole school is closed due to bad weather,
mechanical breakdown or other reason. There are two different methods depending on whether the closure if
for a full day or just half-a-day: full day closures are handled through the Calendar. Half day closures are dealt
with using Excursions.

7.3.1 Full-day Closures

Go to File -> School Setup -> Calendar -> Edit. Select (click) the affected date and it will turn blue. Then click the
Grant Day button at the bottom. Grant Day is used for unexpected school closures. It reduces the students’
possible days of attendance.

The system will ask if you want to reassign the cycle days since you are skipping a day due to school closure.
Select “No” if you want to just skip the cycle day. Select “Yes” if you want to re-assign the cycle day of the
affected date to the following day (and all consecutive days will be bumped up as well).

In the picture below, November 20 is selected. Once you click some other date, you will see that the affected
date has turned green.
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ﬂﬁchuul Calendar 2012-2013 - Qitiglig School | x| |

File Edit Help

July 2012

August 2012

September 2012

October 2012 =

Zum | Mon| Tue |'w'ed| Thu | Fri | Zat | Zum | Mon| Tue |Wed| Thu | Fri | Zat | Sum | Mon| Tue | w'ed| Thu | Fri | 2at | Sum | Mon| Tue |Wed| Thu | Fri | Zat
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22|23 |24 | 25|26 | 27| 25 | 1@ |20 21|22 |25 |24 | 25 |16 | 1T (15 (13 (20| 21 | 22 | 21 |22 |23 |24 | 25 | 26 27
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25 | 26 | 2T | 26 | 23 | S0 25 | 24 27T |25 | 23 | 27 | 26 | 23 | 30 | H 24 | 25 | 26 | 2T | 23
I ) |
March 2013 Apnl 20013 May 2013 June 2013
Zum | Mon| Tue |'w'ed| Thu | Fri | Zat | Zum | Mon| Tue |Wed| Thu | Fri | Zat | Sum | Mon| Tue | w'ed| Thu | Fri | 2at | Sum | Mon| Tue |Wed| Thu | Fri | Zat
1 2 H 2 3 4 5 & 1 2 3 4 1
3 4 5 ] T G a T G a 10 1 12 13 5 B T G a 10 1 2 3 4 5 ] T G
W12 15| 4| 15| e [ 4 |15 16 T | 15 | 13 20|12 | 13 | 14 | 15 | 16 | AT 15 3|10 1|12 |13 (14 15
T |13 |13 |20 21 (22| 25 | 21 [ 22 | 25 | 24 | 25 | 26 | 27 | 13 m 21 |22 |23 | 24 ) 25 | 16 | 1f | 15 [ 13 [ 20 | 21 22
24 | 25 | 26 | 27 | 23 00| 25 [ 23 | 30 26| 27| 25 | 29 | 30 | H 23 [ 24 | 25 | 26 | 27 | 25 | 23
31 a0 hd
Huoliday Exam Special | Grant Dray Board Remove | Optiohz. .. | Dione |

| 112002012 [ 10:03 A

7.3.2 Half-Day closures in Elementary Schools

Example situation: the whole school is closed for the morning due to a blizzard.

Go to Attendance -> Enter Attendance -> Excursions.

Choose the All Students tab, check off the box for Morning and use the G: Grant Day attendance code (used for
unexpected school closures; reduces the students’ possible days of attendance). Enable Change All: it changes
the attendance for all the students regardless of what may have been previously entered in the attendance.
Check off Apply attendance note to excursion if you want to specify a note to each student’s records.

If you are setting the attendance for a day in the past, use the Attendance Date field in the bottom to define the

day

Hit Start when you are ready to apply the changes.
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Frar: ID‘I.-"DS.-"2D‘I4 E:l Today |T0: ID‘I.-"DS.-"2D‘I4 E:l Today |

Excursion List Al Students | ﬁradel ﬂomerooml Defined Eharacterl Inguiry ListI Iransportationl

Canfirmation
Morning ' Change al
2 IG: Girant day j  No previous entries
Afternoon " Conlfirmn previous entries
r IA: Ahzent j " Confim all

¥ Apply attendance note to excursion

Aftendance Date Start [one

Altendance Naote
Starm Closure]

7.3.3 Half-Day Closures in Secondary Schools

Go to Attendance -> Enter Attendance -> Excursions.

Choose the All Students tab; check off the boxes for the morning periods (in this case 1-4) and use the G: Grant
Day attendance code (used for unexpected school closures; reduces the students’ possible days of attendance).
Enable Change All. It changes the attendance for all the students regardless of what may have been previously
entered in the attendance. Select Override teacher entries. Check off Apply attendance note to excursion if you
want to specify a note to each student’s records.

If you are setting the attendance for a day in the past, use the Another Date option at the top to pick another
day than today.
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[ )Excursions x|
v Today's Attendance ( Another Date ||:|E|,.J|:|'| 2014 l;' ~| Tor |EI'EI.-"EI'I.-"2EI'I4 l%' =

Excursion List &l Students l ﬁradel ﬂu:umeru:u:um] Defined Eharacter] Elass] [rguiry Listl Tranzpartatian

Confirmnatian

|I3: Grant day ﬂ {* Change all
[ Perl | PerB
v Per? [ Per?
v Perd [ PerB
[v Perd
[ Perh

" Mo previous entries
(" Confirm previous entries
" Confirm all

[w Oyerride teacher entries

v Apply attendance note to excurzion

Stark Done

Attendance Maote

& chool clozed in the momming due to blizzard. -S|

7.4 Attendance Reports

There are three main attendance reports available in SIS: the Individual Attendance Register, the Monthly
Attendance Register and the Principal’s Monthly Attendance Report. This section explains how to produce
them.

74.1 Individual Attendance Register

1. Open Student Records, search for the student and open his/her record [print ndividual Attendance - |0 x|

FBeport Type

2. Go to the Attendance tab P

3. Click on Print Register
o, o . . Fieport Parameters

4. Select Presence as a % of possible days option to produce a report with

attendance rateS as pel’centages [ Include Code Summary

[ Include Address Information

5. Select Include Legend to add the attendance codes to the report | Iehe fendanee Nates

6. Click View and the report will be generated. See below a sample report and

[ Exclude emergency notes

an explanation of the report information. it fermam e 5

Girid Line Size: 1 j

@ Brint | Done |
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Below is an annotated sample attendance report. Monthly Accumulated
attendance attendance
percentage (%) percentage
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0220 7.._”._._& Wa Th Fr 5s Su|Mo Tu Wa Th Fr Ss Su|Mo Tu We Th Fr Sa Su|Mo Tw We Th Fr Sa Su|Wo Tu We Th Fr Ba Su [amfpm tol  acc tot%e] |acc Jamfpr fof acc

Ll — BTt Bl 20 2 03 24 25 2B |27 28 29 30 31
August K fh h h h K h h |lh h h h h b h |k h h & h h . oo oM i 100°% |100%4 00 0 o
08 10 1T T2 73 T8 15 7 TE T I 2T 22 23 (24 25 6 27 18 29 30
Geplember |, v o vt vt o TN on o oz |odimddez 6 s
01 02 03 0 0s 0 13 14 22 4 30 3
QOctober 1, { o) I I ‘Am. 5 5 & o) A U LA 23 2w 2t [ses|foan |sn & 12
072 03 D4 Q5 06 ng 10 11 [12 17 T 16 1B CREE] 7% 27 28 29 30
Mavemoer _.‘N,_e . Iq% /ﬂ,m ho. JP AL ¢ . . LvoA 10 wie agz  |orw||asw fas 7 oas
03 4 05 0§ 07 0A 09 [0 11 12 14 W15 16 (17 18 19\ 20 21 22 2 |24 25 2 27 28 29 A0
Dacamber |, ,Nc . w /» / AL _._/r AL * MT_ h b h _.w/+ . % a7 7wns 1077 | 50% | |eew |2 & 25
0 02 03 D4 O5 DB 08 09 0 11 14 15 18 §7 18 189 un_.____u._ 22 73 M 25 a7 |4 30 3
varuery ::h:..ﬂ?rﬁ/. ﬂ E/ .._H._,___;uﬁ::%. E.v@/w.ﬁ e Y | EE
01 02 0= |04 05 DE 0oz 09 1M 12 131 15 16 17 |Y&@ 19 20 201 22 23 R4 |25 26 2B
February \ bo* ot Di i M / L. /mq £ o y_u B b b * %_L_ N/ o 1n3 ranog fozs|feex jam & 38
or 02 03 fo4|os o8 o7loe oo o [11 12 13 14his 16 17 |18 19 20 21 22 23 24N2s 26 27 2e M@ 30
[Merch \ AT T .__..'—.__n Lf .__}./_Lm?d uA Aogr A .).___uf_L—... T LA A A T ﬁ b b b % T BT BWME BF_JH”—mmH B2% |43 742
) 01 D2f03 04 D5 O6 OF jOB P2 10 11 213 ._nd__._m 168 17 18 W9 20 1 |22 B3 24 25 36 27 28 an L
.b.ﬁ__.__ h 3\—_ h B " R H_ AL F\ " r_._n A /L L .’ - " L LA L e ot ? /u.i INT 23w B2% | |a2% | TE 15 &7
01 02 03 04 05 o6 &7 08 03 1 11 12 |13 14 15 16 I¥ 1B 19 |20 2| 22 23 24 25 26 |27 2§ 29 30 3
[May L. . Hrc. rﬁ., . yci}r:r/+ = h o Aflmw v o EM/E.__.E V/wéﬁma_mm i | faan Jom 17 74
EEEE%EEE__Ma:_ma_«/a.mg / / / V/
____ .J_ ____ ..._. 0 ./“m._,._um 100 j83% § 00 0 /4
I Late in the Not registered (*), Late in the Present all Qﬁ‘_ is
morning, Absent [the weekend in morning, Present indicated by a dot
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7.4.2 Monthly Attendance Register

The Monthly Attendance Register can be printed to view the attendance of a number of students at a time for a
given month. It can be produced for a grade, homeroom, inquiry list, and so forth — even the whole school at

once.
1. Go to Attendance -> Print Attendance Registers -> Monthly Attendance Register
2. Select Presence as a % of possible days option to produce a report with attendance rates as percentages
3. Select the Month from the dropdown
4. Check the box for Include Legend
5. Under Select Order, select one of the options such as Grade if you want to see a report for a specific grade
6. Click View to move to the step where you pick the grade(s)
7. In Select Method screen, check Individual if you want to produce a report of a single grade (otherwise leave it
unchecked)
[ Print Monthly Attendance Register =] =] [Jselected Method - By Grade x|
Additional Information Select Order [ Individual
= _eiphabetoal e
@ence az a 4 af pns@ @ | [ Fist [ This year only (not returning)
Report Parameters FIEITETEE
- " Defined Character Last in list ‘which Grade

(¢ This year's Grade

~ -
Irguairy List ~| ¥ Last " Mext year's Grade

(" Ewcursion List —

First Afternoon Period: 5 |

< Wi ) Print | Select | Dione
I

e
[[nclude a legend of special codes on report

8. Pick the grade(s) from the dropdown(s) and click OK!

See previous page on how to interpret the report.

7.4.3 Principal’s Monthly Attendance Report

The Maplewood system features a custom Nunavut-style Principal’s Monthly Attendance Report that the DEAs
and Superintendents are familiar with from before. The report summarizes attendance by grade (page 1 of the
report) and, as a new feature, identifies non-attenders (a student who has been Truant for at least 60 % of the
possible periods during the report month) on page 2 of the report.

1. Go to Attendance -> Print Attendance Registers -> Principal’s Monthly Attendance Report
2. Select the Month from the dropdown and click View to produce the report
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Page 1 of the report shows the attendance summary while page two lists individual non-attenders that month:
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Page 1: Attendance Summary
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8 Terms and Topics

8.1 Introduction

This section explains the concept of Terms and Topics and offers basic rules for determining how to select and
assign them for a class in the Classes File. This task is important as each Class in the Classes File must be
associated with certain Terms and Topics in order for marking to be possible

In a nutshell:

e Term refers to reporting terms

e Topic is a placeholder for a mark. Different Topics will be used based on what kinds of marks are expected:
letter grades only, percentage marks only, letter grades or percentage marks, etc.

e Each class needs to know what reporting terms (Terms) apply to it and what kinds of marks are expected
(Topics)

e All Classes must have Terms and Topics assigned to them in order for teacher to put in marks

The report card relies on the exact same rules as presented here to retrieve and display the right mark in the
right places.

8.2 Understanding Terms

Terms refer to reporting terms. Each class in the Classes File needs to know what reporting terms are applicable
to it.

8.21 Terms in Elementary (K-6) Grades

In elementary (K-6) schools, all classes are typically year-long and there are three reporting terms per year.
Therefore, all three elementary terms must be assigned to all classes. Let’s use a grade three English class

3000ELAa as an example: ) o
Elementary ter?dentlflers in Maplewood

Assign

—

- = - ———

7 \
Elementary Term 1{ TERM 1 (ELEM) !

3000ELAa — English Grade 3 . Elementary Term 2, TERM 2 (ELEM)
1

Elementary Term 3: TERM 3 (ELEM)
\

1
I
I
T
I
I
1

8.2.2 Terms in Junior High (7-9) Grades

In junior high, all classes are typically year-long and there are three reporting terms per year (just like K-6).
Therefore, all three elementary terms are assigned to all classes. However, some schools run their junior high
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grades exactly the same way as senior high grades. If that is the case, then use term assighment designed for

senior high grades.

Elementary term Identifiers in Maplewood

Assign

- -

Y \
Elementary Term 1 TERM 1 (ELEM) !
1

7000ELAa — English Grade 7

_ Elementary Term 2! TERM 2 (ELEM) |
1 I

1 T
Elementary Term 3: TERM 3 (ELEM) :

— <

8.2.3 Terms in Senior High (10-12) Grades

In senior high school, there are classes that span the first semester, second semester or full year. Semestered

high schools typically have four reporting terms per year: two reporting terms per semester.

The following secondary school terms are available in Maplewood:

Term name

Term identifier

Description

Secondary Term 1

First (SEC)

The first reporting term, typically ending half
way through semester one.

Secondary Term 2

Second (SEC)

The second reporting term, typically ending at
the end of semester one.

Secondary Term 3

Third (SEC)

The third reporting term, typically ending half
way through semester two.

Secondary Term 4

Fourth (SEC)

The fourth reporting term, typically ending at the
end of the year.

Semester
one terms

Full
Year
Terms

Semester
two terms

Based on the above table, use the following term assignment depending on the duration of the senior high class:

ELA1104a
Semester 1

ELA2104b
Semester 2

FNA1400c
Full Year
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8.3 Understanding Topics

Topic is where you put the mark, be it a letter grade or a percentage mark; it is the placeholder for the mark
provided by teacher for a class. A Topic must be assigned to each class so that a mark can be entered. The Topic
cannot be selected randomly. A class needs to be tied to the correct Topic for marking so that the report card is
able to select and display the mark correctly. Furthermore, each Topic allows for different kind of mark entry
style: letter grades, percentage grades, or both at the same time.

The tables below identify which Topic should be assigned to which class and what the mark entry is for each

topic.

8.3.1 Grade K-6 Topics

The K-6 Topics allow letter grade entry only.

Topic Name

Grade K-6 Subject

Mark Entry

Aulajaaqtut (K-6)

Aulajaaqtut

Letter grade only

Baking (K-6)

Baking

Letter grade only

Computer Science (K-6)

Computer Science

Letter grade only

Cooking (K-6)

Cooking

Letter grade only

Cultural Arts (K-6)

Cultural Arts/Nunavut Culture Studies

Letter grade only

Drama (K-6) Drama Letter grade only

English and Language Arts (K-6) English and Language Arts/English Second Letter grade only
Language

Fine Arts (K-6) Fine Arts Letter grade only

French (K-6)

French/French Second Language

Letter grade only

Health (K-6)

Health

Letter grade only

Home Economics (K-6)

Home Economics

Letter grade only

Inuktitut (K-6)

Inuktitut/Inuktitut Second Language

Letter grade only

Inuktitut Guided Reading (K-6)

Inuktitut Guided Reading

Letter grade only

Inuinnaqtun (K-6)

Inuinnagtun/Inuinnaqtun Second Language

Letter grade only

Mathematics (K-6)

Mathematics

Letter grade only

Music (K-6)

Music

Letter grade only

Physical Education (K-6)

Physical Education

Letter grade only

Science (K-6)

Science

Letter grade only

Sewing (K-6)

Sewing

Letter grade only

Social Studies (K-6)

Social Studies

Letter grade only

Woodshop (K-6)

Woodshop

Letter grade only
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8.3.2 Grade 7-9 Topics

The 7-9 Topics allow both letter grade entry and percentage mark entry.

NOTE: if you are running your junior high school/middle school exactly the same way as your high school, then

use the same Topic assighment as high school (Mark topic only).

Topic Name

Grade 7-9 Subject

Mark Entry

Aulajaaqtut (7-9)

Aulajaaqtut

Letter grade OR percentage

Baking (7-9)

Baking

Letter grade OR percentage

Computer Science (7-9)

Computer Science

Letter grade OR percentage

Cooking (7-9)

Cooking

Letter grade OR percentage

Cultural Arts (7-9)

Cultural Arts

Letter grade OR percentage

English and Language Arts/English Second

Letter grade OR percentage

English and Language Arts (7-9) Language

Fine Arts (7-9) Fine Arts Letter grade OR percentage
French (7-9) French Letter grade OR percentage
Health (7-9) Health Letter grade OR percentage
Inuktitut (7-9) Inuktitut Letter grade OR percentage
Inuinnaqtun (7-9) Inuinnaqgtun Letter grade OR percentage

Mathematics (7-9)

Mathematics

Letter grade OR percentage

Physical Education (7-9)

Physical Education

Letter grade OR percentage

Science (7-9)

Science

Letter grade OR percentage

Sewing (7-9)

Sewing

Letter grade OR percentage

Social Studies (7-9)

Social Studies

Letter grade OR percentage

Woodshop (7-9)

Woodshop

Letter grade OR percentage

8.3.3 Grade 10-12 Topics

In grades 10-12 there is only one topic, Mark. The only exception is grade 12 Social Studies which also has a

Project topic. The Mark and Project topics allow percentage marks only.

Topic Name Grade 10-12 course Mark Entry
Mark ALL SENIOR HIGH COURSES IN GRADES 10-12 Percentage mark only
Project NSS3001 and NSS3002 — Nunavut grade 12 Social Studies Percentage mark only

-NSS3001 and NSS3002 get both Mark and Project topics
-the weight for Mark topic should be set to 70
-the weight for Project topic should be set to 30
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9 Reports

SIS can produce reports on nearly any information on students as long as it has first been entered into the
system. There are several built-in reports that can be produced with a few clicks but the system also features
custom reports that can be tailored to most needs. This section explains the use of the most common built-in
reports available through the menus.

9.1 Print an Alphabetical List of Students
1. Go to Students -> Print Lists -> Alphabetic List of Students.

2. The Filter tab lets you choose which students to print on the report. By default, every student is included. If
you want to select fewer students, uncheck the First in list or Last in list checkboxes and select the first and/or

the last student by clicking the Select button and searching for a particular student.

B|miphabetic hst of students [ x]

Uncheck First in list or Last in list if
; ; ] you want to change the default of
Stalwln Aaglak, Eienda F [istines LR ] printing every student in the school.

Endwih  Ullespak. Sam F Lot e sams—| Use Select button to select the new
first and/or last student in the list.

Inchads studen:s mgisised
I Dot this and res: pea

'Fln] Henelumal:l Sderd n‘an:ﬁc-nl fch e I Eml Fm:sl

¥ Triz et only ol medurring]
[ Mo veor andy

3. Go to the Student Information tab and uncheck Student name only if you want to print more information on
the report. For example, you may want to include Gender and Date of birth on the report. There are many other

options.
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ﬂnlphahetic list of students B3

Filter I Mame formats  Student information | Achievement I Bus I Fonts I

Uncheck Student Name Only on
the Student Information tab

[T Student name only

Enrolment

: ; & [~ Fulltime/Part-time
¥ Date of birth < |
™ Homeraom Check boxes for Gender and Date
I Mumber [ alberta Student Num, of birth (for example) to include
I Designation that information in the report
= Teacher
o | r—— Check any other boxes as you
| = will.
[ Telephone number —wiork numbers
[ Addess I Father
[ Grade [~ Mother
[ Ireurancs number I™" Guardian
[ Student picture — Lacker

. ™ Locker Number
Defined characters I™ Tupe Of Locker
’]_ 1Mz s 4 ™ Laocker Bark

™ Lock Serial Mumber
[~ Student letters as barcode W e
IEode 3of3 j [ Lock Brand

Frint | e | Done I

4. Go to the Fonts tab to fine-tune the look of the report. You may want to resize the font sizes on the report to
make everything fit better on the page: click Header/Footer and select font Arial size 10. Do the same for Title,
Student name and Student info. Also, check Left justify student information to make everything fit better.

Al Bst of studenis
Ficer | Flare lomae] Shadert idomascn] acheoznzn | Bus Fooie |
Forie sebsrdmd
Hachin s | [1ED
~aial
o | Use the buttons to change the
B fonts for these to Arial, 10pt.
Shudenl nae
sncempra | [
Selecting Left justify student
Lz iaate | T Cor sl Bos sreacine: information will typically
T Mipessing spsem - . )
¢ brin, e W Lak il shderk rdoinasion condense horizontal spacing on
£ Moo st TR the report

5. Click View when ready to view the report. If you need to adjust it, close the report, make your changes in the
tabs and click View again. You can print the report when you are happy with it. Or save the report as a PDF.

9.1.1 Save the report as a PDF

If you cannot print the report directly to a printer from your Remote Desktop session, you can save it as a PDF
and copy to your local computer, then print it to a printer. Or perhaps all you need is a PDF.

1. When the report is open, click the little arrow next to Print and select Save to PDF. Save on the PDF on the
Desktop using an intuitive filename such as “Alphabetical List of Students.PDF”.
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@ -
Prink Exit

Prink

Current Page

Armnaguag School

2. Close the report and minimize all other windows so that you can see the Desktop (the remote desktop).

3. Right click the PDF you just saved and select Copy (or use CTRL+C).

4. Minimize or move the remote desktop window so that you can see your own computer’s Desktop (= the local
desktop). Right-click the local desktop and select Paste to copy the PDF to your own computer (or use CTRL + V).
Please note that pasting will not work on Macs but will work on Windows machines.

9.2 Print Homerooms Lists
Print lists of students in different Homerooms.
1. Go to Students -> Print Lists -> Homeroom lists.

2. The Filter tab lets you choose which homerooms to print on the report. By default, every homeroom is
included. However, if you want to select fewer homerooms, uncheck the First in list or Last in list checkbox and
use the dropdown menus to select the new start and end values. You can also check Individual homeroom list if
you want to print students in only one homeroom.
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ﬂHomeroom lists

Filker I Warme: formats' Student informationl Achievementl Bus' Fonts'

I Individual homercom list

Start with: IB, igk K-P 1

j v First in list

End with: IN. Trernblay 4/

[~ Sort students by grade
[T Double spaced

ﬂ ¥ Last in list
Sort by

£ Boom number

" Designation
" Teacher

* Student information
" Attendance enty grid
" Mark entry arid

tdonth: ISeptember 'l
Mumber of mark s I 1o

3. Go to the Student Information tab and uncheck Student name only if you want to print more information on
the report. For example, you may want to include Gender and Date of birth on the report. There are many other

options.

ﬂﬁlphahetic list of students

[ Student name
— Personal

¥ Date of birth

I~ Homeroam

I~ | Diesignation
I~ Tieacher

[ Telephaone numnber
[ Addess

[ Grade

[ Insurance rumber
[T Student picture

Faormat: IMr.John Sty 'l

Enralment

[~ Fulktime/Part-time
[ Date of entry

[ Accumulated credits
[T Alberta Student Mum,

—Wwark numbers
[ Father

[ Mother
[ Guardian

r— Locker

Defined characters
lrl_ 102 Mz T4

[ Locker Murber
[T Type OF Locker
[” Locker Bank

™ Lock Serial Mumber

ormats  Student information | Achievement I Bus I Fonts I

[ Student letters as barcode B Candiaian
[code3erg =l [ Lok Brand
Frint | Wiew | Done I

Uncheck First in list or Last in list if you
want to change the default of printing every
homeroom in the school. Use the dropdown
menus to select the new star and end
homerooms for the report.

[

Check Individual homeroom list if
you want to print a list of students
in a single homeroom. Select the
homeroom using the first dropdown
mentl.

4. Go to the Fonts tab to fine-tune the look of the report. You may want to resize the font sizes on the report to
make everything fit better on the page: click Header/Footer and select font Arial size 10. Do the same for Title,
Student name and Student info. Also, check Left justify student information to make things even more
compact.
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Alphabieii el of studenis

Fiser | Mae o] Stgentmiomnascal aoh cene | B Fooie |

Foris zele=riad

Faial

Heend i 7wz bt

~iial
Tik: Use the buttons to change the

Erai fonts for these to Arial, 10pt.
Shudent pane

e | 7
Selecting Left justify student
Lz icate il =TT S——— information will typically
T Mipessing spsem =L L ) )
 ddrin sy W Lak sty sludent ioimaton condense horizontal spacing on
 Nong ™ I e pnen the report

5. Click View when ready to view the report. If you need to adjust it, close the report, make your changes in the
tabs and click View again. You can print the report when you are happy with it. You can also save the report as a
PDF following the instructions provided earlier in this section.

9.3 Print Class Lists
Print lists of students in specific classes such as “Mathematics Grade 4” or “Aulajaaqtut 12”.
1. Go to Students -> Print Lists -> Class Lists

2. The Filter tab lets you choose which classes to print on the report. By default, every class is included.
However, if you want to select fewer classes, uncheck the First in list or Last in list checkbox and select the new
values using the dropdown menus.

ﬂtlass lists [ %]
Mame formatsl Student informationl Achievementl Busl Fontsl
I Individual class list Uncheck First in list or Last in list if
Start with: [Blick Bela (] ELAK b | [ Fiatin fist you want to change the default of
Sl | R o N printing every class offered in the
nd with: | Tremblay, Maomi v P
S W' Lastinlist _ school. Use the dropdown menus to
1 Fint Sation [ Class Filer select new start and end values
— Sort by Fattern: I Section: IAn-"' vl :
" Class ' Teacher N
O iod in day " Specific pattern
{+ Student information Tem:
" Attendance entry grid Month: IAUQUSt 'l Day:
" Mark entry grid Mumber of marks: I 1a Period: N~
Check Individual class list if you
[~ Include Deleted Students \ . . Y .
want to print a list of students in a
[ Diouble spaced .
- specific class only (such as ELA20-
¥ Include class schedule in tille . .
2). Select the class using the first
[~ Page break between clazses dropdown menu.
Grouped Classe:
[ Print Grouped Classes Together
[ Al Students Alphabetically
FErint Wiew [one
|
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3. Go to the Student Information tab and uncheck Student name only if you want to print more information on
the report. For example, you may want to include Gender and Date of birth on the report. There are many other

options.

ﬂﬁlphahetic list of students

mnats  Student information | Achievement I Bus I Fonts I

Enralment

[~ Fulktime/Part-time
[ Date of entry

™ Accumulated credits
™ Alberta Student Mum.

¥ Date of birth

I Homeroom

I~ | Diesignation
I~ Tieacher
Faormat: IMr.John Smith Vl
[ Telephaone numnber —Wwark numbers
[ Addess I Father
[ Grade [ Mother

[ Insurance rumber I Guardian

[ Student picturs — Locker
™ Locker Nurber

"Qefined characters—‘ ™ Type Of Locker
FTire Ms 4 [” Locker Bank
™ Lock Serial Mumber

[ Student letters as barcode B Candiraian
[code3erg =l [ LockBrand

Frint | Wiew | Done I

4. Go to the Fonts tab to fine-tune the look of the report. You may want to resize the font sizes on the report to
make everything fit better on the page: click Header/Footer and select font Arial size 10. Do the same for Title,
Student name and Student info. Also, check Left justify student information to make things even more

compact.
Algrvabic i Bsi of siudienis
Ficer | Flare lomae] Shadert idomascn] acheoznzn | Bus Fooie |
Forie sebsrdmd
HachinFcmaa | [ 1ED
~aial
Tik: Use the buttons to change the
Bl fonts for these to Arial, 10pt.
Shusdank nae
sncempra | [
Selecting Left justify student
La ot [l T ——— information will typically
T Mipessing spsem . . .
¢ brin, e W Lak iy sludant rloinatizn condense horizontal spacing on
£ Moo st TR the report

5. Click View when ready to view the report. If you need to adjust it, close the report, make your changes in the
tabs and click View again. You can print the report when you are happy with it. You can also save the report as a

PDF following the instructions provided earlier in this section.
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9.4 Print Student Timetables

Print student timetables to see what classes they have been assigned to and what their daily timetables look
like. This report is not very useful for elementary schools as in most cases timetables are not inputted into
Maplewood. This report will be more useful for high school grades.

1. Go to Students -> Print Timetables
2. If printing Semester 1 timetables, select Semester: 1 from the dropdown

=2 . Select the Semester for
n Print Timetables ﬂ | which you want to print the
. _ timetables
Print Optionz:
Sgmester: jv Selup < ] Click on Setup to set print
options
Select Order
(* Alphabetically
Grade
Huomeroom
Clazz

Defined Character
[ ruguiry List

E mzurzion List

i i T R i

Advizor Group

Wie Print | Dane |

[Select options far printing

3. Click Setup button to set printing options. In the Print Options, it is good to at least check the box for Print
Gridlines. You can check other boxes if desired.

ﬂ Print Options ﬂ
) i| Student Information ]
School Mame Font Semesters
Fant Arial f* Print Down
" Print Across
Header Font . .
- v Incl Class Title Qrientation
Font Arial & With Class @ Forralt
" In Legend " Landscape
Info Font
Fant Arial [ Bfint Course Mumber [ Pies to print
D e Enter. |1
Eoater Font i id L
B Pint Gird Lines [~ Print Homeroom
Font Pritt Period Timess _
[w Print Teacher Mame s e 1 :I
School Motice [~ Break on Semester Start Time 245 Abd
| [~ Print Adds and Drope | EndTime 930 Ak

Ok | Cancel |
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While in Print Options, go to Student Information tab. Check the boxes for Grade and Homeroom if you wish to
see those in the timetable printouts. Other options are available as well. Once ready, click OK to approve the
print options.

ﬂ Print Options x|

Optiorns  Student Infarmation

Surname with 1D. Murnbers
* Given name [~ Alberta Student Mum.
" Uszual name [ Student Munber

[ Studert Letters

Perzonal

Locker

[~ Locker Mumber
[~ Locker Bank.
[ LockerType

[ Designation [~ Serial Mumber

[ Teacher [~ Lock Combination
[ Advizor Group [ Lock Brand

™

I~

[ Telephone nurmber

>

4. Back in the Print Timetables dialog, select the way you want to print the timetables. Pick Grade if you want to
print them by grade. Use another Select Order option as desired, such as Homeroom. Then click View.

[ YPrint Timetables x|
Print Options:
Semester: |1 - Setup
Select Order

Huomeroom

Defined Character
[ guiiry List

~
(s
=
(" Clasz
~
~
(" Excursion List
~

Advizar Group

C_yew D pin [[ ome |
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5. In the next step, pick the grade(s). If you want to print timetables for one grade only, first check the Individual
box at the top, then select the grade from the dropdown menu. Uncheck the box for Deleted as you probably do
not want to see timetables for Deleted/Withdrawn students. Click OK.

ﬂ Selected Method - By Grade x|

[v  Individual

[nzlude students registered
[v Both thiz and nest year
B | | First W This vear only (ot returming)
B d

YWhich Grade
f* Thiz pear's Grade

12 | ™ " Mest pear's Grade
Corl

6. The result should look something like below. The document below has 25 pages for 25 students. Print the
document using the Print button or click the little down-arrow next to Print to save it as a PDF for your records.

[ print Preview =10] x|
1725 4 M &R . # = o)
ek Last L00m Seatch Ptink Exit
v -

Attagoyuk lllisavik
Alpaisuk, Maind= zrade: 8

Cray 1 Cray 2 Cray3 Cray g Cayhs Cray G
Semester 1
Period
1 ATTAMZ ATTAMZE ATTAME 2 ATTAME ATTAME a ATTAMZ

Attendance AM | Atendance AWM | Attendance AM | Atendance AW | Attendance A | Adtendance A

. Douffett hl. Drufiett . Dourffett . Druffett hl. D uffett . Duffett

126 125 135 125 126 126
2
2
]
4 ATTFPMZa ATTRMZa ATTRMZ 2 ATTPMEa ATTPME 3 ATTF iZa

Attendance PME | Atendance P2 | Aftendance P2 | Attendance P2 | Attendance PMS | Attendance P2

. Duffett hl. Druffett M. Drurffett . Druffett hl. Duffett M. Duffett

126 125 125 125 125 126
G

=i
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9.5 Print Student Marks (Topic-Based Report)
Produce a report that shows marks given by teachers to a selection of classes. It will be a useful report any time

of the year but especially during report card time.

Note: this report will also indicate if Terms and Topics have not been assigned. Terms and Topics are typically
assigned by the Department of Education. Please contact SIS Coordinators regarding missing terms and topics.

1. Go to Students -> Print Lists -> Topic-Based Reports

2. In Topic-Based Reports screen, use the following settings to view ALL classes and ALL terms: check First in List
and Last in list to include each and every class. Check boxes for all Terms. Also check the box for Include Weight.

ﬂ Topic-Based Reports

=101 x|

Check boxes for First in

Select HomeroomsClasses

Filtgr

" Homerooms

Fritit M ethod
¥ Claze Summary

list and Last in list if you
want to include all

(" Claszes Terms and Topics classes taught in your
Stark With: [~ Individual Homeroom : SC_hOOI_- Alternatively,
|?DDDEL.& a | Esiit v First [SEC) click Filter button to
v Second [SEC) narrow down the
End “ith: v Third (SEC] selection. See next page.
[55T3154 2 [V Lastin list
- Terks Always check all boxes
Options : here!
[ Dne Student Per Page _
r w| Project
w| Prov. Exam , .
w| English and Language Atz [K-E] It's always a good "dea to
v Englizh and Language Artz [7-9) check Include Weight as
v| French [K-B] hd| it provides information
on how term marks are
Select All UnSelect Al

Inchude Deleted Students

-
-
-
-
[ Include decimals at the Term level
-
-
v

Include Final Term

b aplewood MNumber

[~

" Markbook Summary

Termn:
| [

Topic:

| []

weighted into the Final
Mark.

Daone

Click View to generate
the report.

The report should look like this. The sample report below has 41 pages.
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9.6 Print Validation Statements

Schools with secondary grades can print Validation Statements to assess how the students are progressing
towards graduation and what areas still remain incomplete in order to obtain a grade 12 diploma in Nunavut.
Most often Validation Statements are produced by grade.

1. Go to Marks -> Print Transcripts. Select Validation Statement. Click View/Print.
2. In the next screen, select By Grade.

[ settings x| [ print Transcripts %]
Tranzcript Settings
Frint Order
Dateoflssue:  |IE/23/2014 [3]+ " Alphabetically

('“

0

i v i

(" By Homeroom
& Do .
ourss Hista " By Defined Characters
Grades

~
~

[ Limit Courses by Grade By [rgquiry List

XX

Lowest Grade: ]v E_lrl Advizar GTDUI:I
-

- Highest Grade:
Mode
(" (* Prirt Credit Granted f* Current Students
Printer Settings (" Pazt Students

™ Include Students “ith Empty Transcripts
[ Include Barner

% D oo

Print offsets (330 = 1/4 inch) —_—

Top of page: 0 Left edge of page: 0 |

< Wiew £ Print > [one |

To print Validation Statements for a single grade at once, select Individual and pick the grade from the
dropdown menu. Unselect Deleted to exclude Validation Statements for deleted/withdrawn students. Click OK.

ﬂ Selected Method - By Grade |
v [ndividual
First in list Include students registered
v Bath this and nest year
' [ First [w Thiz vear only [not returning]
v _Idest uear only
[ Deleted
Which Grade

1z = o This year's Grade

" Mext year's Grade
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9.7 Print Report Cards

Report cards can be printed both from the admin system and from the connectEd side. This section explains how
to produce from the admin side.

1. Go to Marks -> Print Report Cards -> Report Builder for Report Cards.
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2. In the Report Builder, select All Student Reports from the left to see what report cards are available to your

school. Select the desired report card from the list of available report cards:

W Repeort Dubder MEE
Fit Ell Ve =
+
Student Bepurts - All Beporis Click on Elementary
AT EESE] ) ndividusl Reports (Term x) for grade K-6
- Hlarre Do ipt on Les: Mocisd  Crested On Qs Sesllsble  Tychem Pesor: report cards.
Fezort Corcs v Diapepinry Tamm Lalres o Clevertay (Temn 10 o 2 o o
Tostig Crop e . - y—— 2
Fookdm Vawres (Toemn 10 30 Pidchs Fars (Term 1 Tnust s - o
o = : lick on Middle Year:
e Ragi ot on For, Shudert Reg siration Tam vl £f2L(2012 b LI P peonl e o Click o ddle Years
(Term x) for grade 7-9
report cards.
Click on the combined
Cambined Reports report Secondary
Hharie Lemaichcn Last Mpdted  reateccm Daaner dwalble  SvdeqmRepact (Term X) for senior-
A Scondary 1 Concary [Ta P2 e el Vi
B Secondary [Tem 4 Su-. [acoencory o hiUERPs B secondary report cards.
(It combines pages 1

Explanations of different report cards (for Term 1):

and 2 of the report.)

Card name Grades Intended use

Elementary (Term 1) K-6 Elementary school report card for Term 1

Middle Years (Term 1) | 7-9 Middle school/junior high school report card for Term 1
Secondary (Term 1) 10-12 Senior high school report card for the first semester (fall semester)

After selecting the desired card from the list, press on the the blue Play button at the top to run the selected

report.
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% Report Builder =] |

File:

=+

Edit  Wiew

pd

[

~

Student Reports - All Reports

Student Reports

Individual Reports

Report Cards Marne Description
Middle Years (Term 13
Secondary (Firsk) P1

Secondary (Firsk) P2

Secondary (First) P1
Secondary (First) P2

Combined Reports
Marne

3 Secondary (Firsk)

Descripkion

Secondary (Firsk)

Press the blue Play
button to run the
selected report.

Middle Years (Term 1)
card has been selected

Last Modifi miner  Availal
10f29/2012  7{31/2012 i
10/29/2012  F/31/2012 v
i0jz9iz012  7fs1jzo1z vl

Last Modified  Created On Ownar
10fzaf2012  10j290z012

7

Availsble  System Report

4. In the next screen, set the Report Date the way you want it to appear on the report card.

Sradend equn i Ciikein

Fazor: Farawima

B by

Set the Report Date as

N\

Srowm: Do LLMGECE -

[Tk A AT A Ve

BT s o shlvrdow G "
e ey -

w’ T “war iy —= - =
i 1A il —amon Feco
[ whaz LRt EP e T
o

o S ke sz Cresll 2o e [AEEE e

you want it to appear on
the report card.

5. To see a list of students for whom the card will be printed, click the Show Students button. The list will show

at the bottom:

@Student Report Criteria [<]

Repart Parameters

Enable Page Padding

Report Date; 10/30j2012 - | Termish  Term 1 {ELEM) {Bf27/2012 - 12/7(2012) -

Click the Show
Students button to see

Tnclude Students Student Selection Criteria Sy
= WisYemandit Add Criterion Grade i
W/ This Vear Only o Age
Delete Criterion Homeream A4
Next ear Only Reset Criteria Homeroom Teacher
Deleted
Past
H e
i Hide Students <<«
3 <SS
Student List
Surname Given Name: Grade Status =
v Adion Darnielle 12 Thiz Vear and Mext
Adin Gustin 10 This Vear and Next
adion Regan 1 This Vear and st
Adion iyt 10 This Vear and Next
Aggark. Hyles 11 This Vear and Mest -

who you are printing
for.
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6. To only print students for a single grade (recommended) click on Add Criterion, select Personal Details on the

left and pick Student is in grade ...

@lstudent Report Criteria

Repart Parameters

Report Date: 10/30j2012 ~ | Termis):  Term L {ELEM) {8(27/2012 - 12/7(2012)

Tnclude Students Student Selection Criteria
R This Vear and Next
W/ This Vear Only

Next ear Only

Deleted

Past.

i Hide Students <<<

Student List
Surname Given Name:
b Adion
adion
Adin
Adjun

Darielle 12
Gustin 10
Regan 11
ryatt 10

Aggark. Fyles 11

Add Crierion < d
age
v

Reset Criteria

Enable Page Padding

Sork Order

3

Homeroom
Homeroom Teacher

Run Report Cancel

Status <
This Vear and Mext
This Vear and hext
This Vear and Mext
This Vear and hext
This Vear and Next -

ﬂndd Student Selection Criterion

Alphabetic

-

Click the Add Criterion
button to narrow down
the list of students for
whom the report card will
be printed, for example
grade seven students
only.

On the left sidebar, select

Student is in grade: g
Skudent o
‘ @) Personal Details " ol
~

! Student Mumber
Homeroar

) Class

! Excursion List

! Advisory Group

! Inguiry Lisk

Personal Details...

...and then select the desired
grade here.

To accept, click OK.

x €

AT

7. Finally, to produce the report cards, click Run Report. Wait for the report to generate:

promtvopess |
m Heport Generated

e =

B

e s e
b M e (e 1
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accrdary (Tw) P, ren
Conrdroed Brpuats
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Sevordary
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¥ood on L Tew
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L MO | Croaied O Ot Avshiho Systen Regx
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9. The report should show up looking like this (this example is for a junior high report card):
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10. To save the report as a PDF for printing to a printer, click the green icon at the top and select PDF File. Save
the PDF on the Desktop. After that, you can close the Report Builder and open the PDF file from the Desktop in

Adobe Reader and print it off.
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